Ethernet Products
Intel® Ethernet products and technologies
Announcements
The Intel sign-in experience is changing in February to support enhanced security controls. If you sign in, click here for more information.
4178 Discussions

Intel Network I225-V Nework issue persist even after FW upgrade

KT_Customs
Novice
82,729 Views

Hello,

I have a question about Intel network I225-V. My ASUS Maximus XII Extreme suffer with this issue - https://wccftech.com/intel-foxville-i225-v-2-5gbe-networking-issues-persist-z490-motherboards-affect... like there mentioned.

But when Intel planning to Supply the manufactures of the newest revision B3 of I225-V NIC on Z490 boards? Because mine is B2 revision and I have this issue when I turn on the PC or restart the PC. And it is very annoying when you playing games and streaming that the network connection will drop. This issue is happening intermittently also when playing games. And this is not all, my network speed drops to half when the connection is dropped and the renewed.

So on my side I have tested all things to get this work without issues. 

So I have tested the Firmware update on ASUS page for I225-V.

Intel(R) Gigabit Ethernet Driver V1.0.1.4 for Windows 10 64-bit.
Before installing Intel I225-V driver v.1.0.1.4, please ensure that Intel I225-V firmware should be updated to v.1.45 via firmware update tool. After finishing necessary firmware update, please shut down and unplug the power cord then reboot the system normally. For more information, please refer to the firmware update guide.

Everything was success, the FW is actual, but...

And the issue still persist. I have tested the oldest and newest drivers of I225-V and nothing. So, when we can expect the B3 revision on Z490 Boards with I225-V? 

Thank you for your support.

136 Replies
n1kobg
Novice
6,297 Views

@VipeNess I read everything on internet, not just this forum, including your links & the "FIX".
I also read the Intel® Ethernet Controller I225 Specification Update, Revision 1.2. 

Intel talk about reducing the speed while I see my uploads are increasing above 100mbps on my 100/50mbps connection. Its the opposite of what Intel say they observed.

Also that "driver version NVM version 1.38 or later can detect when the IPG packet drops occur and will automatically reset the link speed to 1Gpbs". Setting to 1Gpbs doesnt work for me.

Refunding means I wont have PC for up to a month. 

Talamar1
Beginner
5,473 Views

Same issue on an Asus Z490-E.  Out of the box with Windows drivers, updated to Intel drivers/NVM, downgraded to Asus drivers/NVM.  Still have the same issues.  Slow performance and, while playing games, network disconnects.  Cannot reset the port, when you try to shutdown you get BSOD and it says a device had an invalid power state.

Majek
Novice
7,459 Views

I bought Z490 Aorus Master in June 2020 with the hope of upgrading 10900k to Rocket Lake. I wanted one of the 'higher-end' boards. And now it turns out that my board does not even have the 'B2' revision of the I225v controller. I have the buggiest chip and no software/firmware solution will fix this.

I am really bummed to have bought a board that is faulty. I did upgrade the firmware to 1.45 and at least I am no longer losing the connection after reboot but downgrading the advertised 2.5 Gbps to 1 Gbps is not really a solution.  Gigabyte and Intel advertised it to support 2.5 GbE.

I'd RMA my board but what are the chances I still get the B1 or B2 revision?

Let's keep this thread open and hope for some updates.

JT-Low-See
Novice
7,438 Views

hey guys,

Fresh/new install of Win10 with the Intel Network Adapter Drivers v25.6 appears to have fixed this issue for me: https://downloadcenter.intel.com/download/25016/Ethernet-Intel-Network-Adapter-Driver-for-Windows-10

Note: I had already updated the NIC firmware to 1.45 from my previous efforts, so probably do that if you havent already prior to wiping Windows and doing the fresh install.

Long version of the story:

So I hadn't yet shipped back my Asus ROG Strix z490-H board with the i225-v ethernet onboard, and today I had some extra time so I decided to set 'er back up in my case but this time with a spare SSD and a fresh install of Win10 x64 Pro (previously I had just swapped the MOBO, CPU & RAM into my existing setup, hoping Win10 would be good with it, and installed the drivers from Asus). After the install as soon as it hit the desktop it popped up a prompt to install Armory Crate (Asus' wrapper for installing all their bloat ware which is loaded directly onto the board for an "easy" install). The first/last time I tried this I went with it not knowing of this issue with the Intel i225-V NIC, but this time I cancelled it and instead installed a copy of the 25.6 Intel driver from USB. I also installed the Intel "chipset-10.1.18383.8213-public-mup" drivers to get all the drivers for the "unknown devices" showing in device manager. I didnt install any of Asus' versions of drivers this time. 

I'm happy to report that web browsing and downloading feels snappier than before and better yet, didnt experience any dropped connections/LAN adapter resets like before. Optimistically, I fired up Battlefield 4 that was crapping out within seconds of launching into an online game previously, and I was able to play through 2 games of about 40 minutes each without any disconnects. I still did see the warning icons for dropped packets several times that i never used to get on my old Gigabyte Z68/1Gb Realtek NIC, but I was also seeing those on the TUF z490-gaming board with a 1Gb i219-V that I bought to replace this ROG Strix/i225-V board with.

I'm going to keep testing, but wanted to share my results with you guys after taking this to the extreme of a complete OS reinstall and direct install of the Intel OEM drivers....Will let you know results tomorrow after some more testing.

OlegD
Novice
7,430 Views
Try to upload files to other PC in LAN over the i225-v. Big upload traffic will crush your connection until power off/on.
JT-Low-See
Novice
7,425 Views

Yea, confirmed. Trying to copy a file to another PC over my 1Gbps LAN is horrific: 5-7MB/sec max. I guess I was just happy to not get any LAN disconnects like I was before...pretty sad to be considering this an improvement over what I was getting before I reloaded Win10. Go from a 10 year old 1Gbps NIC to a cutting edge 2.5Gbps, and see a drop of upload throughput of ~80+%...nicely done Intel!

Copying data (downloading) from LAN is decent ~50MB/sec. But uploading to other PC on LAN is abysmal.

Attached image #1 is copying from LAN to local, image #2 is uploading from local to LAN.

JT-Low-See
Novice
7,360 Views

Alright, what gives....I picked up a TPLINK 1Gbps PCIe NIC and still the download speed over LAN is horrible (3-8MB/sec). Uploading to another PC on my LAN is normal, around 90MB/sec. When I move a file the opposite way from the other PC back to this PC i get ~90MB/sec, so I know my environment is capable of handling that speed end to end. I even disabled the Intel i225-V onboard NIC in the BIOS, and then fully powered off the PC for a minute to be safe...

How can there be something more to this motherboard that still cannot handle uploading a file at any decent speed...do I need to fully re-load Win10 with the intel i225-V disabled in BIOS...?

JT-Low-See
Novice
7,335 Views

Well another update on this. Did some more testing and discovered that the slow LAN upload issue was is actually something going on with my home server. I have several 7200RPM 2TB drives in RAID5 and then an SSD boot/OS drive in it. When writing to any of the shares on the RAID the throughput speed starts at about 80-90MB/sec then within a couple seconds drops to 3-10MB/sec for the duration of the copy. 

However if I write to the SSD on that server I get sustained 70-90MB/sec throughput. I've written several files to confirm it's consistent.

I assumed this was an issue with the intel i225-V but then saw the same behavior on this 1GBe Realtek NIC...so at this point i'm giving the i225-V a clean bill of health, at least in my environment. I knew in the back of my mind I should do a fresh OS install with a new MOBO, CPU & RAM, but tried to take the lazy route.

Those of you with issues still with your i225-V dropping connections/resetting and slow upload performance - have you gone as far as to reload your OS like I had to do??

Again, I updated the i225-V firmware to 1.45 prior to the reload and also used Intel's v25.6 ethernet adapter drivers, NOT the manufacture's drivers (ASUS).

n1kobg
Novice
7,297 Views

@JT-Low-See I also have bad uploads and also thought that might not be related because capping the connection improves the bufferbloat & packet loss but the connection still drops from time to time. Especially when i tweak my driver from the registry. I wanted to have an option to disable RSS for ex. which I dont have on this NIC (it also doesnt refresh/restart when changing an option but need PC restart).
I have 4 Windows installations with different Win versions. On fresh install it is more stable but when you start tweaking & changing options its pretty much the same. Default settings are trash so i have to make some changes. The firmware v1.45 is more stable but its far from a "FIX".

Znuas
Beginner
7,111 Views

Exact same issue on my new Asus ROG strix Z490-A Gaming. 

Followed instructions and press release from intel, made it a little bit better, no longer disconnects, but still have low ethernet speed. 

Average results on networktests 40.23 ms | 12 mbit/s down |16 mbit/s up

 

Plug in my old computer on the same ethernet cable, 
Average results on networktests 3.2 ms | 87 mbit/s down | 91 mbit/s up

 

I have a 100/100 connection. 

ClarenceDonath
Beginner
7,001 Views

Today's date, 2/2/2021

I've been through this thread and tested the suggestions.
My post is not a fix, but a confirmation the problem still exists.
I would very much appreciate an email when someone discovers a fix.  intel@mrdo.com

Asus ROG Maximus Extreme
BIOS v2004

Intel I225V Rev2

Asus firmware to address problem flashed -- FXVL_15F3_ASUS.bin

Intel I225-V Driver version 1.0.1.4

I have Windows 10 group policy configured to reject driver update from Windows Update.

Intermittent adapter reset persists.
Other ethernet adapter on motherboard works without an issue.

FYI, group policy summary to reject driver update...
https://www.auslogics.com/en/articles/prevent-windows-10-from-updating-specific-drivers/
Interl(R) Ethernet Controller (2) I225-V
computuer configuration -> administrative templates -> system -> device installation -> device installation restrictions ->
prevent installation of devices that match any of these device ids
device Ids..
PCI\VEN_8086&DEV_15F3&SUBSYS_87D21043&REV_02
PCI\VEN_8086&DEV_15F3&SUBSYS_87D21043
PCI\VEN_8086&DEV_15F3&CC_020000
PCI\VEN_8086&DEV_15F3&CC_0200

Firmware from Asus...
CURRENT FAMILY: 1.0.0
CONFIG VERSION: 1.14.0
BEGIN DEVICE
    DEVICENAME: NNT

    VENDOR: 8086
    DEVICE: 15F3
    SUBVENDOR: 1043
    SUBDEVICE: 87D2
    NVM IMAGE: .\FXVL_15F3_ASUS.bin
   IMAGE DOWNGRADE: TRUE
END DEVICE

KT_Customs
Novice
6,994 Views

@ClarenceDonath  when did you bought that mainboard? Today, yesterday etc..

 

Im Waiting for my Maximus XII Extreme Z490 from retailer and see, If there is new B3 revision of NIC. My mainboard will arrive on Friday.. I hope that I will have s luck to B3 revision. If not, returning the mainbord.

ClarenceDonath
Beginner
6,986 Views

Hello KT.  I received it mid-January.

KT_Customs
Novice
6,750 Views

@ClarenceDonath Hi, Today arrived my Maximus XII Extreme. I have removed the heatsink and spoke that the NIC is SLNJY which is B2/V2 revision of i225-V. So.. I'm sad about this and tommorow I'm returning the mainboard back to retailer unused.

 

It looks like we will need to wait.. or in my case buy Z590 Maximus XIII Extreme for my project.

 

I assumed I would be lucky, but unfortunately nothing again.

ClarenceDonath
Beginner
6,736 Views

@KT_Customs 

Interesting information.  I guess we cannot expect there to be recent versions of hardware in stock and get lucky to receive one randomly from stock.

Personally, had I known about this issue before-hand I would also wait for the Z590 Maximus XIII Extreme

I'm in it for the long haul -- when there is updated firmware or drivers that address the issue.

VipeNess
New Contributor I
6,723 Views

Intel has changed their page reporting that the issues were fixed back in Oct 2020 but the issue is not resolved as people are still having issues.

https://www.intel.com/content/www/us/en/support/articles/000057261/network-and-i-o/ethernet-products...

This needs to be fixed, once and for all.

criskoe
Novice
6,202 Views

@KT_Customs

Curious question.

I’ve had the MEXII since launch. And notice right out the gate the issues with the intel NIC. For a month I tried working with intel and Asus to fix the problem. Even tried replacement boards. Which was not fun as I run a full custom water loop. Multiple tear downs to change out the motherboard was not fun. And even after that, Same wonky behaviour from intel NIC. Asus would blame intel. And intel would blame Asus. Round and round I went. I literally tried everything possible. 

Anyways I gave up after wasting a month of my spare time dinking around trying to fix that peice of poop. I Disabled the intel NIC and just used the other 10gb NIC on the MEXII board and haven’t looked back or had any issues since. Everything works as should. Funny Thing is it’s been such a long time ago I actually forgot that this board has that crappy NIC on it. Lol. 

Now don’t get me wrong. I get having a defective component on something brand new sucks. I totally understand. But the 10G NIC works great. I’ve actually forgotten about the intel NIC.

Any reason you don’t just do that?

Do you need a system with two networks? Did you plan on running both LANs? 

VipeNess
New Contributor I
6,198 Views

@criskoe 

Because we already paid for it and it's broken out of box.  I bet you would take your car back if you couldn't put gas in it.  This is exactly what Intel want us to do and to buy something else and forget it.  I'm a Lion, not a sheep.

 

n1kobg
Novice
6,236 Views

Also Latency penalty. Its not big but its there, especially bad for competitive FPS gaming.

criskoe
Novice
6,211 Views

@n1kobg

You got any actual proof of said latency other then what some random might of said somewhere?

I’m not trying to argue or discredit you. I’m actually curious.

Honest question. Cause I can tell zero difference using this 10g and any other good NIC on other pcs I have and all I play is comp FPS shooters. Now I’m no shroud so yeah. But I’d willing to bet the bank that 99.99999 % of users wouldnt be able to blindfold spot which is which.

Now again I’m not telling or asking people to just use the broken NIC. This situation gave me a ton of headache and frustration. I get it. But I went through this almost a year ago. And on the MXIIE specifically that has TWO Lans. I found the 10g to work great! Other mb that don’t have this other NIC. I fully agree. **bleep**s broken and I wouldn’t keep it.

But I hate to say it. Y’all are kidding yourself if you think intel is going to do anything about now. I’m sure glad I didn’t sit around waiting for intel to actually do something about it. Cause a year would of passed and I’d still have the same problem. 

I made a choice to keep the board for other reasons and just use the marvel 10g NIC and move on with my build and life. And whata ya know. Everything been great. 

But with that said don’t for one second think that it didn’t effect my opinion of intel. Cause it did. Of the 3 other systems I built over the last year. I made absolutely sure none of them had this defective NIC on them first. 

Intel really messed this one up. And to be honest with you. I don’t know If I would even trust a reversion 3 of this garbage. 

I think the funniest part of all this is that after all this. Lots of the new z590 boards including the brand new MXIIIE are still using this broken NIC. 

n1kobg
Novice
6,121 Views

This is a known fact. Its also true for Audio. I dont need to prove anything, its up to you whether you want to believe me or not. At the same time I understand where you're coming from. These days the internet is full of misinformation and 16yold "wanna be" guru/experts.
Its true that most people wont notice any difference but that doesnt mean its not there. Although it depends on your specific connection, location, game and system whether it will affect you in real-time games or not.  Still, if you are a competitive FPS shooter gamer I would not use a 3rd party adapters.

Reply