Ethernet Products
Intel® Ethernet products and technologies
3891 Discussions

Intel X710 SR-IOV VF latency on small traffic

James_Lin
Beginner
392 Views

I using a X710-DA2  dual 10G port ,when I setup SR-IOV in Centos 7 ,I found VF is delay in response with small traffic ,ping command show like below :

PING 10.10.10.10 (10.10.10.10) 56(84) bytes of data.

From 10.10.10.20 icmp_seq=1 Destination Host Unreachable

From 10.10.10.20 icmp_seq=2 Destination Host Unreachable

From 10.10.10.20 icmp_seq=3 Destination Host Unreachable

From 10.10.10.20 icmp_seq=4 Destination Host Unreachable

64 bytes from 10.10.10.10: icmp_seq=5 ttl=64 time=2999 ms

64 bytes from 10.10.10.10: icmp_seq=6 ttl=64 time=2000 ms

64 bytes from 10.10.10.10: icmp_seq=7 ttl=64 time=1000 ms

64 bytes from 10.10.10.10: icmp_seq=8 ttl=64 time=0.320 ms

64 bytes from 10.10.10.10: icmp_seq=9 ttl=64 time=3000 ms

64 bytes from 10.10.10.10: icmp_seq=10 ttl=64 time=2000 ms

64 bytes from 10.10.10.10: icmp_seq=11 ttl=64 time=1000 ms

64 bytes from 10.10.10.10: icmp_seq=12 ttl=64 time=0.285 ms

64 bytes from 10.10.10.10: icmp_seq=13 ttl=64 time=3001 ms

64 bytes from 10.10.10.10: icmp_seq=14 ttl=64 time=2001 ms

64 bytes from 10.10.10.10: icmp_seq=15 ttl=64 time=1001 ms

64 bytes from 10.10.10.10: icmp_seq=16 ttl=64 time=0.338 ms

 

10.10.10.10 is VF address inside  Guest OS ,my i40e version in below :

filename:       /lib/modules/3.10.0-1160.15.2.el7.x86_64/updates/drivers/net/ethernet/intel/i40e/i40e.ko

version:        2.14.13

license:        GPL

description:    Intel(R) 40-10 Gigabit Ethernet Connection Network Driver

iavf :

filename:       /lib/modules/3.10.0-1160.el7.x86_64/kernel/drivers/net/ethernet/intel/iavf/iavf.ko.xz

version:        3.2.3-k

 

it is look like a slowstart behavior ,when I run ab to send more traffic to Guest ,the latency is gone . 

rx_dropped in /sys/class/net/ens4f0/device/sriov/0/stats  is 0 . 

still try to find out what happen ,it is look like some queue or cpu step-up behavior. 

I been try with difference server (HPE DL380 Gen10 and C610),the behavior is same. 

any input is welcome .many thanks .

 

Labels (1)
0 Kudos
0 Replies
Reply