Community
cancel
Showing results for 
Search instead for 
Did you mean: 
CLame
Novice
3,135 Views

Lan connection lost on I218-V when streaming

Jump to solution

Each time I'm streaming data my LAN connection disconnects and reconnects. This happens about 2 times a minute.The LAN adapter is integrated on the system board (Asus H81-Gamer). My PC is running Win8.1 64 bit. It only ocurs when streaming so I assume it has somthing to do with the load. No problems or disconnects when simply browsing the internet.

Things I have tried so far that did not resolve the issue:

- installed the latest driver from Asus for the Inel card

- Installed the latest driver from Intel for the intel card (12.12.80.19)

- Disabled all power savings options for the Lan card

- Disabled TCP chimney offload in win OS

- Disabled RSS in win OS

- Disabled Receive window autotuning in OS

- Disabled IPV6

- disabled all the above options in the advanced settings for the Lan card.

- set speed fixed to 100MB full duplex.

- updated the chipset drivers of the systemboard

I'm out of ideas. Anyone has the magic solution?

0 Kudos
1 Solution
CLame
Novice
201 Views

Hi,

It seems the issue is resolved by setting the legacy switch compatibility mode to enabled,

My pc is directly connected to a fritz box 7360. Apparently the NIC and the fritzbox do not like playing together.

View solution in original post

15 Replies
SYeo3
Valued Contributor I
201 Views

Hi Molleke,

Thank you for contacting Intel.

Here are the other advanced settings you can try:

Under Performance Options Properties -

1. Adaptive inter-frame spacing - disable

2. Interrupt moderation rate - disable

3. Receive descriptors or Receive buffers - increase the value to 1024 (Range: 128 - 2048 in increments of 64)

4. Transmit descriptors or Transmit buffers - increase the value to 1024 (Range: 128 - 16384 in increments of 64)

If you continue to encounter disconnection when streaming data. Please contact Asus* support.

Because this may be a motherboard issue and may need a software patch or BIOS update to fix the issue.

We look forward to your test results.

Sincerely,

Sandy

CLame
Novice
201 Views

Unfortunately all the other options also did not solve the issue. To make it even weirder. I can only reproduce the issue whith streaming traffic like spotify or youtube. When just downloading large files there is no issue at all. This has to be a nic driver or systemboard setting or win8 setting somewhere. I already checked my router as well. No issues there.

SYeo3
Valued Contributor I
201 Views

Hi Molleke,

Thanks for providing us the test results.

You might want to check the settings in Spotify* and Youtube* options since you are experiencing the problem only when using these applications.

I'll try to see if I can find anything on this.

CLame
Novice
202 Views

Hi,

It seems the issue is resolved by setting the legacy switch compatibility mode to enabled,

My pc is directly connected to a fritz box 7360. Apparently the NIC and the fritzbox do not like playing together.

View solution in original post

st4
New Contributor III
201 Views

Hi Molleke,

Thanks for the sharing the update. A good news indeed.

rgds,

wb

SYeo3
Valued Contributor I
201 Views

Hi Molleke,

Thanks for sharing your solution with us. Glad to know your issue is resolved!

Sincerely,

Sandy

TNore
Beginner
201 Views

thx i will try it.

I have the same problem with my asus X99-A mobo and intel lan

SYeo3
Valued Contributor I
201 Views

Hi yarled,

Thank you for posting. Hope this helps resolve your network connection problem.

Sincerely,

Sandy

TNore
Beginner
201 Views

I have try i't the setting legacy switch compatibility mode to enabled,

The results are better, but if i stream hd movies suddenly i have again the problem.

What to do!!!! I must every time restart the computer to fix the LAN problem.

SYeo3
Valued Contributor I
201 Views

Hi yarled,

Thanks for your updates.

Please provide your system setup so we may check for software or driver updates:

1. Motherboard or system model:

2. Router model:

3. Operating System:

We look forward to your reply.

Sincerely,

Sandy

TNore
Beginner
201 Views

Mobo: Asus X99-A/USB 3.1

Row: 4 - 4096 MB PC4-21300 DDR4 SDRAM Kingston KHX2666C15D4/4G

Intel(R) Core(TM) i7-5820K CPU @ 3.30GHz

MSI ATI/AMD Radeon R9 390

650W PSU

850PRO Samsung SSD

Windows 8.1 PRO

Router: Zyxel NBG6716

WIth Dlink router the same problem!

SYeo3
Valued Contributor I
201 Views

Hi yarled,

Thanks for providing your system details.

We suggest to update the drivers for your system. You may also update your router's firmware in case there are new versions available. Please refer to website below for link to download drivers of you motherboard - http://www.asus.com/us/Motherboards/X99AUSB_31/HelpDesk_Download/ http://www.asus.com/us/Motherboards/X99AUSB_31/HelpDesk_Download/

*This link will take you off of the Intel website. Intel does not control the content of the destination website.

Hope this helps.

Sincerely,

Sandy

TNore
Beginner
201 Views

That's not the solution i have done this before. I have the problem when i streaming 1080p movies.With my old pc worked it like a charme. So i have now a fast super computer and the only big problem i have is with the intel lan. Must i do something with the settings? And i see i'm not the only one with this problem.

SYeo3
Valued Contributor I
201 Views

Hi yarled,

Thanks for the updates. I'll check on this. In the meantime, you may also check with Asus* for other suggestions.

I believe you enabled the "Legacy Switch Compatibility" mode, please disable it for troubleshooting purposes.

Sincerely,

Sandy

SYeo3
Valued Contributor I
201 Views

Hi yarled,

Here are some advance configuration that you may try. This is to tune the adapter for better performance, since streaming requires higher bandwidth.

- Go to Network Connection Properties, click on Advance tab, under Performance Options

1. Increase the Transmit Descriptors buffer size 1024. The default is 256. Maximum value is 2048.

Note: Increasing Transmit Descriptors increases system memory usage.

2. Increase the Receive Descriptors buffer size 1024. The default is 256. Maximum value is 2048.

Note: Increasing Receive Descriptors increases system memory usage.

3. Reduce Interrupt Moderation Rate to Low, Minimal, or Off

For more information, please refer to our website below:

http://www.intel.com/support/network/adapter/pro100/sb/CS-029927.htm Intel javascript:;http://www.intel.com/support/network/adapter/pro100/sb/CS-029927.htm ® Desktop Adapters — Intel Ethernet Desktop Adapter Troubleshooting Guide

Under "Tuning Intel® Ethernet Adapter throughput performance"

We'll wait for your test results.

Sincerely,

Sandy

Reply