Community
cancel
Showing results for 
Search instead for 
Did you mean: 
VecteurIT
Beginner
5,064 Views

Poor performance with x722 10GB Vswitch Hyper-V Windows 2019 23.5 drivers

Hi,

We have poor performance with vswitch based on X722 :

Transfer rate Debian VM = 7.5 MiB/s

on the same server with the same VM with vswitch on I350 :

Transfer rate Debian VM = 123 MiB/s

 

0 Kudos
34 Replies
Daniel_D_Intel1
Employee
542 Views

Hello VecteurIT, Thank you for posting in Intel Ethernet Communities. Please let us know if this is a board integrated X722, or a PCIe adapter. Is the transfer rate from an iperf transfer, or is it recorded using another utility? Please provide the kernel version being used in Debian, and the output of "ethtool -i <interface>" and "ethtool <interface>". Is SR-IOV or passthrough configured on the vSwitch? From Windows Server 2019 please provide the System Support Utility. Download from the link below, and attach a log file for us to investigate this issue. Server 2019 is not included in the supported OS, but it should work if this is a Windows server with a GUI. 1- Download from https://downloadcenter.intel.com/download/25293/Intel-System-Support-Utility-for-Windows- 2- Open SSU.exe 3- Mark the box "Everything" and then click "Scan". 4- When finished scanning, click "Next". 5- Click on "Save" and attach the file to a post. Let us know if you have any other questions. Best regards, Daniel D Intel Customer Support
VecteurIT
Beginner
542 Views

 

Thank you for this quick response

I continued my test, and here's what I can say:

There is no problem if the VM is in windows 2019, or Windows 2016

 

Yesterday, I did tests with NTTTCP (sort of iperf) and here are the results:

 

Test NTTTCP VM on Vswitch 10G

 

VM Windows 2019 -> Windows 2019

Test1.png

Windows 2012R2 -> Windows 2019

test2.png

Windows 2012 -> LINUX

 

 

test3.pngWindows 2019 -> Linux

 

test4.png

 

I have try to disable PacketDirectEnabled $false, disable vRSS, disable VMQ, but no change....

 

Ethtool results:

 

2019-01-11 09_26_28-WAC - Remote Desktop Connection Manager v2.7.png2019-01-11 09_25_02-WAC - Remote Desktop Connection Manager v2.7.png

VecteurIT
Beginner
542 Views

Board are Onboard Flexible LOM X722 SFP 4 ports (Fujitsu)

VecteurIT
Beginner
542 Views

SSU.exe is not supported by the system ( Windows 2019 Core)

Daniel_D_Intel1
Employee
542 Views

Hello VecteurIT, Thank you for the reply. Is the I350 also integrated into the board, or a PCIe adapter? Please check with Fujitsu if this on board controller has a NVM update, as the firmware we have is for Intel boards. Please provide the "get-netadapter -name <interface> | format-list" and "get-netadapteradvancedproperty -name <interface>" outputs. This should provide us similar information from Windows 2019 as the SSU logs. Let us know if you have any other questions. Best regards, Daniel D Intel Customer Support
VecteurIT
Beginner
542 Views

Hi Daniel,

 

2019-01-15 09_49_40-Window.png

2019-01-15 09_50_40-Window.png

VecteurIT
Beginner
542 Views

The I350 is   also integrated into the board. All firmware are Up to date

VecteurIT
Beginner
542 Views

Today a BSOD : i have not symbols for X722

Where can i found it ?

2019-01-15 12_08_23-Window.png

Daniel_D_Intel1
Employee
542 Views

Hello VecteurIT, Thank you for the update. Please try to update your drivers to 23.5.1. This was released just after 23.5 and provides support for the X722. Let us know if this changes anything or if you have any other questions. Best regards, Daniel D Intel Customer Support
VecteurIT
Beginner
542 Views

Hi,

Driver installed. Nothing change...

 

Daniel_D_Intel1
Employee
542 Views

Hello VecteurIT, Thank you for the update. We will check on this. Please also make sure the chipset drivers are installed, as the X722 Controller relies on the Xeon scalable processor. We will update you as soon as possible if the chipset drivers do not resolve the issue. Best regards, Daniel D Intel Customer Support
VecteurIT
Beginner
542 Views

Hi Daniel,

Yes chipset drivers are installed : V 10.1.2.85

Daniel_D_Intel1
Employee
542 Views

Hello VecteurIT, Thank you for the reply. Please allow us to check on this further. Will update you as soon as possible. If you have any other questions please let us know. Best regards, Daniel D Intel Customer Support
Daniel_D_Intel1
Employee
542 Views

Hello VecteurIT, Have you tried this with other Linux distributions? Debian is not on the support list for this adapter. We would recommend CentOS, SUSE, or Ubuntu. Would you be able to check if the low throughput is persistent in one of the other Linux distributions? Best regards, Daniel D Intel Customer Support
Daniel_D_Intel1
Employee
542 Views

Hello VecteurIT, Please let us know if the results are different on other Linux distributions, as this may be isolated to Debian. If you have any other questions please let us know. Best regards, Daniel D Intel Customer Support Under contract to Intel Corporation
VecteurIT
Beginner
542 Views

Hello Daniel,

We have the same problem with RED HAT and Debian

Daniel_D_Intel1
Employee
542 Views

Hello VecteurIT, Thank you for the information. Let us further check on this. We will update you soon. Best regards, Daniel D Intel Customer Support Under contract to Intel Corporation
Daniel_D_Intel1
Employee
542 Views

Hello VecteurIT, From the Red Hat VM would you be able to provide "ethtool -k <interface>", and "ethtool -c <interface>" so we can see the interrupt moderation and offloading settings? Let us know if you have any questions. Best regards, Daniel D Intel Customer Support Under contract to Intel Corporation
Daniel_D_Intel1
Employee
542 Views

Hello VecteurIT, Please let us know if you still need assistance with this issue, or have already resolved it. It you have any questions please do not hesitate to ask. Best regards, Daniel D Intel Customer Support Under contract to Intel Corporation