Ethernet Products
Determine ramifications of Intel® Ethernet products and technologies
4875 Discussions

Two Ethernet host with same name in Yocto ? and Internet Sharing problem from laptop

VSubr2
Novice
2,292 Views

My Galileo Gen 2 is connected to my laptop ethernet and when I type ifconfig in the terminal, I am getting two ethernet host with same name (enp0s20f6) and same Hardware Address. Why there is two ethernet host when I have only one?

root@galileo:~# ifconfig

enp0s20f6 Link encap:Ethernet HWaddr 98:4F:EE:01:CC:89

UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1

RX packets:583 errors:0 dropped:0 overruns:0 frame:0

TX packets:260 errors:0 dropped:0 overruns:0 carrier:0

collisions:0 txqueuelen:1000

RX bytes:63482 (61.9 KiB) TX bytes:103044 (100.6 KiB)

Interrupt:49 Base address:0x8000

enp0s20f6:avahi Link encap:Ethernet HWaddr 98:4F:EE:01:CC:89

inet addr:169.254.9.12 Bcast:169.254.255.255 Mask:255.255.0.0

UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1

Interrupt:49 Base address:0x8000

lo Link encap:Local Loopback

inet addr:127.0.0.1 Mask:255.0.0.0

inet6 addr: ::1/128 Scope:Host

UP LOOPBACK RUNNING MTU:65536 Metric:1

RX packets:1323888 errors:0 dropped:0 overruns:0 frame:0

TX packets:1323888 errors:0 dropped:0 overruns:0 carrier:0

collisions:0 txqueuelen:0

RX bytes:101916368 (97.1 MiB) TX bytes:101916368 (97.1 MiB)

Where as when I connect the galileo to wifi router's lan, only one ethernet host is displayed:

root@galileo:~# ifconfig

enp0s20f6 Link encap:Ethernet HWaddr 98:4F:EE:01:CC:89

inet addr:192.168.1.123 Bcast:192.168.1.255 Mask:255.255.255.0

UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1

RX packets:2030 errors:0 dropped:0 overruns:0 frame:0

TX packets:2522 errors:0 dropped:0 overruns:0 carrier:0

collisions:0 txqueuelen:1000

RX bytes:289213 (282.4 KiB) TX bytes:268478 (262.1 KiB)

Interrupt:49 Base address:0x8000

lo Link encap:Local Loopback

inet addr:127.0.0.1 Mask:255.0.0.0

inet6 addr: ::1/128 Scope:Host

UP LOOPBACK RUNNING MTU:65536 Metric:1

RX packets:1966 errors:0 dropped:0 overruns:0 frame:0

TX packets:1966 errors:0 dropped:0 overruns:0 carrier:0

collisions:0 txqueuelen:0

RX bytes:207571 (202.7 KiB) TX bytes:207571 (202.7 KiB)

Now the problem is I couldn't share my laptop internet to galileo via Lan (by following this http://www.instructables.com/id/Intel-Galileo-Share-LaptopPC-WiFi-to-Galileo-over-/ instructable)

7 Replies
asss
Valued Contributor II
1,247 Views

Hi Vijayenth,

you have one physical and one logical interface. See https://en.wikipedia.org/wiki/Subinterface https://en.wikipedia.org/wiki/Subinterface

The name of subinterface/logical interface is enp0s20f6:avahi.

I guess this software is on your board: https://en.wikipedia.org/wiki/Avahi_%28software%29 Avahi (software) - Wikipedia, the free encyclopedia

BR,

xbolshe

Carlos_M_Intel
Employee
1,247 Views

Hi Vijayenth,

Are you having errors after the last step of the tutorial?

Which is the output of running uname -a?

Did you enable the sharing option on your network?

Regards,

Charlie

0 Kudos
VSubr2
Novice
1,247 Views

Hi CMata_Intel

root@galileo:~# uname -a

Linux galileo 3.8.7-yocto-standard # 1 Tue Jun 9 22:07:14 GMT 2015 i586 GNU/Linux

I enabled the internet sharing option in my laptop. I didn't get any error in the last step of the tutorial.

Result of ipconfig command in laptop:

Ethernet adapter Ethernet:

Connection-specific DNS Suffix . :

Link-local IPv6 Address . . . . . : fe80::1c93:a43b:adff:3cba%7

IPv4 Address. . . . . . . . . . . : 192.168.137.1

Subnet Mask . . . . . . . . . . . : 255.255.255.0

Default Gateway . . . . . . . . . :

Wireless LAN adapter Wi-Fi:

Connection-specific DNS Suffix . :

Link-local IPv6 Address . . . . . : fe80::146a:18cb:b116:870b%11

IPv4 Address. . . . . . . . . . . : 192.168.0.131

Subnet Mask . . . . . . . . . . . : 255.255.255.0

Default Gateway . . . . . . . . . : 192.168.0.1

Result of ifconfig in Galileo:

enp0s20f6 Link encap:Ethernet HWaddr 98:4F:EE:01:CB:58

inet addr:192.168.137.4 Bcast:192.168.137.255 Mask:255.255.255.0

inet6 addr: fe80::9a4f:eeff:fe01:cb58/64 Scope:Link

UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1

RX packets:596 errors:0 dropped:0 overruns:0 frame:0

TX packets:90 errors:0 dropped:0 overruns:0 carrier:0

collisions:0 txqueuelen:1000

RX bytes:59942 (58.5 KiB) TX bytes:17676 (17.2 KiB)

Interrupt:50

lo Link encap:Local Loopback

inet addr:127.0.0.1 Mask:255.0.0.0

inet6 addr: ::1/128 Scope:Host

UP LOOPBACK RUNNING MTU:65536 Metric:1

RX packets:2891 errors:0 dropped:0 overruns:0 frame:0

TX packets:2891 errors:0 dropped:0 overruns:0 carrier:0

collisions:0 txqueuelen:0

RX bytes:211632 (206.6 KiB) TX bytes:211632 (206.6 KiB)

Still internet connection is not working in the galileo. Any workaround to solve this problem?

0 Kudos
asss
Valued Contributor II
1,247 Views

Hi,

please provide an output of command sequence below (on Galileo board):

route

route add default gw 192.168.137.1

ping 8.8.8.8

nslookup www.intel.com

ping www.intel.com

BR,

xbolshe

0 Kudos
VSubr2
Novice
1,247 Views

Hi xbolshe

Here's the output in order:

root@galileo:~# route

Kernel IP routing table

Destination Gateway Genmask Flags Metric Ref Use Iface

default * 0.0.0.0 U 0 0 0 enp0s20f 6

192.168.137.0 * 255.255.255.0 U 0 0 0 enp0s20f 6

root@galileo:~# route add default gw 192.168.137.1

root@galileo:~# ping 8.8.8.8

PING 8.8.8.8 (8.8.8.8): 56 data bytes

64 bytes from 8.8.8.8: seq=0 ttl=56 time=19.694 ms

64 bytes from 8.8.8.8: seq=1 ttl=56 time=32.068 ms

64 bytes from 8.8.8.8: seq=2 ttl=56 time=24.971 ms

^C

--- 8.8.8.8 ping statistics ---

3 packets transmitted, 3 packets received, 0% packet loss

round-trip min/avg/max = 19.694/25.577/32.068 ms

root@galileo:~# nslookup www.intel.com

Server: 127.0.0.1

Address 1: 127.0.0.1 localhost.localdomain

nslookup: can't resolve 'www.intel.com'

root@galileo:~# ping www.intel.com

ping: bad address 'www.intel.com'

root@galileo:~# route

Kernel IP routing table

Destination Gateway Genmask Flags Metric Ref Use Iface

default Vijayenthiran.l 0.0.0.0 UG 0 0 0 enp0s20f6

default * 0.0.0.0 U 0 0 0 enp0s20f6

192.168.137.0 * 255.255.255.0 U 0 0 0 enp0s20f6

0 Kudos
asss
Valued Contributor II
1,247 Views

I guess you have fixed the problem with DNS.

FYI:

BR,

xbolshe

0 Kudos
VSubr2
Novice
1,247 Views

Hi xbolshe,

Thank you very much. My problem is fixed after doing

connmanctl config ethernet_984fee01cc89_cable --nameservers 8.8.8.8 8.8.4.4

- Vijay

0 Kudos
Reply