Community
cancel
Showing results for 
Search instead for 
Did you mean: 
rudyrednose
Beginner
3,248 Views

VLAN support broken, Windows 10 1903, ProWinx64v23.5.2 on i219-LM

Greetings, no working VLAN on just released Windows 10 v1903.

  1. Fresh full install of Win10 edu (similar to pro) v1903 on a Dell Latitude 5580 (i219-LM), after first deleting all partitions.
  2. Full cycle of Windows updates
  3. installed ProWinx64v23.5.2 drivers
  4. created a few VLANs using PowerShell with following commands :

$intelnic = Get-IntelNetAdapter

Add-IntelNetVLAN -parent $intelnic -vlanid 10

Add-IntelNetVLAN -parent $intelnic -vlanid 20

Add-IntelNetVLAN -parent $intelnic -vlanid 30

 

The VLANs do show up, but they are always disabled, nothing I can do.

 

I scrapped everything and did a fresh install of Win10 edu v1809, same exact sequence, everything works A-OK.

 

Any recommendation, beside waiting another 5-6 months for a working driver ?

 

I am a bit frustrated with this ever repeating story of new Windows-->broken Intel VLAN support...

 

Cheers.

10 Replies
EClau
Beginner
924 Views

Ran into the same issue myself after updating to 1903. This is becoming a rather bothersome issue that occurs after pretty much every major Windows update.

ŁTuro
Beginner
924 Views

Teaming is not working too - AGAIN!!!! Time to switch hardware and software too. Linux bonding and vlans is far more simple and stable.

LPong
Beginner
924 Views

Same problem here, only difference is that i have I219-V.

 

Yesterday before WIn update I mangaged to get VLAN enabled, but main adapter could not connect to network because there was no IPV4 protocol enabled inside properties. If I wanted to enable it I just get message:"your current selection will disable following feaut.: IPV4"

 

Some screens:

 

https://imgur.com/a/RXP9ce0

CrisselleF_C_Intel
Moderator
924 Views

Hello rudyrednose,

 

Thank you for posting in Intel Ethernet Communities. 

 

Support for Microsoft Windows* 10, Version 1903 (19H1) & Microsoft* Windows Server* 2019, Version 1903 (19H1) will be available in SW Release 24.1.

 

SW Release 24.1 will support Microsoft Windows* 10, Version 1903 & Microsoft* Windows Server* 2019, Version 1903 and also include fixes for issues some customers were experiencing with Team and VLAN configuration using PowerShell. 

 

SW Release 24.1 is expected in June of 2019. 

 

Important Note: Prior to the release of SW 24.1, we will be releasing SW 24.0. Please be aware that 24.0 does not support Microsoft Windows* 10, Version 1903 or Microsoft* Windows Server* 2019, Version 1903. Support for Microsoft Windows* 10, Version 1903 & Microsoft* Windows Server* 2019, Version 1903 will be in release 24.1

 

The Intel Ethernet team is responsible for validating and submitting new driver packages to Microsoft for inclusion on Windows Update. Microsoft does not support Team and VLAN configuration on Window 10. Team and VLAN configuration for Intel Ethernet Adapters on Windows 10 is supported via our Intel® PROSet software. Intel® PROSet is not included on Microsoft Windows Update.

 

Please let us know if you have additional questions.

 

Best regards,

Crisselle C

Intel Customer Support

Under Contract to Intel Corporation

rudyrednose
Beginner
924 Views

Thank you CrisselleC, good news.

CrisselleF_C_Intel
Moderator
924 Views

Hello rudyrednose,

 

You are welcome. If you have additional question and clarifications, please do not hesitate to ask.

 

Best regards,

Crisselle C

Intel Customer Support

Under Contract to Intel Corporation

jsali12
Novice
924 Views

i have a question. why cant Intel have these drivers sorted in ready to go when Microsoft push out these updates i dont get why a company as huge as Intel cant be ready with the fix ahead of time when Microsoft has betas out for these updates months ahead of time. smaller companies then Intel can have drivers ready to go for prime time so people dont have to deal with these failures every 6 months Intel should be able to do the same.

JSmit179
Beginner
924 Views

Computer is new i7-8086k + Gigabyte Z370 + i350 4 port Intel card.

I use LACP TEAM with a D-Link switch 4 to 4 ethernet cables. Worked great for a year.

 

My windows (already 1809) totally crashed after the last cumulative update for 1809 and after reboot I got the blue screen "CRITICAL PROCESS DIED". Initially I suspected RAM, power supply and all other components. After windows 10 pro clean installation on the spare SSD it only works with DELL drivers and I can't use Team #0 because it is grayed out. I can create LACP team, no problem but the team can't be used.

There is also a problem with any single port of i350. When nothing is configured and ports are in a default LAN state the transmission is choppy, computer looks like stuttering when I transfer through i350. Onboard LAN works normally and a cheap add-on pcie lan card also works good.

I tested all drivers available.

VLAN and Teaming Tabs are only visible on Dell drivers 18.5.0 and 18.8.0 with different or corresponding bios.

No VLAN and Teaming tabs on Intel's generic drivers.

Something is messed up.

VincentT_Intel
Moderator
924 Views

Hi rudyrednose,

 

Please be informed the SW 24.1 is already available in Download Center, for additional details, kindly visit this thread.

 

Let us know if it fixes your VLAN issue.

 

 

Best Regards,

 

Vince T.

Intel Customer Support

A Contingent Worker at Intel

 

 

CrisselleF_C_Intel
Moderator
924 Views

Hello rudyrednose,

 

We'd like to check if you were able to test our latest driver and didn't encounter any issues?

 

We look forward to hear from you.

 

Best Regards,

Crisselle C. 

Intel Customer Support

A Contingent Worker at Intel

Reply