Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
229 Views

What can I do?

I have an Intel® Ethernet Connection I219-V adapter. And I can't use the full speed of my internet what my provider provides me (120 Mbps), because I can only select 100 Mbps speed in the setting of my adapter. But if I choose the gigabit full duplex option I can't acces the internet. And also my cable is a gigabit one and it's fine.

 

My driver version 12.18.8.9 (2018. 06. 12.)

 

PS: I have measured 120 Mbps on this current setup about 2 years ago.

And on wifi with my mobile connected I can measure 120 Mpbs

0 Kudos
5 Replies
Highlighted
17 Views

Hello No00pe,

 

Thank you for posting in Intel Ethernet Communities. 

 

Kindly provide the following details as this would help us in checking your query.

1.) Brand and model of your system.

2.) What is the Operating System used?

3.) Based on the SSU log you have provided, the driver version installed on your system is 12.18.8.9. Have you tried updating the driver to its latest generic driver version(12.18.9.10) from SW24.2?

4.) Have you tried to test another system to further isolate the issue?

5.) Have you tried to select Auto Negotiation on Speed and Duplex Advanced property of the adapter?

 

Looking forward to your response.

 

Best regards,

Crisselle C

Intel Customer Support

A Contingent Worker at Intel

0 Kudos
Highlighted
Beginner
17 Views

Hi CrisselleC, Thank you for replying my question. I have an Asrock z270 pro4 motherboard with intel i5 7600k processor. I'm currently using a Windows 10 Pro (64 bit) I've tried updating the driver but when I looked up for new verion it said the drive is up to date. I've tried Linux SystemRescueCD but I couldn't manage to run a speedtest because the systems browser can't support JavaScript. This Linux system is only bootable into memory. When I try to set the speed on the adapter to Auto Negotiation the connection goes away just like when I set it to 1 gigabit but it comes back after 15sec. And when I set these two options and run a diagnostics it says the following: "This adapter does not have link. Make sure the cable is connected and the speed and duplex settings are configured correctly on the adapter and link partner." Hope I could provide you the information you needed. Best regards, Frank
0 Kudos
Highlighted
17 Views

Hello Frank,

 

Yes, you have provided the information we asked and thank you for that. We hope you don't mind providing the additional details below which will be helpful for us to further check the issue.

1.) Since this is an embedded controller to Asrock system, we'd like to check if you have tried to install the driver provided by Asrock? For OEM on-board Ethernet controller, it would be best if you can get in touch with Asrock for further support since they have customized drivers and software to enable or alter features on your system. They are in best position where you can seek assistance so you don’t lose features or customizations of the Ethernet controller. Please visit this link for Support Options for Intel® Ethernet Controllers

https://www.intel.com/content/www/us/en/support/articles/000006628/network-and-i-o/ethernet-products...

2.) You may also try to manually install/update the driver from Intel website or Asrock to check if this would help to fix the issue.

Please refer to this link on How to Manually Install Intel® Network Adapter Drivers in Windows*

https://www.intel.com/content/www/us/en/support/articles/000022174/network-and-io.html

Please visit this link for Intel® Network Adapter Driver for Windows® 10

https://downloadcenter.intel.com/download/25016/Intel-Network-Adapter-Driver-for-Windows-10?product=...

3.) We'd like to double check if the port on your switch/router is also set to auto negotiation? We have to ensure that both sides of the link are configured the same way.

4.) Please share the exact model of the switch/router and cable type used.

 

Looking forward to hear an update from you.

 

Best regards,

Crisselle C

Intel Customer Support

A Contingent Worker at Intel

0 Kudos
Highlighted
17 Views

Hello Frank,

 

Good day!

 

We are sending this to follow up on the details we have requested above. This would help us in further checking the issue. Please also share if you have tried to contact Asrock for further assistance regarding this issue.

 

We hope to hear from you soon.

 

Best regards,

Crisselle C

Intel Customer Support

A Contingent Worker at Intel

0 Kudos
Highlighted
17 Views

Hello Frank,

 

I hope you are doing great!

 

Please be informed that we will now proceed in closing this request since we haven't received any response from our previous follow up. Just in case you have any other concern or assistance needed in the future,please do not hesitate to post a new question.

 

Best regards,

Crisselle C

Intel Customer Support

A Contingent Worker at Intel

0 Kudos