Community
cancel
Showing results for 
Search instead for 
Did you mean: 
WQian6
Beginner
473 Views

When SR-IOV enabled on FreeBSD 12.1R, X540-T2 will not pass the traffic. driver vesion is ix-3.3.10

Since the original case is closed, create a question again.

for detail. please check original post.

thanks.

 

https://forums.intel.com/s/question/0D50P00004PZuQZSA1/when-sriov-enabled-on-freebsd-120r-x540t2-wil...

0 Kudos
12 Replies
CrisselleF_C_Intel
Moderator
106 Views

Hello WQian6,

 

Thank you for posting in Intel Ethernet Communities. 

 

While we are checking on this, could you please share if you already tried the latest vf driver from the link below? 

Version: 1.5.17 

https://downloadcenter.intel.com/download/26004/Ethernet-Intel-Network-Adapter-Virtual-Function-Driv...

 

Please also provide the PBA markings of the adapter for us to identify if you are using a retail or OEM version of Intel Ethernet adapter. Kindly refer to the link below on where to find the PBA of the adapter. It is a 6-digit number located at the last part of the serial number. Or you may provide a photo focusing on the markings so we can double check on it.

https://www.intel.com/content/www/us/en/support/articles/000007022/network-and-io/ethernet-products....

 

Looking forward to your response.

 

Best regards,

Crisselle C

Intel Customer Support

A Contingent Worker at Intel

WQian6
Beginner
106 Views

Hello Crisselle C

 

Thanks for the quick response.

I didn't know ixv is a seperate driver!

I play a lot with it. and it is funny...

 

I am using an OEM card. I will post the picture later.

 

Here is a long test story....

 

using lastest ixv driver and load on boot. confirm it with kldstat.

create 3 VFs using previous config. one for host, 2 for PPT. so one ixv0 device appear from host.

root@moon:/etc # ifconfig ixv0 ixv0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500 options=6407bb<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,JUMBO_MTU,VLAN_HWCSUM,TSO4,TSO6,LRO,VLAN_HWTSO,RXCSUM_IPV6,TXCSUM_IPV6> ether 12:76:dc:ba:1b:19 media: Ethernet autoselect (10Gbase-T <full-duplex>) status: active nd6 options=29<PERFORMNUD,IFDISABLED,AUTO_LINKLOCAL> root@moon:/etc # ifconfig ix1 ix1: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500 options=e407bb<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,JUMBO_MTU,VLAN_HWCSUM,TSO4,TSO6,LRO,VLAN_HWTSO,RXCSUM_IPV6,TXCSUM_IPV6> ether a0:36:9f:83:cc:aa media: Ethernet autoselect (10Gbase-T <full-duplex,rxpause,txpause>) status: active nd6 options=29<PERFORMNUD,IFDISABLED,AUTO_LINKLOCAL>

didin't config IP for PF and VF. only bring them up.

on host A. clear the ARP table. by

root@nas:~ # arp -a -d 172.16.2.240 (172.16.2.240) deleted 192.168.11.201 (192.168.11.201) deleted

and make the ping. just ping the non-exist IP from Host A.

root@nas:~ # ping 172.16.2.240 PING 172.16.2.240 (172.16.2.240): 56 data bytes ping: sendto: Host is down ping: sendto: Host is down ping: sendto: Host is down

above result it correct.

tcpdump on host B. on the test machine.

root@moon:/etc # tcpdump -i ixv0 tcpdump: verbose output suppressed, use -v or -vv for full protocol decode listening on ixv0, link-type EN10MB (Ethernet), capture size 262144 bytes 16:11:08.693300 ARP, Request who-has 172.16.2.240 tell 172.16.2.253, length 46 16:11:09.714350 ARP, Request who-has 172.16.2.240 tell 172.16.2.253, length 46 16:11:10.722354 ARP, Request who-has 172.16.2.240 tell 172.16.2.253, length 46 16:11:11.724785 ARP, Request who-has 172.16.2.240 tell 172.16.2.253, length 46 ^C 4 packets captured 4 packets received by filter 0 packets dropped by kernel

OK!, the ixv0 can get the ping packet. so I assign that IP to ixv0 by

root@moon:/etc # ifconfig ixv0 172.16.2.240/24

and from host A. it has reply now

ping: sendto: Host is down ping: sendto: Host is down ping: sendto: Host is down ping: sendto: Host is down 64 bytes from 172.16.2.240: icmp_seq=100 ttl=64 time=351.945 ms 64 bytes from 172.16.2.240: icmp_seq=101 ttl=64 time=0.079 ms 64 bytes from 172.16.2.240: icmp_seq=102 ttl=64 time=0.105 ms ^C --- 172.16.2.240 ping statistics --- 103 packets transmitted, 3 packets received, 97.1% packet loss round-trip min/avg/max/stddev = 0.079/117.376/351.945/165.865 ms

and only this case it is good.

 

if I assign other subnet IP to PF. the ping will stop response.

if I make 2 or more VFs. also same result, not working ether.

 

that is all. totally lost for a afternoon.

 

 

CrisselleF_C_Intel
Moderator
106 Views

Hello WQian6,

 

You are welcome.

 

We will wait for the picture of the adapter. As you have mentioned that it is an OEM card, we will be requesting you to check with manufacturer for the available driver of the card as they might have have customized drivers and software to enable or alter features on your system. 

 

Please also share if you have followed the Installation guide based on the read me file of the driver.

https://downloadmirror.intel.com/26004/eng/README.txt

 

Just to confirm, are you also using FreeBSD 12.1R on your guest OS?

 

We hope to hear from you soon.

 

Best regards,

Crisselle C

Intel Customer Support

A Contingent Worker at Intel

WQian6
Beginner
106 Views

Hello Crisselle C

 

Yes, I am using FreeBSD 12.1 Release.

 

So the product PBA number is G50137 as follow.

 

IMG_1829.jpg

 

I am using 10g base-t adapter. I have read the Installation guide.

but I cannot make it work at this very first.

CrisselleF_C_Intel
Moderator
106 Views

Hello WQian6,

 

Thank you for the reply.

 

Please allow us to check on this. Rest assured that we will get back to you within 1-3 business days.

 

Hoping for your patience.

 

Best regards,

Crisselle C

Intel Customer Support

A Contingent Worker at Intel

WQian6
Beginner
106 Views

Hello Crisselle C

 

I am grad Intel is investigting this issue.

 

You know, from what I know, SR-IOV functionality in Intel 10GB Card is broken for couple years..

Because this is a driver issue, it is difficult to know what is going except the Vendor guys.

 

I am hoping you can solve this issue, so I can make all my virtual machines using the VF interface.

that will make things faster.

 

Thanks.

 

 

CrisselleF_C_Intel
Moderator
106 Views

Hello WQian6,

 

While we are checking on this, we would suggest to reach IBM support also to check if they have driver for your adapter as this is an IBM OEM ethernet adapter.

 

Looking forward to hear an update from you

 

Best regards,

Crisselle C

Intel Customer Support

A Contingent Worker at Intel

WQian6
Beginner
106 Views

Hello Crisselle C

 

Yes, I have already check IBM website, which is

 

https://www.ibm.com/support/pages/overview-intel-x540-t2-dual-port-10-gigabit-baset-ethernet-adapter...

 

and they only support Windows and Linux

 

The following network operating systems have been tested for compatibility with the Intel X540-T2 Dual Port 10GBaseT Adapter for IBM System x.

Network operating systems

  • Microsoft
    • Windows Server 2008 x86 (all versions)
    • Windows Server 2008 x64 (all versions)
    • Windows Server 2008 R2 x64 (all versions)
    • Windows PE 3.1 and 2.1 x86 / x64
  • Linux
    • RHEL5 for x86, x64
    • RHEL6 for x86, x64
    • SLES10 for x86, x64
    • SLES11 for x86, x64

 

Every company supprt Linux nowadays, But we love FreeBSD more.

 

Hope you can fix this issue.

CrisselleF_C_Intel
Moderator
106 Views

Hello WQian6,

 

Please be advised that we are still checking on your query. Rest assured that we will provide an update within 3 business days.

 

Hoping for your patience.

 

Best regards,

Crisselle C

Intel Customer Support

A Contingent Worker at Intel

CrisselleF_C_Intel
Moderator
106 Views

Hello WQian6,

 

Apologies for the delay on this matter.

 

We would suggest to send a request to freebsd@intel.com for further assistance on this matter.

 

Let us know if there is anything else needed from Intel Ethernet team.

 

Looking forward to your response.

 

Best regards,

Crisselle C

Intel Customer Support

A Contingent Worker at Intel

CrisselleF_C_Intel
Moderator
106 Views

Hello WQian6,

 

Good day!

 

We hope that you were able to send a request on the email address provided above. Please be informed that we will now proceed in closing this request. If you need any other assistance from Intel Ethernet team, please do not hesitate to post a new question.

 

Best regards,

Crisselle C

Intel Customer Support

A Contingent Worker at Intel

WQian6
Beginner
106 Views

Hello Crisselle C

 

I am glad you have tried your best.

 

Thanks for your support.

 

Have a nice day.