Community
cancel
Showing results for 
Search instead for 
Did you mean: 
KDutt
Beginner
1,206 Views

intel QV driver: eeupdate or lanconf is not able connect to the QV driver

The eeupdate and the lanconf tool is not working. These tools need the IQV driver. However once I load the latest driver, these tools errors out with the following messages:

Connection to QV driver failed - please reinstall it!

This output is with the older iqv driver version: 1.1.4.17

[root@xrsdev29 ~]# ./lanconf64e /VERSION

Connection to QV driver failed - please reinstall it!

Using: Intel (R) PRO Network Connections SDK v2.28.29

LANConf v1.28.29.03

Intel(R) Diagnostic Tool for PRO Series Ethernet adapters

Copyright (C) 2006 - 2017 - 2017 by Intel (R) Corporation. All rights reserved.

Intel (R) Confidential and not for general distribution.

[root@xrsdev29 ~]#

Now, if I run the older tool, it does not complain. However, in both these cases the lanconf tool should have complained, as the iqv driver is not loaded in either of these cases.

root@xrsdev29 ~]# ./STX_3PF_UTIL_106/util/intel/lanconf /VERSION

Using: Intel (R) PRO Network Connections SDK v2.24.33

LANConf v1.24.33.07

Intel(R) Diagnostic Tool for PRO Series Ethernet adapters

Copyright (C) 2006 - 2015 by Intel (R) Corporation. All rights reserved.

Intel (R) Confidential and not for general distribution.

[root@xrsdev29 ~]# lsmod |grep iqv

[root@xrsdev29 ~]#

After I load the iqv driver (latest):

[root@xrsdev29 ~]# modprobe iqv

[root@xrsdev29 ~]# modinfo iqv

filename: /lib/modules/3.10.0-327.36.3.el7.0.1.63.xl7.x86_64/weak-updates/iqv/iqv.ko

version: 1.2.0.4

license: GPL

description: 1.2.0.4

author: Intel Corporation

rhelversion: 7.2

srcversion: EBD18E94CC97F7B1A7F08EF

depends:

vermagic: 3.10.0-327.28.2.el7.0.1.29.xl7.x86_64 SMP mod_unload modversions

[root@xrsdev29 ~]#

[root@xrsdev29 ~]# ./STX_3PF_UTIL_106/util/intel/lanconf /VERSION <----- older lanconf tool, so expected output.<p>

Driver version do not match, please reinstall driver

[root@xrsdev29 ~]# ./lanconf64e /VERSION <------- New lanconf tool came with iqv driver. It still complains after loading the iqv driver

Connection to QV driver failed - please reinstall it!

Using: Intel (R) PRO Network Connections SDK v2.28.29

LANConf v1.28.29.03

Intel(R) Diagnostic Tool for PRO Series Ethernet adapters

Copyright (C) 2006 - 2017 - 2017 by Intel (R) Corporation. All rights reserved.

Intel (R) Confidential and not for general distribution.

[root@xrsdev29 ~]#

So, why the latest IQV driver does not work with the latest eeupdate and lanconf tools, whereas older driver with older tools works!

Thanks

Kongkon

Tags (1)
0 Kudos
0 Replies