Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Novice
417 Views

intel-i219V wake on lan right after shutdown (due to magic packets while computer awake)

Jump to solution

Hello,

I've finally managed to set up wake on LAN with magic packet with my intel i-219v and my windows 10 64 bit PC and amazon alexa. However, sometimes when i shut down my PC, it wakes up immediately after shutdown automatically.

After troubleshooting and trial and error I discovered that if an extra/accidental magic packet is sent while the computer is awake, then whenever i shut down the computer it will restart due to the magic packet; as if it was queued.

Is there any way to disable this?

 

Thanks!

0 Kudos

Accepted Solutions
Highlighted
Novice
260 Views

i have come up with a solution for this.

first i ran a test.

If while computer is awake, and wake on magic packet under device manager for intel i219-v is "Enabled", and then I send magic packet requests to wake computer, and then set it to "Disabled", then after shutdown the computer doesn't restart (we already knew this).

If while computer is awake, wake on magic packet under device manager for intel i219-v is "Disabled", and then I send magic packet requests to wake computer, and then set it to "Enabled" before shutdown, the computer doesn't restart after shutdown!

Interestingly if while computer is awake, and wake on magic packet under device manager for intel i219-v is "Enabled", and then I send magic packet requests to wake computer, and then set it to "Disabled", save, then set it to "Enabled" again before shutdown, the computer still restarts.

So basically the magic packet request gets "queued" whenever it is received while computer is awake ONLY IF the wake on magic packet setting is enabled at the time the magic packet is received (again indicating this is likely a network card related function, because it has to do with the properties of the network card under device manager).

 

My fix: I'm abit of a programmer, and already have a smarthome application i created that starts up with computer and usually shuts down my computer using smarthome commands.

Using windows process monitor, i tracked down the registry key responsible for wake on magic packet for intel i219-v; (it was under "HKLM\System\CurrentControlSet\Control\Class\{*******-****-****-****-**********}\0001\*WakeOnMagicPacket

when my computer starts up, my smarthome application sets the key value to "0", which disables wake on magic packet while my computer is awake. If my computer accidentally receives magic packets while awake, they won't be processed.

before my computer shuts down, my smarthome application sets the key value to "1", which allows wake on magic packet to be enabled again (so i can still use wake on lan to turn on my computer from the off state).

 

It's pretty brilliant if i may say so myself :D

You may mark this topic as resolved.

View solution in original post

11 Replies
Highlighted
Moderator
260 Views

Hi Iakel,

Thank you for posting on our Intel® Ethernet Communities Page.

We know the importance of having your issue resolved, and we will do our best to assist you.

Please provide the following information so we will have a more detailed understanding of your issue:

1. Kindly download and run our Intel® System Support Utility from this page, https://downloadcenter.intel.com/download/25293/Intel-System-Support-Utility-for-Windows-. After running it, it will create a text file, please attach the text file on your reply to this message.

2. May we know what program are you using to send wake packets?

We look forward to your reply. Should we not hear from you, we will check back with you after three business days.

 

 

Best Regards,

Alfred S

Intel® Customer Support

0 Kudos
Highlighted
Novice
260 Views

Thank you for your response.

I attached the log file.

I have used 3 different tools all with the same outcome. i used an amazon alexa skill on my 3rd gen echo dot, i have used remoteboot ios app on my phone, and i have used wake-on-lan tool from my windows laptop.

All 3 of these tools use a local broadcast to send the wake on lan packet.

I have also used a wake on lan monitor on my PC, that identifies the packet gets received over UDP port 9 while computer awake at the time i send it.

I have tested from all sources, and inevitably if a wake on lan packet is received when my computer is awake, then whenever i shutdown my computer (even hours later) it starts up right after shutting down if i have wake on lan enabled.

I have even used windows firewall to block incoming traffic on UDP port 9, and the wake on lan monitor tool no longer receives/identifies the WOL magic packet, and my computer STILL starts up after next shutdown if i have wake on lan enabled.

I have run powercfg and the windows event monitor, and even though it says "source unknown" for the startup event I can at least tell it's not an erroneous shutdown or restart (no associated errors or error details).

I have proven there is no other source of the restart, because if i send magic packets while my PC is awake, and turn off wake on lan from the device manager, then when i shutdown my computer stays off next shutdown.

 

 

Regarding the WOL messages that are getting sent while my computer is awake, it is my amazon echo dot alexa skill that sometimes sends wake on lan commands when my desktop is already on (i have routines that turn on my desktop that can't detect if it's already on).

0 Kudos
Highlighted
Moderator
260 Views

Hi Iakel,

Please allow us some time to investigate your concern.

We will get back to you no later than 3 business days from now.

Best Regards,

Alfred S

Intel® Customer Support

 

0 Kudos
Highlighted
Moderator
260 Views

Hi Iakel,

We are still checking on your concern. Thank you for patiently waiting for an update.

While we are investigating, please try to disable the "EnablePME" setting in your network's advanced tab, and see if it fixes the issue.

Looking forward to your update. We will check back with you after 3 business days, should we not hear from you.

Best Regards,

Alfred S

Intel® Customer Support

0 Kudos
Highlighted
Novice
260 Views

I tried it. My computer no longer started up after shut down, but wake on lan also stopped working.

Essentially it was another way that proves the restarting after shut down is from magic packet while computer is awake :\

0 Kudos
Highlighted
Moderator
260 Views

Hi Iakel,

Thank you for updating us on this one. Please allow us some time to continue investigating your concern. We will get back to you no later than 3 business days from now.

Best Regards,

Alfred S

Intel® Customer Support

0 Kudos
Highlighted
Moderator
260 Views

Hi Iakel,

Thank you for patiently waiting for an update.

We thoroughly checked all possible reasons that is causing your issue.

Your drivers are updated. Your settings are correct. The only thing that we can think about is how the integrated network card was implemented on the board. For this one, we would recommend for you to check with your motherboard manufacturer to see if they have BIOS settings or updates that you can try on your board that could fix the issue.

We hope for your understanding on this. We will check back with you after three business days.

 

 

Best Regards,

Alfred S

Intel® Customer Support 

0 Kudos
Highlighted
Novice
260 Views

i updated the bios to the latest version, it didn't solve the problem

i really don't think it's a bios problem, pretty sure the stored wake execution is coming from the lan card because if i turn off wake on magic packet from lan but keep it on in bios, then it doesn't turn on.

Let me ask another question that might be able to offer a solution: Is there a way to block wake on magic packet or wake on lan commands from certain ip addresses? I need to block them at the level of the lan card, because it seems even if i block magic packets from an ip at the windows firewall level (they don't reach OS software), they still execute.

Is there a way to block data in general prior to reaching or being processed by the lan card? If so, if i could have a blocker on in the background while the computer is awake it would solve my problem.

 

Thanks!

0 Kudos
Highlighted
Moderator
260 Views

Hi Iakel,

We appreciate the time that you took out of your busy schedule to share that information.

We will continue investigating your concern, and we will give you an update no later than 3 business days from now.

We may need to ask for more information during the investigation process.

 

Best Regards,

Alfred S

Intel Customer Support

0 Kudos
Highlighted
Novice
261 Views

i have come up with a solution for this.

first i ran a test.

If while computer is awake, and wake on magic packet under device manager for intel i219-v is "Enabled", and then I send magic packet requests to wake computer, and then set it to "Disabled", then after shutdown the computer doesn't restart (we already knew this).

If while computer is awake, wake on magic packet under device manager for intel i219-v is "Disabled", and then I send magic packet requests to wake computer, and then set it to "Enabled" before shutdown, the computer doesn't restart after shutdown!

Interestingly if while computer is awake, and wake on magic packet under device manager for intel i219-v is "Enabled", and then I send magic packet requests to wake computer, and then set it to "Disabled", save, then set it to "Enabled" again before shutdown, the computer still restarts.

So basically the magic packet request gets "queued" whenever it is received while computer is awake ONLY IF the wake on magic packet setting is enabled at the time the magic packet is received (again indicating this is likely a network card related function, because it has to do with the properties of the network card under device manager).

 

My fix: I'm abit of a programmer, and already have a smarthome application i created that starts up with computer and usually shuts down my computer using smarthome commands.

Using windows process monitor, i tracked down the registry key responsible for wake on magic packet for intel i219-v; (it was under "HKLM\System\CurrentControlSet\Control\Class\{*******-****-****-****-**********}\0001\*WakeOnMagicPacket

when my computer starts up, my smarthome application sets the key value to "0", which disables wake on magic packet while my computer is awake. If my computer accidentally receives magic packets while awake, they won't be processed.

before my computer shuts down, my smarthome application sets the key value to "1", which allows wake on magic packet to be enabled again (so i can still use wake on lan to turn on my computer from the off state).

 

It's pretty brilliant if i may say so myself :D

You may mark this topic as resolved.

View solution in original post

Highlighted
Moderator
260 Views

Hi Iakel,

Thank you for sharing your brilliant workaround for the issue that we are trying to resolve.

We will take note of this fix.

We will now be closing the thread, and again we deeply appreciate your initiative in finding a genius workaround for your concern.

 

Best regards,

Alfred S.

Intel Customer Support

0 Kudos