FPGA Intellectual Property
PCI Express*, Networking and Connectivity, Memory Interfaces, DSP IP, and Video IP
6021 Discussions

Arria 10 Low Latency 40G Ethernet IP with Quartus 21.3

fst21
Beginner
583 Views
Dear Community, When upgrading from to the new Quartus version 21.3, the following errors occur in the IP Core Low Latency 40G Ethernet IP for Arria 10: Error(13223): Verilog HDL or VHDL error: No key to decrypt data block Error(13223): Verilog HDL or VHDL error: decryption of data_block failed Error(13223): Verilog HDL or VHDL error: No key to decrypt data block in file MACController/alt_eth_ultra_40_1910/synth/alt_aeu_40_pfc_tx_odp.v Obviously, the key to decrypt the files is missing. The problem occurs both with a newly created IP Core and with an update from Quartus 19.4. With Quartus 19.4 this problem does not exist. According to the license setup, a license for version up to 2025.01 is available. How can this problem be solved? Or is there a workaround? Thanks a lot for your help! With all the best, fst21
0 Kudos
7 Replies
Deshi_Intel
Moderator
544 Views

Hi,


I used Quartus Linux v21.3 to generate and compiled Arria 10 Low Latency 40G Ethernet IP example design and it works fine.


Therefore, I suspect your issue could be due to your licensing issue.

  • Can you share your licensing *.dat file for debug review ?
  • Also just to confirm are you using exactly same 40G IP setting between old Quartus version vs this latest Quartus v21.3 ? For instance, did you enable KR-PHY feature as I recall KR-PHY feature may require separate license to use it


Thanks.


Regards,

dlim



fst21
Beginner
483 Views

Hello dlim,

 

thank you for your reply. Yes, I used exactly the same settings for both Quartus versions. I did not use the KR-PHY feature.

 

Enclosed is the license file used.

 

With best regards,

fst21

Deshi_Intel
Moderator
455 Views

Hi,


Thanks for sharing your licensing file.


I will transfer your case to Intel FPGA Licensing support team to review your license file.


Thanks.


Regards,

dlim


AR_A_Intel
Employee
451 Views

Hi

 

I’m helping regarding you license issue. Based on my understanding, you license is Issued on 19 January 2021. The latest Quartus version support you license is Quartus v20.4 as it is Release in December, 2020


fst21
Beginner
433 Views

Hello,

 

Yes, the license was issued on 19/01/2021. But my understanding is that it is possible to get upgrades with this license until the maintenance date expires. This is still in the distant future as can be seen in lines 11-12.

AR_A_Intel
Employee
429 Views

Hi

 

Yes, you can get upgrades with this license until the maintenance date expires. Apologize as I overlook into this. To further understand the issue, could you get me the:

1) Debug/error.log file

2) Error message screen shot

3) Screenshot of Quartus II>>tools>>license setup

4) Machine OS information

5) Quartus version used

6) Output of “lmutil lmstat –a –c <port>@<address>” server and client

And for privacy, you can reply/attach your file in private message


AR_A_Intel
Employee
362 Views

We do not receive any response from you to the previous reply that I have provided. This thread will be transitioned to community support. If you have a new question, feel free to open a new thread to get the support from Intel experts. Otherwise, the community users will continue to help you on this thread. Thank you


Reply