FPGA Intellectual Property
PCI Express*, Networking and Connectivity, Memory Interfaces, DSP IP, and Video IP
Announcements
The Intel sign-in experience is changing in February to support enhanced security controls. If you sign in, click here for more information.

Library Setup broken?

Altera_Forum
Honored Contributor II
1,039 Views

Hi, 

 

I have NIOS/SOPC_BUILDER design here with libraries in the generated files not matching my library (at least I guess so). 

 

The actual problem is a component called "altera_std_synchronizer" that is used at several places. The generated files only include the "altera" library, however the altera_std_synchronizer is in the altera_mf library. 

 

I can resolve the problem (e.g. just compile altera_std_synchronizer to the altera library) but I guess this problem is an indication, that there is something wrong with my library setup. Or is the library setup broke by default? 

 

Quartus Version is 9.1. 

 

Regards 

flintstone
0 Kudos
3 Replies
Altera_Forum
Honored Contributor II
94 Views

i recall similar problems, i'm not sure there is a problem with your setup

Altera_Forum
Honored Contributor II
94 Views

So it could be broke by default? This is annoying. Quartus will synthesize the design warning about missing files but for simulating in Modelsim we will need a workaround. 

 

Thanks 

flintstone
Altera_Forum
Honored Contributor II
94 Views

it might be fixed in newer versions, i'll check 10.0 

 

do you know which component is calling altera_std_synchronizer?
Reply