FPGA Intellectual Property
PCI Express*, Networking and Connectivity, Memory Interfaces, DSP IP, and Video IP
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.
5875 Discussions

Problem with HIL, DSP_Builder and Stratix IV GX

Altera_Forum
Honored Contributor I
793 Views

Hi, I use Quartus II 10.1 SP1, DSP_Builder 10.1 SP1, Matlab 2009a and Stratix IV GX Development kit. 

 

I have created the following scheme in Matlab: see image myhil_1.jpg. 

And all works! 

 

Then I have created the following scheme: see image myhil_2.jpg. 

The devboard gives out a incorrect signal. 

 

I have done all too most for other development kit Cyclone III Starter kit. And all works! 

 

What is a problem with Stratix IV GX Development kit? 

 

PS: sorry for my english)
0 Kudos
3 Replies
Altera_Forum
Honored Contributor I
75 Views

I think DSP Builder 10.1 didn't work very well with combinatorial systems. Try adding a delay block in between your Input and Output blocks.

Altera_Forum
Honored Contributor I
75 Views

I adding a delay block in between my Input and Output blocks. It does not work correct. 

I think DSP_Builder 11.0 solves my problem, but I have not license for Quartus 11.0.
Altera_Forum
Honored Contributor I
75 Views

11.0 should have fixed the combinatorial problem. It also fixed a case where multiple devices were on the same JTAG chain. I don't know whether that board has that problem.

Reply