FPGA, SoC, And CPLD Boards And Kits
FPGA Evaluation and Development Kits
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.
5234 Discussions

After software update of the DE10-NANO-sd-card the HDMI-port seems to be damaged. Is that possible or there other options to reset that?

CPaul6
Beginner
1,816 Views

I use the DE10-NANO since one year with success. Now I tried to do some opencv over python and updatet some apis for that. After doing that immediatly the HDMI output didn't work any more. Because I thought it wasd because of the update I changed to my MISTER-SDCARD which worked always fine. This i did use as before, but HDMI didn't work. Is the HDMI-Port damaged or may it be that the code in one chip has been changed and should be reseted by an special command. Has anybody an idea?

0 Kudos
8 Replies
JOHI
New Contributor II
283 Views

Hello,

Did you try to make a fresh card based on a fresh download of the image supplied via the terasic site? There is a golden reference application that should work. Terasic also provides very good manuals how to make sd cards that boot properly.

Br.

Johi.

BoonT_Intel
Moderator
283 Views
Thanks Johi for help. Yes, if possible please contact Terasic as DE10-NANO is Terasic board. From your description, it is unlikely hardware damage. The malfunction is happen after you updated the APIS. Probably that is due to some software/setting issue.
CPaul6
Beginner
283 Views

Thanks for your hints. But thats what I did. I did put a view different images to sd-cards and tried them. This sdcards boot, but don't give an output to the hdmi-screen. I can use ssh to connect to the board and get the linux shell. I can use it very well. Perhaps I will try also the Angstrom-distribution. Perhaps there is an application, which can reset some microcode for the hdmi-output? If I connect with ssh -X I can start the reference applications and they work fine with the remote X11-monitor. So I need a special application for hdmi-tests.

BoonT_Intel
Moderator
283 Views
Hi CPaul6, I will suggest you contact Terasic to get further help on this.
CPaul6
Beginner
283 Views

Thank you. I just did sent an email to TERASIC and two days before I did send a mail to the german distributor digikey, but they didn't answere till now.

BoonT_Intel
Moderator
283 Views
Thanks. If from Intel PSG stand point. Usually we will ask user to narrow the issue by using the example design as below: https://www.intel.com/content/dam/www/programmable/us/en/pdfs/literature/ug/ug-hdmi-de.pdf However, this is Terasic board, I doubt that Terasic does not use the full solution from us. So, it is better to consult them directly as we can see this is board level issue instead of the FPGA.
CPaul6
Beginner
283 Views

Thank you. I have contacted them and there is a HDMI RX-TX Example I tried. But theyhave some more ideas and I hope they will work finally

BoonT_Intel
Moderator
283 Views

Good luck!

Reply