Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Valued Contributor III
748 Views

[Arria10GX - Flash HW design] Problem to connect to the BUP Web Page

Hi everyone, 

 

I meet a problem when I try to flash my design into my FPGA Arria 10.  

I followed the process specified page 53 of the "ug-20007 : arria 10 fpga development kit (https://www.altera.com/en_us/pdfs/literature/ug/ug_a10-fpga-prod-devkit.pdf)". 

After I set all the switch as specified on the user guide, I connected the board by ethernet to my laptop and power it up. 

The next step should have been to copy the IP address displayed by the LCD on the board. But here comes my problem: The LCD keep displaying "Net Initialize.." 

 

https://image.noelshack.com/minis/2018/07/2/1518496334-26709.png (https://www.noelshack.com/2018-07-2-1518496334-26709.jpg

 

My laptop is connected to the Wifi of my company. Also, I tried to solve the problem by doing a "Factory Reset" (page 14; UG-20007) of my board, but it didn't solved the problem. 

 

I haven't seen any post, or document mentioning this situation so far. I would be grateful to hear any suggestion you may have to get rid of this problem. 

 

Thank you all, 

 

Tolec 

 

 

EDIT :  

I did one last attempt to make my platform work as I wanted. Hopefully, it worked to solve the problem. 

The board needs to be directly connected by ethernet to a switch (connected to the server). It doesn't work if you try by Wifi. 

 

Best, 

 

Tolec
0 Kudos
1 Reply
Highlighted
Valued Contributor III
2 Views

The issue is that the board needs to see a DHCP server to get an IP address. If you connect it directly to your laptop, unless you're running a DHCP server, the board never gets an address. I solved this by installing a simple free server: http://www.dhcpserver.de/cms/download/ 

 

By connecting the board to a switch that is connected to the rest of your network, the board is able to see a DHCP server.
0 Kudos