FPGA, SoC, And CPLD Boards And Kits
FPGA Evaluation and Development Kits
6029 Discussions

Cyclone 10 GX FPGA Development Kit - board test system

OlegT
New Contributor I
2,132 Views

Hello.

I want to use BoardTest System application with 10GX Kit, but always get following message:

OlegT_0-1628795343367.png

Embedded download cable is not working, so I use external Terrasic Blaster, connected to J11.

Quartus programmer is able to scan JTAG chain with this programmer.

My Quartus version is 19.1 Pro.

In system variables I've changed QUARTUS_ROOTDIR to Q19.1_inst_folder/quartus. I did this, because starting Quartus did not change this variable, as described in user guide.

Terrasic Blaster has an LED, indicating activity. I see, that it blinks once, when I start BoardTestSystem.exe

So my questions are:

Does BoardTestSystem.exe work with Quartus 19.1 and external Terrasic blaster?

Thank you.

Best regards,

Oleg.

0 Kudos
1 Solution
OlegT
New Contributor I
1,979 Views

Now I've tried original USB-Blaster II. BoardTestSystem works!

I did not try with Q19.1. Only on 17.1

So Terrasic Blaster is not really good.

View solution in original post

0 Kudos
13 Replies
OlegT
New Contributor I
2,115 Views

Thank you.

I'll try to use older version of Quartus.

0 Kudos
OlegT
New Contributor I
2,105 Views

So, I've installed Quartus Pro 17.1.0 build 240, as recommended in  Intel® Cyclone® 10 GX FPGA
Development Kit User Guide
 .

No luck. The result is the same - LED on Terrasic blaster blinks, and message "No devices" appears.

echo %QUARTUS_ROOTDIR% returns correct path to Q17.

 

By the way, the README.TXX in BTS folder states, that reference design is built by Quartus Version 16.1.1.200 (useg guide recommends using 17.1.0.240). But intel web site reports, that C10GX is supported starting from Q17:

OlegT_0-1628864829005.png

 

 

0 Kudos
AR_A_Intel
Employee
2,091 Views

Hello

 

Welcome to INTEL forum. Sorry, I am not familiar with Terrasic blaster. We don’t use Terrasic blaster to test our dev kit. I also not sure whether BTS test could work with Terrasic blaster. You could try use the Terrasic blaster to program the FPGA to see if it works.

 

·      For detail, it would be better if you could contact Terasic directly to understand the support model of this Terasic blaster. https://www.terasic.com.tw/cgi-bin/page/archive.pl?Language=English&CategoryNo=12&No=20     

 

Please accept my apologies for not being able to assist you fully as this is out of my expertise


0 Kudos
OlegT
New Contributor I
2,082 Views

Terrasic blasster is fully functional. I could scan, program, use signal tap.

0 Kudos
AR_A_Intel
Employee
2,059 Views

Hi

 

May we know what’s the error message seen while launching BTS ?


0 Kudos
OlegT
New Contributor I
2,053 Views

Hi.

Here is the message:

OlegT_0-1629443653775.png

 

FYI:

OlegT_1-1629443730548.png

 

0 Kudos
AR_A_Intel
Employee
2,033 Views

Could you help to try out recommended troubleshoot for Error when scanning hardware - No devices in https://www.intel.com/content/www/us/en/programmable/documentation/nfa1418282998564.html A.2. Troubleshooting Procedure for Error when scanning hardware - No Devices


0 Kudos
OlegT
New Contributor I
2,026 Views

All tests from troubleshooter passed. 

I don`t think, that the problem is in drivers or jtag server. I am able to find C10GX (as well as Max10) on the jtag chain with help of Quuarus programmer.

When I start BoardTestSystem.exe, the LED on the Terrasic Blaster blinks. As I understand, BoardTestSystem has access to blater.

0 Kudos
AR_A_Intel
Employee
2,005 Views

Hi

 

Could you help try on this just reboot Altera JTAG server (not disable it)

•           Goto Window task manager -> process -> look for jtagserver.exe and kill it

•           After that, the default JTAG clock frequency is 24M. Could you try reducing the JTAG clock speed to 16M or 6M to see how things go.


0 Kudos
OlegT
New Contributor I
1,981 Views

Unfortunately the Terrasic Blaster does not support changing clock. During JTAG chain scan from Quartus Programmer I see, that the TCK is about 1.3MHz

May be Terrasic Blaster is not the one I have to use.

0 Kudos
OlegT
New Contributor I
1,980 Views

Now I've tried original USB-Blaster II. BoardTestSystem works!

I did not try with Q19.1. Only on 17.1

So Terrasic Blaster is not really good.

0 Kudos
AR_A_Intel
Employee
1,931 Views

Sounds good, thanks for sharing and hope everything is working well at your side. This thread will be transitioned to community support. If you have a new question, feel free to open a new thread to get the support from Intel experts. Otherwise, the community users will continue to help you on this thread. Thank you


0 Kudos
Reply