Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Altera_Forum
Honored Contributor I
2,471 Views

DE10 Nano kit - mini USB OTG without 5V?

I just received my DE10 Nano. Boot it up with the default linux on the sd card works fine. However I am unable to use any usb client devices (mouse, keyboard) plugged in to the OTG port. They only work when I hook them up through a self-power USB HUB. So is my board faulty or why does the USB OTG port does not provide usb devices with 5V supply voltage? Any suggestion would be highly appreciated.

0 Kudos
10 Replies
Altera_Forum
Honored Contributor I
430 Views

 

--- Quote Start ---  

I just received my DE10 Nano. Boot it up with the default linux on the sd card works fine. However I am unable to use any usb client devices (mouse, keyboard) plugged in to the OTG port. They only work when I hook them up through a self-power USB HUB. So is my board faulty or why does the USB OTG port does not provide usb devices with 5V supply voltage? Any suggestion would be highly appreciated. 

--- Quote End ---  

 

 

I second this one, same thing happen to me. 

A
Altera_Forum
Honored Contributor I
430 Views

It works fine for me, but I need to disconnect it every time linux starts.

Altera_Forum
Honored Contributor I
430 Views

I third this one. I followed the instructions to the letter, even re flashed the SD card with the Linux Xfce Desktop (kernel 4.1.33-ltsi-altera) image. I waited for the board to boot, then plugged in my wired USB mouse, no go. I tried the same procedure with a wireless keyboard/track pad combo, same thing, no go. Re Flashed the SD card to the Linux LXDE Desktop (kernel 4.5), repeated the same procedure again, no go. Are our boards defective? Moderator?

Altera_Forum
Honored Contributor I
430 Views

Did you check if the USB power switch U7 is enabled (USB_EXTVBUS activated)? If not, it's probably a BSP bug.

Altera_Forum
Honored Contributor I
430 Views

I solved the problem. It was a bad Male Mini USB OTG to Female USB A adapter. I only had the one, bought a new one today and it's working fine. Thanks for the reply though FvM, it's appreciated.

Altera_Forum
Honored Contributor I
430 Views

Board: De10 Nano Rev B 

 

I have the same issue .... its driving me nuts. For me I know my OTG is good because it works on my phone. 0 power hitting the OTG device. Even when I provide power externally I cant get the Armstrong OS to detect anything connected to the OTG port via lsusb or dmesg. 

 

When I connect the device to a laptop in slave mode ... the laptop does detect the device; 

 

"Bus 001 Device 005: ID 1d6b:0104 Linux Foundation Multifunction Composite Gadget"  

 

And the boot partition does appear as USB storage. 

 

So the issue appears to be the port cant operate in Host mode !!!! 

 

I wonder if pin 5 is broken on the port ?!? 

 

***** UPDATE ******** 

I found this in the manual 

 

"6.4 Enable/Disable USB GadgetUse can use the above features only when the USB Gadget function is enabled in the Xfce Desktop. 

When the USB gadget is enabled, the DE10-Nano acts as a USB storage after it is connected to a 

host PC.If it is unusable, please follow below steps to check if the USB Gadget is disabled: 

1. Boot up the DE10-Nano with the Xfce Desktop. 

2. Execute the USB_Gadget icon on the desktop. 

3. Check if the USB Gadget is Enable. 

4. Note that, any modified setting will be applied after the system is reboot" 

....it then goes on to show you how to disable the Gadget via the desktop with a mouse!!! (f****** ****s at Terassic you need a working OTG to use a mouse!!!) 

 

It states that you have to connect peripherals to the USB OTG "after" the device boots because of the Gadget forcing the OTG in host mode on boot. 

I wonder if even after boot the Gadget is preventing the OTG going into Host Mode. 

 

I'm trying to figure out a way to disable Gadget via command line.
Altera_Forum
Honored Contributor I
430 Views

 

--- Quote Start ---  

Board: De10 Nano Rev B 

 

....it then goes on to show you how to disable the Gadget via the desktop with a mouse!!! (f****** ****s at Terassic you need a working OTG to use a mouse!!!) 

 

--- Quote End ---  

 

 

As another posted mentioned, you need to unplug the mouse/keyboard from the OTG connector when Linux boots. Then after Linux is booted, plug the mouse/keyboard into OTG connector. Then they should work. This was mentioned in the Gettting_Started_Guide.pdf that came with my board. 

 

It also mentions that some mice/keyboards might not work with the DE10 due to an incompatibility problem. I have not run into that issue with my equipment -- I am using a Microsoft keyboard and mouse, and a non-powered hub. 

 

There should be an icon on the Xfce desktop that allows you to enable/disable the USB gadget.
Altera_Forum
Honored Contributor I
430 Views

 

--- Quote Start ---  

As another posted mentioned, you need to unplug the mouse/keyboard from the OTG connector when Linux boots. Then after Linux is booted, plug the mouse/keyboard into OTG connector. Then they should work. This was mentioned in the Gettting_Started_Guide.pdf that came with my board. 

 

It also mentions that some mice/keyboards might not work with the DE10 due to an incompatibility problem. I have not run into that issue with my equipment -- I am using a Microsoft keyboard and mouse, and a non-powered hub. 

 

There should be an icon on the Xfce desktop that allows you to enable/disable the USB gadget. 

--- Quote End ---  

 

How to disable the USB gadget before I cannot use mouse and keyboard control the Desktop? 

I have tried to disable it in command line but it told me that "QXcbConnection: Could not connect to display"...... 

 

Altera_Forum
Honored Contributor I
430 Views

 

--- Quote Start ---  

How to disable the USB gadget before I cannot use mouse and keyboard control the Desktop? 

I have tried to disable it in command line but it told me that "QXcbConnection: Could not connect to display"...... 

 

 

--- Quote End ---  

 

 

Try this command when logged in using the serial port as root, then reboot or power-cycle: 

 

root@de10-nano:/bin# cd /bin 

root@de10-nano:/bin# ./systemctl disable de10-nano-gadget-init.service 

Removed /etc/systemd/system/basic.target.wants/de10-nano-gadget-init.service. 

root@de10-nano:/bin#
alid
Beginner
175 Views

To add, using serial port (connecting the mini-USB port called 'UART to USB' to computer and running a program like Tera Term ) to log in and running the command above solved my problem.

Serial port parameters (couldn't find them in manual): 115200, 8 bit, no parity, 1 stop bit, no flow control. 

Also, despite what manual says, there is no password for root.

Hope this helps new users running into this issue.

Reply