Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Altera_Forum
Honored Contributor I
1,571 Views

DE4 terasic PCIe software not working

I have the terasic DE4 board, and I installed the development kit that came with it. I'm using Windows XP just to note. 

 

I was trying to get one of the PCIe examples the dev kit came with to work. Up to this point I have got my computer to recognize the board with a design (PCIe_Fundamental). But when I try to run the .exe with the design it doesn't let me send anything to the FPGA. 

 

When downloading the design to the board my computer does not always recognize it. I have to download multiple time until it works. And when my computer does find it most of the time it has a warning in the device drivers. 

 

I wanted to know if someone had an idea why the software executable is not working? 

 

Thanks, 

- Robert
0 Kudos
6 Replies
Altera_Forum
Honored Contributor I
71 Views

Hi Robert. 

I tested pci fundamentals demo on my DE4 board under XP and it worked. I was able to communicate with the board using the PC software provided in the demo. 

Do you get any specific error? 

BTW,do you have any daughterboard plugged in?
Altera_Forum
Honored Contributor I
71 Views

Hi Rhalstea, 

 

Have you already installed the PCIe drivers under: 

root\demonstrations\DE4_230\PCIe_SDK\Driver
Altera_Forum
Honored Contributor I
71 Views

I did not install the driver for the 230. I have the 530 board so I installed that driver. When I try do download the pcie_imageprocess demonstration it goes to the board without reporting any errors or warnings. 

 

I then restart the computer, and try to run the .exe here it gives an error message saying "Failed to connect to target FPGA board". 

 

- Robert
Altera_Forum
Honored Contributor I
71 Views

Hi Rhalstea, 

 

Did you find a solution to this issue. I am also facing the same issue when running the PCIe_Fundamental example. After downloading the design when i run the exe it shows failed to connect to target FPGA  

 

Thanks & Regards 

Hari
Altera_Forum
Honored Contributor I
71 Views

Hi Hari. I m going to prepare a step by step guide. Please stay tuned. I will try to post this guide here by tomorrow. I am pretty positive you should be able to put the demo to work on your board.

Altera_Forum
Honored Contributor I
71 Views

Hi Inakito, 

 

Could you please post the step by step details of making the demo work. I had been mailing Terasic guys too regarding the issue, still could not sort it out. The terasic_pcie.inf file does not seem to get executed properly. Can you also post details regarding PCIe port, configuration and other settings that you may have changed on the board. Thanks a lot. 

 

Regards 

Hari
Reply