FPGA, SoC, And CPLD Boards And Kits
FPGA Evaluation and Development Kits
Announcements
The Intel sign-in experience is changing in February to support enhanced security controls. If you sign in, click here for more information.
5416 Discussions

JTAG-Problem: Unable to scan device chain on CV GT Development Kit

Zarquin
Novice
282 Views

Dear Community,

 

  1. JTAG no longer works on my CV GT Dev board since yesterday, without any apparent cause. I have worked with an external USB-Blaster cable until now (Error message Fig.1). The cable is not the cause. I tested it with an other board.

  2. I tried to use the internal USB-Blaster, but unfortunately that doesn't work either (Error message Fig.2).

  3. All the switches are to their default settings.

  4. I opened the JTAG Chain Debugger and did a JTAG Chain integrity test for the external USB Blaster (see Fig.3 below). Seems something with the JTAG signal lines goes wrong.

  5. So I had a look at the schematic of the JTAG Header for external USB Blaster (Fig.4) and have looked at it on the board (Fig. 5). I have noticed that some resistors and capacitors are not populated (see red line, Fig.5). But I don't think that's the cause of the problem because it looks like they were missing before when the blaster was still working.

  6. All the JTAG lines from the external JTAG Header and the internal USB-Blaster Port lead to the MAX II on the underside of the board, which configures the JTAG chain and deactivates the internal USB-Blasterwhen the external USB Blaster is connected (Fig.6). So maybe this is the problem. But I don't have an idea how to check this or whether the MAX II can be reprogrammed.

I would appreciate any ideas of what else i could try to get it to work again?

Best regards

 

 

Fig.1 Error Extenal Blaster, Fig.2 Error Internal Blaster

unable_to_scan_device_chain.pngunable_hardware_disabled.png

Fig. 3: JTAG Chain Integrity Test

JTAG_Chain_Debugger.png

Fig.4 JTAG Header for external USB Blaster

JTAGHeader_Schematic.png

 

Fig.5 JTAG Header on the board

 

20221206_CVGT_JTAG_Forum.jpg

Fig.6 MAX II

MAX II.png

0 Kudos
5 Replies
NurAiman_M_Intel
Employee
247 Views

Hi,


Thank you for contacting Intel community.


-To confirm, the JTAG are working well previously and suddenly it is not working?

-What is the Quartus version that was used?


Regards,

Aiman


Zarquin
Novice
243 Views

Hi Aiman,

 

yes, exactly, before it worked and then next day it didn't - for no apparent reason.

The Quartus programmer version is 17.0.

The programmer cabel and the programmer software work well with my other  CV dev kit.
In the meantime I even tried again with a new programming cable: Same error message.

 

Best regards

NurAiman_M_Intel
Employee
184 Views

Hi,


Sorry for the delay.


The dev kit has on board USB Blaster, can you try using the onboard USB Blaster and see if it is working?


Regards,

Aiman


Zarquin
Novice
115 Views

Hi Aiman,

 

I wish you a happy new year.

  1. Did you read my initial post at the top of the page?
    "I tried to use the internal USB-Blaster, but unfortunately that doesn't work either (Error message Fig.2)."

  2. Is there a warranty on your products?

 

Is there

Regards

NurAiman_M_Intel
Employee
56 Views

Hi,


Sorry that I overlook that information.


Before we go for RMA, could you advice below for warranty checking,

I have request some information through forum email . Kindly provide the information.


Regards,

Aiman


Reply