FPGA, SoC, And CPLD Boards And Kits
FPGA Evaluation and Development Kits
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.
4965 Discussions

configure quartus PL to start model sim within it- Manjaro Linux (Arch packages)

JShan27
Beginner
374 Views

I can not get modelsim starter ed to start within quartus prime light 19.1. I specifically installed it with its own installer file.

 

I get a license error when I attempt to run a simulation in tab: tools- run rtl.

 

I point the settings to the linuxoleam folder within the modelsim_ase file.

 

The web link below describes my similar problem and has "a" solution that seems like it could apply to my system but to no avail,,, and really I looked in my package manager and I seem to already posess the files the blog is suggesting a person with this problem needs.. NOTE- the blogger is using open suse soo, ya, I noted that and hence why I am asking for some guidance/help,,, because I am kinda stuck :(

 

https://twoerner.blogspot.com/2017/10/running-modelsim-altera-from-quartus.html

0 Kudos
6 Replies
AR_A_Intel
Employee
160 Views

Hi

 

To narrow down this issue. Can you provide your

1) Debug.log file

2) Error message screen shot

3) Machine OS information

4) Quartus version used

5) License.dat file

And for privacy, you can also reply/attach your file in private message.

JShan27
Beginner
160 Views
1) Debug.log file 2) Error message screen shot 3) Machine OS information 4) Quartus version used 5) License.dat file    - Not applicable since it is prime light and  " ModelSim-Intel FPGA Edition (includes Starter Edition) " ? Thanks for helping
AR_A_Intel
Employee
160 Views

But before setting up modelsim, would you kindly help check whether your machine is supported or not (OS) by referring to ling below:

https://www.altera.com/support/support-resources/download/os-support.html   

JShan27
Beginner
160 Views
My operating system is Manjaro Linux, which is based off of Arch Linux ( Manjaro will use the same Arch files repositories?),,,, so no ModelSim is not supported by Manjaro Linux in accordance with the link you showed. I guess I am trying to manipulate the files (vco) in order for Manjaro to be able to run modelsim since that is what it seems like others have been doing,, albeit with alot of research and manipulation... hence showing you the link to a web page showing efforts to make it happen. Thanks
AR_A_Intel
Employee
160 Views

Thanks for sharing. Based on my understanding Manjaro Linux version is not an officially support OS for Quartus. An unsupported platform means that some things may work, but others not, and we won't put any resources into debugging or diagnosing. We recommended to use the right OS for Quartus based on the link provided.

JShan27
Beginner
160 Views
Reply