GPU Compute Software
Ask questions about Intel® Graphics Compute software technologies, such as OpenCL* GPU driver and oneAPI Level Zero
Announcements
This community is designed for sharing of public information. Please do not share Intel or third-party confidential information here.
56 Discussions

Installing the latest GPGPU software packages on Ubuntu 20.04

Steve_D
Employee
1,191 Views

I'm following the steps at https://dgpu-docs.intel.com/installation-guides/ubuntu/ubuntu-focal.html to install the latest GPU packages on Ubuntu 20.04. I have a Dell XPS 9310 with an i7-1185G7 / Iris Xe graphics. My Ubuntu system is fully updated according to Software Updater.

When I get to the step of installing runtime pacakges, the install of intel-opencl-icd gives me:

Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
intel-opencl-icd : Depends: libigc1 (>= 1.0.7862) but it is not going to be installed
Depends: libigdfcl1 (>= 1.0.7862) but it is not going to be installed
Recommends: intel-igc-cm (>= 1.0.1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Installing the libigc1 package wants to remove libigc which seems to cause other problems: "trying to overwrite '/usr/lib/x86_64-linux-gnu/libiga64.so", ran "sudo apt --fix-broken install" as suggested. I haven't yet tried to install the other runtime packages or optional developer packages.

Any help appreciated.

0 Kudos
2 Replies
Steve_D
Employee
1,124 Views

I have worked around this issue by restoring my machine to the Dell factory install of Ubuntu and installing the Intel GPGPU packages _before_ any of the standard updates Ubuntu suggests.  Taking this path, the install steps described at the referenced Intel link worked perfectly.  

I'm not positive but it seems the conflict that got me stuck centered around the Intel "igc" compiler the Ubuntu updater installed conflicting with the "igc1" compiler that the referenced Intel recipe wanted to install.

 

Dunni_A_Intel
Moderator
1,103 Views

Hi Steve,


Thank you for posting an update on your workaround. Perhaps your machine had incompatible versions of libigc1 and libigdfcl1. In that case, updating those packages would have likely fixed the issue.


Since your issue has now been resolved, we will no longer be motoring this thread.




Reply