Gaming on Intel® Processors with Intel® Graphics
Ask questions and get answers, tips/tweaks, and techniques from product and technology experts
406 Discussions

Cant play minecraft 1.17 or above

Ramalhito743PT
Beginner
1,704 Views

When i try to play Minecraft 1.17 or above its says my driver does not support OpenGL (shown in the screenshot). My notebook is very old. Me and my friend tried doing some things. In the website it says i dont have new updates for the driver and i dont know what to do. If it helps i have intel core i3 and Intel(R) HD Graphics 3000. I would really appreciate help even if i can't fix it. If needed, i can give more info about my notebook.

0 Kudos
2 Replies
AlHill
Super User
1,690 Views

There is nothing you can do except to get a new(er) laptop.  Your graphics are simply too old.

 

Doc (not an Intel employee or contractor)
[Maybe Windows 12 will be better]

0 Kudos
AlHill
Super User
1,554 Views

@DesomZues If you want to run Minecraft (a Microsoft product, and they set the requirements for their game), you need to meet their minimum requirements.

 

Doc (not an Intel employee or contractor)
[Maybe Windows 12 will be better]

0 Kudos
Reply