Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
2,475 Views

Automatically disabling the built-in display when connecting an external monitor

I have a problem about automatic switch between the built-in display and the external monitor. My machine is an MSI GS63 that runs Intel HD Graphics 630 along with Nvidia GTX1050.

When I connect the external monitor, I must manually set the display to "show only on 2" because the built-in display is not disabled when the lid is closed. You can check the attached screenshot that show both screen even with the lid closed.

The reason I find this weird is that on my other laptop, which is Lenovo Thinkpad Carbon that runs Intel HD graphics 5500, the built-in display is automatically disabled when I close the lid.

I have tried some suggestions like selecting the single display option from Intel Settings. However, even in Intel Settings the active displays list contains the built-in display when the lid is closed.

Another clue is that I can't view BIOS from the external monitor, something that I can do in Lenovo.

I have also tried to disable the Nvidia GTX1050 just to make sure that the HDMI port is on Intel, which is the case eventually.

I have checked another machine (Alienware) with Intel HD Graphics 530 and GTX 980, and its behavior was as expected, no problem at all.

I'm not very sure, but I think that the problem is with the Intel 630 driver or VBIOS.

Any suggestions is very appreciated.

0 Kudos
6 Replies
Highlighted
Community Manager
298 Views

Hello sahnounz,

Thank you for joining the Graphics Community. I am sorry to hear you are having issues with this matter.

 

 

Please let's try the following;
  1. Access the Intel® HD Graphics Control Panel.
  2. Go to Multiple Displays.
  3. Select your External Display as the primary display. It should set the Built-in as the secondary display, so make sure the external is 1 and the Built-in 2.
  4. Find "Change what closing the lid does" in Windows configuration.
  5. Set "When I close the lid" to "Do nothing" for On battery and Plugged in.

I tried this on a Dell XPS 15 and it worked fine, I even access the BIOS and I was able to see it in the external display.

Let me know how it goes.

Regards,

Amy C.

0 Kudos
Highlighted
Beginner
298 Views

Hello Amy,

Thank you for your quick reply.

Unfortunately, none of these worked.

I still can see the built-in display, and even make it as the only display when the lid is closed!.

It would be more logic if the built-in display just disappear from any settings (Intel or Windows) if the lid is closed. It's a PnP display panel, so closing the lid means unplugging it. I'm still investigating though

For the post-boot display, including BIOS setup, I managed to show it on an external display by switching from UEFI mode to UEFI with CMS. As far as I know, CMS means using VBIOS instead of GOP. As a conclusion, the issue is probably due to the GOP on the UEFI driver. I'm still looking for workarounds to reinstall or update the UEFI driver, I'n not sure if it's possible.

Thank you for your precious suggestions,

Regards,

Zakaria

0 Kudos
Highlighted
Community Manager
298 Views

Sure Zakaria.

Let see if I can find anything else regarding this behavior, I will update the thread as soon as possible.

Regards,

Amy C.

0 Kudos
Highlighted
Community Manager
298 Views

Zakaria, thank you for your patience.

Since we were unable to replicate this behavior, we believe this could be related to the GOP or VBIOS, as you mentioned. So, at this stage is the best thing to do is to report the behavior to your computer manufacturer explaining that Intel® tested it on other systems with the same driver and works as expected.

Regards,

Amy C.

0 Kudos
Highlighted
Beginner
298 Views

Hi Amy,

Thank you for your effort.

It's actually my guess too, since I've tried the same scenario with Lenovo Thinkpad running HD Graphics 620 and it was completely normal.

I strongly believe that it's something about GOP or the display panel driver (MSI has none, their panels use the generic PnP driver from Microsoft).

I'll try to get in touch with MSI support and update this thread, it could be useful for someone else.

Thank you

Regards,

Zakaria

0 Kudos
Highlighted
Community Manager
298 Views

Zakaria sure keep me posted, I am interested in their answer.

Regards,

Amy C.

0 Kudos