Community
cancel
Showing results for 
Search instead for 
Did you mean: 
JNdur
Beginner
11,723 Views

Black screen After Intel Graphics Family Driver Installation

I have been dealing with the above named issue for a few weeks now and i don't know where the problem is. I have tried uninstalling and re-installing the drivers again but still doesn't work. I have tried updating from windows update but still nothing. I have tried updating from manufactures site but still nothing. I have a Dell Latitude e5440. My only solution is to either disable or uninstall the Intel graphics driver. But then my machine runs on Microsoft basic driver when that happens and my Nvidia gpu is not detected from there on. So i need my Intel to work in order for my Nvidia to work properly. What i'm i missing?? Please help. I'm running out of my mind here!!

0 Kudos
8 Replies
AlHill
Super User
4,868 Views

What is the complete processor model number?

What intel graphics do you have?

What operating system do you have?

Doc

JNdur
Beginner
4,868 Views

I have intel(R) Core(TM) i5-4310U CPU@2.00GHz.

 

My Os is Windows 10 professional (64bit).

 

Dell Driver Update Package: Intel HD, 4200, 4400, 4600, 5000, 5100, 5200, 5300, 5500, 6000, 515, 520, 530, P530, Iris 540 Graphics Driver, 20.19.15.4531, A05
idata
Community Manager
4,868 Views

Hello Babayega,

 

 

Thank you for contacting Intel® technical support. I will be more than happy to help you.

 

 

Thank you for the information provided. I understand that you are having issues with the screen only when enabling the Intel® HD Graphics controller.

 

 

I would suggest uninstalling and deleting the current driver in the system, and then installing the latest version available in the Intel® website.

 

 

Please follow the steps below to uninstall the graphics driver:
  1. On the keyboard, press WinLogo key + R, then type in devmgmt.msc
  2. Expand the Display Adapters section.
  3. Find the Intel® Graphics Driver. The driver can also be called the Intel® Graphics Media Accelerator Driver (Intel® GMA Driver).
  4. Right-click the Intel Graphics Driver and select Uninstall.
  5. Select the check box Delete the driver software for this device.
  6. Reboot the computer after the uninstall process has finished.
Please follow these steps in order to update the graphics driver:
  1. Download the graphics driver ZIP file: https://downloadmirror.intel.com/27267/a08/win64_154037.4835.zip
  2. Unzip the file to a designated location or folder.
  3. Right-click Windows Start icon and open Device Manager.
  4. Click Yes when prompted for permission from User Account Control.
  5. Expand the Display adapters section.
  6. Right-click the Intel® graphics entry and select Update Driver Software.
  7. Click "Browse my computer for driver software".
  8. Click "Let me pick from a list of device drivers on my computer".
  9. Click "Have Disk".
  10. Click "Browse".
  11. Access the designated location or folder, and access a folder called "Graphics".
  12. Select the file called "igdlh64" or "igdlh".
  13. Click Open, then click OK, and finally click Next. Drivers are now being installed.
  14. Reboot your computer.
Regards,

 

 

Xavier A.
idata
Community Manager
4,868 Views

Hello Babayega,

 

 

I was checking your case and would like to know if you need further assistance. If so, please do not hesitate in replying back.

 

 

Regards,

 

 

Xavier A.
チドワード
Beginner
4,868 Views

After about two months of digging throughout the internet for a definitive remedy, I realized no solution was working for me. Then I went back to my computer to study the installation logs. It is from there that I found the problem with black screen upon installing intel hd graphics drivers. Apparently, installation always stopped due to the computer's power plan/policy. It happens that the intel graphics driver won't work with the default Balanced Power Plan, which seems to be the default when installing Windows 10 1803. Therefore, to correct the black screen, I entered into Safe Mode and reinstalled the problematic intel graphics driver, then went to the Control Panel > Hardware and Sound > Power Options. Under the Balanced (recommended) option, I selected Change plan settings > Change advanced power settings, then expanding the 'Intel (R) Graphics Settings > Intel (R) Graphics Power Plan', I set both On battery and Plugged in to "Maximum Performance". Then I restarted my computer and voila! It worked. No black screen again.

I hope this will work for most people.

idata
Community Manager
4,868 Views

Hello osako_007,

 

Thank you for contacting our community forums.

 

In this case, we really appreciate your feedback.

 

We will leave your post here for other community peers that may find it helpful.

 

 

I hope this helps.

 

Regards,

 

Diego S.

 

APros2
Beginner
4,868 Views

THANK YOU A LOT! This was helpful. 3 days of the stupid black screen problem. I tried everthing: reisntalled wind 10,downgraded drivers... Intel sucks.

adaha2
Beginner
4,868 Views

it isn't working for me plz help , Whenever i try changing graphics driver other than basic stupid black screen appears

Reply