Community
cancel
Showing results for 
Search instead for 
Did you mean: 
JNoba
Novice
1,628 Views

Blender 2.80 3d program not working well on Surface Pro 7.

I have recently bought a Surface pro 7. And i cant use my main 3d program blender on it, it is too laggy too have an efficient workflow. I have the older version of Microsfot Surface pro 4 works fine in blender 2.80. I have installed the older version of Blender 2.79 and this works fine on both devices. This is out of the box products freshly installed no plugins only the 3d program and only a single cube in the viewport. I belive this problem is centered to the iris graphics and i have a forum post with more details here.

 

https://blenderartists.org/t/blender-not-working-well-on-surface-pro-7/1187133

 

Greetings/Josef

0 Kudos
18 Replies
AlHill
Super User
821 Views

Contact Microsoft for support of their device.

 

Doc

 

JNoba
Novice
821 Views

I will contact microsoft aswell, but ive seen reports of other machines from other vendors that have the same issue with the software, and the root of problem seams too be the CPU or IRIS Drivers. But yeah i will write a mail to Microsoft aswell, but still i think Intel might have a part in this aswell.

AdrianM_Intel
Moderator
821 Views

Hello JNoba,

 

Thank you for posting on the Intel® communities. 

 

To better assist you with your request, I will need to check some information about your computer. Please follow these steps: 

 

Please run the following tools and attach the reports generated 

 

1. Intel® System Support Utility (Intel® SSU) 

  • Intel® SSU Download link 
  • Open the application and click on "Scan" to see the system and device information. By default, Intel® SSU will take you to the "Summary View". 
  • Click on the menu where it says "Summary" to change to "Detailed View". 
  • To save your scan, click on "Next", then "Save". 

  

2. DXDIAG 

  • Go to Start > Run or Windows Key + R. 
  • On the Run prompt, type "dxdiag" then click OK. 
  • On the DirectX Diagnostic Tool window, click on Save All Information. 
  • Browse to a folder, type in a filename then click Save. 

 

Regards,

 

Adrian M.

Intel Customer Support Technician 

A Contingent Worker at Intel

JNoba
Novice
821 Views

THx for your respons! Here are the infromation you requested. Greeting/Josef Nobach
AdrianM_Intel
Moderator
821 Views

Hello JNoba,

 

Thank you for your response.

 

I am unable to see the attachments, can you please attach the files to the thread again?

 

Please send us pictures of the task manager when you use the Blender version 2.80 and 2.79 to check the differences in (CPU usage, GPU, memory, etc).

 

Please provide steps to try to replicate the issue and if possible send us a sample project.

 

Regards,

 

Adrian M.

Intel Customer Support Technician 

A Contingent Worker at Intel

JNoba
Novice
821 Views

Previous i have attached the bug report. I will attach this again too this thread, and also i will attach DirectX Diagnostic Tools information. Seams i can only attach 1 file at a time to this thread. I have mailed this documents to you before though.

JNoba
Novice
821 Views

DxDiag report.

JNoba
Novice
821 Views

Graphics bug report.

JNoba
Novice
821 Views

In this video recording i try too explain the problem and how it shows up and affects me.

 

https://www.youtube.com/watch?v=bhk00eO_Zec&t=177s i have tried too suply you if all infromation i can, hope this is enough if not plz write e again.

 

Greetings/Josef

JNoba
Novice
821 Views

Blender 2.79 Taskmanager pic 2.jpgBlender 2.79 Taskmanager pic 1.jpgBlender 2.8 Taskmanager pic 2.jpgBlender 2.8 Taskmanager pic 1.jpg

JNoba
Novice
821 Views

I found this thread intressting as it shows different lineups of computers experiencing the same issues with Intel IRIS graphics drivers.

 

https://developer.blender.org/T71287

 

Greetings/ Josef

AdrianM_Intel
Moderator
821 Views

Hello JNoba,

 

Thank you for your response.

 

I will try to set up this on my end, I will get back as soon as possible.

 

Regards,

 

Adrian M.

Intel Customer Support Technician

A Contingent Worker at Intel

 

JNoba
Novice
821 Views

I thank you for your respons! Greetings/Josef
AdrianM_Intel
Moderator
821 Views

Hello JNoba,

 

I would like to update the thread.

 

We tested the software Blender 2.80 with Intel® Iris® Plus Graphics following the steps of the video you shared and we did not get any laggy issues.

 

We tested the software with:

  • Intel® Iris® Plus Graphics 
  • Driver version: 26.20.100.6912

 

The laggy issue might be related to the system or software configuration. We recommend you to check this with the system manufacturer of your computer or software developer.

 

Regards,

 

Adrian M.

Intel Customer Support Technician

A Contingent Worker at Intel

JNoba
Novice
821 Views

I got a mail from you saying that you havent been able too reproduce the issue. I just whanted too supply some post with other users experiencing the same problem as myself.

 

https://developer.blender.org/T70922

https://developer.blender.org/T71287

 

It seams that blender has too solve this. But its strange that you havent experienced the same issue. Seams too happen to many other users.

EMTEDM
Beginner
821 Views

its been clear that the problem is happened on only ice lake gpu but not every gen gpu,why intel just test a random iris plus and tell us they worked fine its all of the icelake users that their gpu driver couldnt be recgnized in blender opencl thats why its lagging

EMTEDM
Beginner
821 Views

xps and macbook air 2020 arefacing the same problem because of icelake gpu. opencl drivers are not working at all for blender2.8 you cant explain why blender2.8 are working fine with the previous gen gpu ,blender .microsoft. intel , none of them took a step to fix the issue

TKoen
Beginner
806 Views

Is there any news on this topic? I am experiencing similar issues when trying to run Virtual Surveyor on a Surface Pro 7 or Surface Book 3 (when using Intel Iris Plus). Virtual Surveyor runs smoothly on all other hardware that we have tested, even on Surface Pro 4.

Only basic OpenGL 3.3 operations are performed, so I don't know why it runs so slow.

Maybe someone at Intel could try to reproduce the issue on their side? Or should I create a new ticket for this? I believe it could be the same underlying issue as with Blender.

Reply