Graphics
Intel® graphics drivers and software, compatibility, troubleshooting, performance, and optimization
20580 Discussions

Closing of topics without solution

Simon_HE
Novice
2,979 Views

Hello,

 

a few weeks ago i created a topic regarding a serous issue with .Net WPF applications on Intel UHD 770 Graphics cards. https://community.intel.com/t5/Graphics/Net-WPF-Application-high-memory-consumption/m-p/1434020/thread-id/111478 
The Application uses up to 10x the memory while running under the Intel compared to other GPUs or even the UHD 770 with the default Microsoft VGA driver.

After Intel failed to replicate the issue because the provided information regarding the affected hardware was ignored, the topic was closed.
Despite the the notice from @ChrisV that the wrong CPU/iGPU was used and my last answer stating that i'm unavailable during the holidays.

 

Such behavior is very frustrating and rude for a customer trying to report and get an issue resolved.
Please immediately review the decision to close the original topic and tell me how to proceed further on this!

 

Thanks

Simon

20 Replies
DeividA_Intel
Employee
2,948 Views

Hello Simon_HE,  


  

Thank you for posting on the Intel® communities. I am sorry to know that you are having issues with your Intel® UHD Graphics 770.


In this case, we were not able to get the same results when we tried to replicate the issue as you saw in the information provided related to the test. I recommend you check this behavior with Hp since they customized our generic drivers and need to make sure that new drivers are compatible with their BIOS and system as well as to make sure that it contains the customizations approved by them.  



Regards,  

Deivid A.  

Intel Customer Support Technician 


0 Kudos
Whiteman
Beginner
2,889 Views

Dear Deivid,

we have the same issue than Simon and ChrisV. Also with the 770.

I've read the previous topic (https://community.intel.com/t5/Graphics/Net-WPF-Application-high-memory-consumption/m-p/1434020)

I think the reason, why u couldn't get the same result is, that you didn't test with the same hardware.

It is essentially to test with the UHD Graphics 770. Not with 750, cause there isn't this problem.

Also the right processor Gen 12. And make sure, that the screen is connected to the Intel Graphics card. 

 

So, it would be very kindly from intel, to repeat the tests with the right configuration. I'm sure you will be very suprised 😉

 

Kind regards

 

Thank u in advance

 

0 Kudos
Simon_HE
Novice
2,866 Views

Hello Deivid,

 

as already stated in both, the previous thread and this thread, please actually test with the hardware mentioned in the issue and not just a different one.
Like a i9-12900(K) with UHD 770 iGPU.
And make sure that the screen running the application is connected to the iGPU and not some other graphics card.

If you don't actually test for the problem, of course you won't find it.

 

 

Kind Regards

 

0 Kudos
DeividA_Intel
Employee
2,845 Views

Hello Simon_HE, 



Thanks for your response, I will check on this issue internally once more to make sure if the test can be performed correctly and check if I get the same results as you.


I will get back to you as soon as possible.



Regards,  

Deivid A.  

Intel Customer Support Technician 


0 Kudos
DeividA_Intel
Employee
2,832 Views

Hello Simon_HE,  

 

 

Thanks for your patience. I would like to let you know that the test was performed using the hardware that you mentioned (i9-12900K with UHD 770 iGPU).

 

However, I did not get the same results and the issue was not present. I recommend you try the driver version 31.0.101.4032 and if the issue persists, please get in contact with the app developer for further assistance.

 

 

Regards,  

Deivid A.  

Intel Customer Support Technician  

 

0 Kudos
Simon_HE
Novice
2,785 Views

Hello Deivid,

 

thanks for testing again.
Can you provide info file similar to SSUVSTest.txt that Alberto shared with the first test?

I just tested with the driver version 31.0.101.4032 and the issue still persists.

Were you using the computer in person or through some remote software like Windows Remote Desktop or TeamViewer?
The issue was not present for me when accessing the computer remotely.

 

Regards

Simon

 

0 Kudos
DeividA_Intel
Employee
2,721 Views

Hello Simon_HE, 



I appreciate your reply to the previous post. I will try to collect the information that you are requestioning and I will get back to you as soon as possible.


Thanks for your time and comprehension.



Regards,  

Deivid A. 

Intel Customer Support Technician 


0 Kudos
DeividA_Intel
Employee
2,694 Views

Hello Simon_HE,  



Thanks for your time. I am sorry if I am bothering you with this, however, I would like to replicate this issue one more time to provide you with a better and updated report and specifications to proceed I would appreciate it if you provide the following:


1. Just to make sure, can you provide a step-by-step with more details?

2. Can you provide a video where we can see how to install it, run it, and the issue?



Regards,  

Deivid A. 

Intel Customer Support Technician 


0 Kudos
DeividA_Intel
Employee
2,651 Views

Hello Simon_HE,  


 

After checking your thread, I would like to know if you need further assistance. 


If so, please let me know. 


 

Regards,  

Deivid A.  

Intel Customer Support Technician  


0 Kudos
Simon_HE
Novice
2,639 Views

Hello Deivid,

sorry for the late response.
I wasn't able to reply due to the forum maintenance.
The problem still exists, i'll try to record a video of it next week.

 

Regards

Simon

0 Kudos
DeividA_Intel
Employee
2,617 Views

Hello Simon_HE, 



Thanks for the confirmation. I understand that this will take you some time to gather the information. I will be waiting for the details, just as a friendly reminder this is the information needed.


1. Just to make sure, can you provide a step-by-step with more details?

2. Can you provide a video where we can see how to install it, run it, and the issue?



Regards,  

Deivid A. 

Intel Customer Support Technician


0 Kudos
Simon_HE
Novice
2,579 Views

Hello Deivid,

i was able to reproduce the issue with the newest drivers on a fresh windows 10 installation.
I had to split the recording into multiple parts due to reboots and installing the graphics drivers.
Videos are packed into zips as i don't have the permission to upload them directly
Part1: starts right after installing windows and setting up OBS to record the screen.

  • 0:05 - You can see the installation of dotnet SDK (Version 6.0.406)
  • 1:12 - Creation of an empty dotnet core WPF appication ("dotnet create wpf")
  • 1:24 - Start of the created application ("dotnet run")
  • 1:35 - Task-Manager showing the memory consumption (19,5MB) of the created application WITHOUT Intel drivers installed
  • 1:50-End - Installation of latest Intel WHQL driver (31.0.101.4091) and reboot

Part2: Starts right after the reboot after installing Intel Drivers

  • 0:13 - Start of Application with Intel driver
  • 0:19 - Task-Manager showing the memory consumption (104,1MB) of the created application WITH Intel drivers (31.0.101.4091) installed
  • 0:40 - Disabling the Intel GPU via device manager
  • 1:00 - Minimizing and maximizing the Application
  • 1:03 - Task-Manager showing the memory consumption dropping back to  (29,9MB) of the created application WITH Intel drivers (31.0.101.4091) installed
  • 1:11 Enabling the Intel GPU again. I had to restart OBS afterwards

Part3: Starts after restarting OBS after enabling the IntelGPU

  • 0:08 - Minimizing and maximizing the Application
  • 0:11 - Task-Manager showing the memory consumption rising to  (107.7MB) of the created application WITH Intel drivers (31.0.101.4091) installed
  • 0:25-End - Installation of latest Intel Beta Driver (31.0.101.4125)

I had to restart OBS as it was unresponsive after installing the new driver.

Part4: Starts after installing the Intel Beta driver

  • 0:23 - Start of application with Intel beta driver
  • 0:27 - Task-Manager showing the memory consumption rising to  (102,5MB) of the created application WITH Intel drivers (31.0.101.4125) installed

Part 5: Shows the creation of SSU report.

Please find the SSU report and the videos attached to this post.

 

Regards Simon

0 Kudos
DeividA_Intel
Employee
2,545 Views

Hello Simon_HE, 



I apologize for the late response, I appreciate the report and the videos shared. I will proceed with the investigation and as soon as I have any news I will let you know.


I appreciate your understanding.



Regards,  

Deivid A. 

Intel Customer Support Technician


0 Kudos
DeividA_Intel
Employee
2,488 Views

Hello Simon_HE, 

 

 

Thanks for your time. We have tried to replicate this issue based on the instructions that you provided. However, we did not get the same results, this seems more related to the configuration of the laptop.

 

I recommend you check this behavior with HP since they need to make sure that the drivers are compatible with their BIOS and system as well as to make sure that it contains the customizations approved by them.  

 

 

Regards,  

Deivid A. 

Intel Customer Support Technician 

 

0 Kudos
Simon_HE
Novice
2,426 Views

Hello Deivid,

thanks for your response.
Unfortunate that you were not able to replicate the issue on your end.
Did performing the steps above lead to smaller changes than the ones show in the video on no difference at all?
We will escalate the issue to HP as well.

 

Regards

Simon

 

0 Kudos
Simon_HE
Novice
2,150 Views

Hello @DeividA_Intel ,

i recently had the chance to test the issue on a non-HP laptop (Razer Blade 2022)
The observed behavior was the same, except slightly different numbers, probably due to different screen sizes.
On the Razer laptop i had ~20Mb with the intel GPU disabled and ~100MB with it enabled.
If needed i can collect more details on that system as well.

 

Regards

Simon

0 Kudos
Vyvoj
Beginner
1,980 Views

Hello, we have exactly the same problem with the RAM, which takes up 10x more memory than it should. We use a 12th Gen Intel(R) Core(TM) i9-12900K with integrated UHD Graphics 770 on Windows 10.

We use the WPF environment, which works fine for us, but when we got the mentioned CPU 12 gen, the Ram problem occurred.

If we uninstall the intel driver and leave the basic one from microsoft, the ram is fixed.

I see that you tested the problem on Windows 11, which I think is wrong and it would be good to test it on the mentioned HW & windows 10.

I hope for a quick reply and fix.

0 Kudos
Simon_HE
Novice
1,969 Views

Hey,

 

i was able to reproduce it on Windows 11 as well on my Razor Blade 2022.
The steps to reproduce were the same as on other computers, Windows 10 or Windows 11.
Sadly i don't think @DeividA_Intel will answer since i didn't get a reply to my last post.
It feels like they stop monitoring topics quickly and hope that we forget about it.

In addition, others have raised this issue as well: https://github.com/dotnet/wpf/issues/7704

It would be great if Intel finally got it's stuff together and starts investigating it rather than washing it off with "works on my machine"

0 Kudos
Vyvoj
Beginner
1,958 Views

Hey,

I see that it has been resolved since November xD.
So I'm at the end.


I even found that even if I switch the integrated graphics to the basic driver from Microsoft, I get a memory leak (datagrid) and it is 1mb per hour (now I'm waiting to see if it stops).

I really did not expect such a stick under my feet.
So the only thing that will help me is to add a graphics card for example from nvidia?

 

Have you tried contacting Microsoft or it is wrong way?

0 Kudos
Simon_HE
Novice
1,954 Views

The memory leak itself (higher consumption on Intel) is not resolved to my knowledge.
Consumption due to that issue is constant over time, it doesn't seem to be a memory leak, it's just consuming a multitude of memory from the start.
1Mb/Hour sounds like a memory leak on your side, probably due to keeping references or events somewhere.


Adding another GPU is one way to get rid of the issue.
We went with splitting the application and converting part of it to 64Bit so we don't run into out of memory issues at that part.
However, up to 10x the memory consumption is still not acceptable.

0 Kudos
Reply