Graphics
Intel® graphics drivers and software, compatibility, troubleshooting, performance and optimization
17450 Discussions

D435 camera won't publish infra2 topic

rodolfo76
Beginner
382 Views

An update or a wrong setting seems to have stopped infra2 ROS topic from being published. This is to work with rtabmap software. At first the camera worked perfectly with the mapping software, with infra1 and infra2 stereo image streams. Now I can't get camera to produce infra2 at any time. Is this from a software or firmware update? I am using the Nvidia Jetson TX1 board, Ubuntu 18.04, and ROS Melodic.

Labels (1)
0 Kudos
3 Replies
rodolfo76
Beginner
365 Views

Turns out this is simple: the USB cable being used wasn't 3.0 type. Cable as well as jacks must have blue plastic ends inside plug

 

 

oanteuhtoaheaoeuoaeu
306 Views

thanks for posting solution!

DeividA_Intel
Moderator
352 Views

Hello rodolfo76,  

  

 

Thank you for posting on the Intel® communities.   

 

 

I am glad to know that you noticed the source of the issue, and tracked it to the compatibility with the USB 3.0. Just a friendly advice, remember to add the Intel product that may be related to the issue (graphics, processor, wireless, etc).

 

Also, I recommend you to get in contact with the laptop/motherboard manufacturer to get more details of your computer and troubleshooting steps if needed.

 

Please keep in mind that this thread will no longer be monitored by Intel.

 

Regards,  

   

Deivid A. 

Intel Customer Support Technician 

 

Reply