Community
cancel
Showing results for 
Search instead for 
Did you mean: 
JDiav
Beginner
1,265 Views

DSA asks for latest version to run - but latest version is already installed?

DSA ran once - then the next day it says I need to install the latest version to run. I uninstalled the DSA - downloaded the current version (which was the same) installed it - and again it says I need the latest version.

What is up. I even tried the uninstall untillity - nothing seems to work - its' like its stuck in a loop.

0 Kudos
2 Replies
RAJU2529
New Contributor III
54 Views

go to this folder C:\Program Files (x86)\Intel Driver and Support Assistant

find DSATray.exe , go to properties, then details , see the version number

 

mine is 3.7.0.8 this is the latest

JDiav
Beginner
54 Views

Today is mysteriously ran... I think there was an issue with the site friday.

Reply