Graphics
Intel® graphics drivers and software, compatibility, troubleshooting, performance, and optimization
20623 Discussions

Dragon Age not able to run full-screen in Optimus

DBord2
Novice
5,389 Views

Hello, I tried to run Dragon Age Inquisition in full screen on my optimus laptop, also trying to override the scaling, without success.

Can you please confirm that this driver is not supposed to fix the issue of this game on Optimus systems?

Is there still hope that a driver with a specific fix shall be produced?

0 Kudos
22 Replies
ROBERT_U_Intel
Employee
3,766 Views

@ Dydog, For the scaling issue please be sure to change the Scaling options in the Intel HD Graphics Control Panel. to "Override Application Settings".

Thanks

Robert

TChow
Beginner
3,766 Views

Hi Robert,

Thanks for the reply re: Dragon Age Inquisition. I have a similar system to dydog and the rest of the folks in the below thread:

Looks like this update didn't fix our particular issue. We'll be keeping our fingers crossed for the next beta!

0 Kudos
ROBERT_U_Intel
Employee
3,766 Views

Optimus users, could you temporarily switch the Optimus settings to run the game on the Intel GPU? This will help us with our debug path.

Thanks

Robert

0 Kudos
DBord2
Novice
3,766 Views

Hello Robert,

on Optimus systems, if the game is forced to run on the integrated card, Dragon Age Inquisition works full screen.

Let me know if there is some kind of other test to perform or log to provide that could help.

Thank you

PS - Please note that there are other games, less famous than this, which have the same behaviour, according to reports on the net. For example GRID Autosport and Elite: Dangerous. Just the focus is on this one because of its wider spread.

0 Kudos
ROBERT_U_Intel
Employee
3,766 Views

@ dydog, Do you also have the latest drivers from NVidia installed?

Thanks

Robert

0 Kudos
DBord2
Novice
3,766 Views

I confirm I have installed Nvidia latest drivers, 353.06

0 Kudos
TChow
Beginner
3,766 Views

Same as dydog again. Forced DA Inquisition to run on the Intel Integrated card, and Fullscreen worked.. just that the game is now slow as molasses because it's not using the GeForce card. Also have the 4600/ 860M combo, using your beta drivers and NVIDIA's 353.06 drivers.

0 Kudos
ROBERT_U_Intel
Employee
3,766 Views

For the Dragon Age Inquisition issue, are you using a single display system or multiple displays?

For the You Tube video issues. Is there a specific video that exposes the issue? I tried several HD videos and do not see the issue, however, Chrome is at Version 43.0.2357.124 m on my tests system.

Thanks

Robert

0 Kudos
GChen33
Novice
3,766 Views

I got the upgrade to Chrome 43.0.2357.124 today and it still has the same issue. As far as I can tell, it is with every YouTube video I've tried. YouTube is using the HTML5 player and the WebM format with VP9 codec, are these the settings you have? If you right click on the video, it should say HTML5 player and if you click "stats for nerds" you can see the video format and codec. IE doesn't have this problem. IE uses the HTML5 player by default, but the codec is h.264 not VP9.

 

Might this issue be related to the VP9 acceleration feature? Robert, which processor are you using on your test system? I've tested on 2 Core M systems with this same issue and a previous poster with the issue was on a Broadwell Core i5, so it might be limited to only when it tries to use VP9 hardware acceleration on supported hardware. I can't find any way to get YouTube to use h.264 instead of VP9 in Chrome to test this though.

0 Kudos
ROBERT_U_Intel
Employee
3,766 Views

@ McChen, I am running the same setting as you with the exception of a Core I5 Haswell CPU. I am setting up other systems to test further.

0 Kudos
GChen33
Novice
3,766 Views

Ah OK, the Haswell CPU might explain why you're not seeing it, if the problem is really with VP9 hardware acceleration. Let us know how the tests on a Broadwell system goes. Thanks!

0 Kudos
DBord2
Novice
3,766 Views

Robert_U ha scritto:

For the Dragon Age Inquisition issue, are you using a single display system or multiple displays?

For the You Tube video issues. Is there a specific video that exposes the issue? I tried several HD videos and do not see the issue, however, Chrome is at Version 43.0.2357.124 m on my tests system.

Thanks

Robert

Single display system, just the integrated display in the laptop.

0 Kudos
TChow
Beginner
3,766 Views

Ditto, single screen for DA.

0 Kudos
MBalt1
Beginner
3,766 Views

I believe it does explain that. Youtube works fine on my Haswell i5 with the latest Chrome with the 4222 driver while my Broadwell i5 does not.

0 Kudos
ROBERT_U_Intel
Employee
3,766 Views

@ Dragon Age / Optimus users, could you please attach the Dispdiag logs for you system? This log will contain some basic info reg the resolution, scaling, etc applied from the game.

Steps to generate the logs:

1. Restart the system (this is required so that the logs doesn't have any old details)

2. Open Intel Graphics control panel and enable "Override Application Settings" for the display on which the game will be played (skip this if it is enabled already)

3. Launch the game where the centering issue is seen

4. Close the game once the issue is replicated

5. Open command prompt and type dispdiag -> this will generate a .dat file, post this file.

Since some users have stated that the issue doesn't happen if they force to game to run on Integrated graphics – we can request them to generate a log for systems with and without Optimus (NVidia drivers case as well (same steps above).

Thanks

Robert

0 Kudos
DBord2
Novice
3,766 Views

Hi Robert,

thank you for your continuos interest on this issue.

I followed your steps, run the game twice after every reboot, first time with the integrated Intel HD4600, then with the Nvidia GTX980m.

I attach the two dat files.

In both cases I forced the Full Screen, Override Application Settings in the Intel Control Panel.

Hope this helps to troubleshoot.

0 Kudos
ROBERT_U_Intel
Employee
3,766 Views

@ Dragon Age / Optimus users, do your systems have touch or non-touch displays?

Thanks

Robert

0 Kudos
DBord2
Novice
3,766 Views
0 Kudos
TChow
Beginner
3,766 Views

Much like the Champagne room, my system is non-touch

0 Kudos
ROBERT_U_Intel
Employee
3,557 Views

@ dydog

Thanks for the logs. It looks like they were taken with the system and the game at the native resolution of the display.

Could you create logs with non-native resolution when the centering issue is replicated (One with Intel rendering & one with NVIDIA rendering).

Thanks

Robert

0 Kudos
Reply