Graphics
Intel® graphics drivers and software, compatibility, troubleshooting, performance and optimization
Announcements
Welcome to the Intel Community. If you get an answer you like, please mark it as an Accepted Solution to help others. Thank you!
16840 Discussions

External screen resolution maxes out at 1920x1200?

jowi
Beginner
291 Views

I've bought a new Lenovo T15 laptop with Intel UHD 620. I bought this one because my previous company laptop, a Lenovo T490, also with intel uhd, worked perfectly with my DELL U3011 30" monitor. It could output the native 2560x1600@30Hz using a custom resolution over HDMI.

But this new laptop can not. For some reason, it maxes out at 1920x1200@60Hz. Even if i add a custom resolution, it will output 1920x1200, but scales the output so it fits 2560x1600... so it becomes unreadable and soft. The actual signal is 1920x1200, ALWAYS.

Why can't i use 2560x1600 over HDMI with this new laptop, while the old one could?

Or do i need to use the USB-C (the DELL does not have USB-C, it does have DisplayPort)

Please help, i really don't want to look at a stamp size, scaled output on my 30" monitor...

0 Kudos
4 Replies
jowi
Beginner
282 Views

I think i fixed it. The .inf driver file stated that over HDMI the max res. was 1920x1200... probably the former T490 laptop and it's Intel UHD driver discarded that restriction, and the newer driver does not and so maxes out at 1920x1200 over HDMI. 

After some fiddling with the inf file (inreasing the max res over HDMI to 2560x1600, like the displayport settings) and tricking Windows into accepting a now tampered with and basically unsigned inf file, the custom resolution in the intel driver actually work 🙂

JDMWDC
Beginner
265 Views

Appears to be a Lenovo problem. I bought a new Lenovo laptop and same issue: want to output 2k to my external monitor but it's limiting me to 1080. Intel's integrated graphics supports three 4k displays! Why would Lenovo bottleneck it?

 

Can you provide a step by step on how you fixed it?

jowi
Beginner
258 Views

I opened the .inf driver file for the monitor, which contains settings for hdmi and displayport:

...
[U3011_HDMI.AddReg]
HKR,"MODES\2560,1600",Mode1,,"29.0-113.0,49.0-86.0,+,-"
HKR,,PreferredMode,,"2560,1600,60"
HKR,,ICMProfile,0,"U3011.icm"

[U3011_DP.AddReg]
HKR,"MODES\2560,1600",Mode1,,"29.0-113.0,49.0-86.0,+,-"
HKR,,PreferredMode,,"2560,1600,60"
HKR,,ICMProfile,0,"U3011.icm"
...

 In the original inf file the hdmi mode was 1920x1200, i changed that to match the 2560x1600 from the DP input, and saved the file.

Now, if you try to use this updated driver, Windows complains that the signing does not match and the file is tampered with (which is correct 🙂 ) and will not install it. After some googling i found that you can put windows in test mode by entering:

bcdedit /set testsigning on

in a command prompt (RUN AS ADMIN!) and reboot windows.

If rebooted, you can now install the new driver, either from the manage/hardware settings or from explorer by right click ' install'... reboot the machine again and now i could use the custom resolutions correctly.

turn testmode off by entering bcdedit /set testsigning off in an elevated prompt & reboot.

If the command complains about secure boot, reboot the machine, go into BIOS and disable secure boot (turn it on again once done).

Also explained here in a video i found: https://www.youtube.com/watch?v=sJIJ02VCCoM 

Hope this helps you as well!

Maria_R_Intel
Moderator
219 Views

Hi jowi,


We are glad to know you found a solution, thank you for taking the time to share this fix, and hopefully, it may help other community members experiencing similar behavior. Since the thread is now solved, we will proceed to close it.

 

If you need any additional information, please submit a new question as this thread will no longer be monitored.

 

Best regards,

Maria R.

Intel Customer Support Technician


Reply