Community
cancel
Showing results for 
Search instead for 
Did you mean: 
GSlaz
Beginner
831 Views

Graphics Driver Bug - Windows glMapBufferRange Fail

Please check my app to reproduce the problem

https://www.dropbox.com/s/rti7ktbzkizkalp/Windows%20glMapBufferRange%20Fail.7z?dl=0

 

This is a Windows OpenGL application.

 

Run app on Intel GPU.

Updating UBO's uses 'glBufferSubData' by default, works OK.

Press SPACE to change updating to 'glMapBufferRange' and it starts to break.

 

App works fine on GeForce.

 

Code for updating UBO's:

glBufferSubData(GL_UNIFORM_BUFFER, 0, buffer.size, data);

 

and for MAP:

if(Ptr dest=glMapBufferRange(GL_UNIFORM_BUFFER, 0, buffer.size, GL_MAP_WRITE_BIT|GL_MAP_INVALIDATE_BUFFER_BIT))

{

  memcpy(dest, data, buffer.size);

  glUnmapBuffer(GL_UNIFORM_BUFFER);

}

 

Windows 10

Intel UHD 630

Driver: 25.20.100.6617

Capture-1.jpg

0 Kudos
14 Replies
Esteban_C_Intel
Employee
261 Views

Hello GSlaz,

 

Thank you for posting on the Intel® communities.

 

Could you please confirm if the issue persists using the latest graphics driver (26.20.100.7000)? If so, please run the Intel® System Support Utility for Windows* and share the results with me. You will find the tool at the following link.

 

Esteban Ch.

Intel Customer Support Technician

A Contingent Worker at Intel

GSlaz
Beginner
261 Views

Yes the problem also happens on latest driver version.

 

Btw. It's really problematic to test on latest drivers, because as a Dell laptop user, several times I try to install latest driver from your website, I get either:

-error driver not compatible with this system

-error computer does not meet minimum requirements

-dell driver will auto replace the intel driver without my permission.

 

Please solve those problems with Dell, it's frustrating.

 

But yes after a lot of fighting to try to install your driver, it has the same bug.

Esteban_C_Intel
Employee
261 Views

Hello GSlaz,

 

Please share with us the information requested on the following link.

 

 

Esteban Ch. 

Intel Customer Support Technician

A Contingent Worker at Intel

GSlaz
Beginner
261 Views

attached

Esteban_C_Intel
Employee
261 Views

Hello GSlaz,

 

Thank you for your response, 

 

Please allow us to research this problem and as soon as we have an update on this we will let you know. 

 

I think is also worth mentioning that the drivers provided by Intel® are generic and the correct way to install them is uninstalling any other graphics driver until you get the Microsoft® Basic Adapter on the device manager, so you can install the latest Intel® graphics driver.

 

Thank you for your patience and understanding on this matter. 

 

Esteban Ch. 

Intel Customer Support Technician

A Contingent Worker at Intel

GSlaz
Beginner
261 Views

I think is also worth mentioning that the drivers provided by Intel® are generic and the correct way to install them is uninstalling any other graphics driver until you get the Microsoft® Basic Adapter on the device manager, so you can install the latest Intel® graphics driver.

Kindly please tell your software engineers that this should be done automatically by the driver installer.

The user should have an enjoyable experience, instead of being greeted by a bunch of problems and errors.

Esteban_C_Intel
Employee
261 Views

Hello GSlaz,

 

Were you able to check the recommendations provided on the previous post? If you need further assistance, please let us know.

 

Esteban Ch.

Intel Customer Support Technician

A Contingent Worker at Intel

Esteban_C_Intel
Employee
261 Views

Hello GSlaz,

 

Afterward testing, we found similar errors running on 3rd party video cards, which indicates that the issue might not be related to our graphics driver only.

Are you able to reproduce this issue using a commercial application?

 

Esteban Ch. 

Intel Customer Support Technician

A Contingent Worker at Intel

GSlaz
Beginner
261 Views

The code works fine on GeForce 1050Ti

But doesn't work on Intel GPU.

I've also tested the same code on Android and works fine there too.

Please fix

Esteban_C_Intel
Employee
261 Views

Hello GSlaz,

 

We would like to inform you that we were able to replicate the issue with the following systems configuration: A computer with Intel® HD Graphics 620 and also a ring with an X299 motherboard and a GTX 1060. You can see on the attached video the issue replication with a GTX 1060.

 

Since the issue is not occurring on a commercially available app and only on the code provided, we recommend you posting this issue on the Intel® Software and Developer Zone Forum and a developer should jump in to assist you.

 

Esteban Ch.

Intel Customer Support Technician

A Contingent Worker at Intel

GSlaz
Beginner
261 Views

The issue on your video is different than from my post. Just because another driver for another GPU has some other bug, you're going to ignore the fact that your own driver has a bug too. This is disappointing that reporting a driver bug from a developer perspective is being juggled around without just fixing it.

GSlaz
Beginner
261 Views

I've posted the source code in previous post, do you see any problem with it? Because I don't.

RonaldM_Intel
Moderator
261 Views

Hello,

 

I would like to let you know that we have sent this information to our driver debug team for review under bug report # 14010085183. I cannot promise you any particular outcome, but as soon as we have more information on it I'll update this thread.

 

Best Regards,

Ronald M.

RonaldM_Intel
Moderator
261 Views

Hello @GSlaz​ 

I would like to provide an update.

Our devs confirmed that a fix for this issue has been checked-in our driver code.

Please stay tuned for the next two upcoming driver releases (circa January 2020) as any of those could contain the new code fix.

 

Thank you for your patience and also for taking the time to report this issue to Intel.

 

Best Regards,

Ronald M.

Reply