Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
378 Views

HD 630 settings not applied on monitor through USB-C

Jump to solution

Hello, my laptop is a Dell G7 7588. When I plug my HDMI external monitor through my Anker USB-C dock, the colors are washed out. I see in the graphics control panel that the gamma setting now only appears on the Video section. I see the gamma is on "Limited", which is causing the washed colors. But changing that to Full doesn't seem to do anything. And I tried any other option on the section and nothing works. No brightness, contrast, color settings apply. I can move the sliders, but nothing happens. I think this is a driver issue since this didn't happen before I factory reseted my laptop and updated both Windows (2004) and all the Intel drivers. Is this a known issue?

0 Kudos

Accepted Solutions
Highlighted
Moderator
234 Views

Hello HernanBiasotti

Thank you for your response and for attaching a new report.


After checking it, we could confirm that the Connector Type is being detected as "DisplayPort™, thus, it is explaining the behavior about the option disappearing from the Intel® HD Graphics Control Panel based upon the facts we previously explained.


Regarding your question, we hope to add the gamma option in the future; however, just to clarify, it is expected to be added in future releases of the Intel Graphics Command Center app (not necessarily tie to driver updates).


Should you have additional inquiries, please do not hesitate to contact us back.


Note:

For more information about the Intel® Graphics Command Center, please review the Frequently Asked Questions (FAQs):

https://www.intel.com/content/www/us/en/support/articles/000032768/graphics.html


Best regards,


Andrew G.

Intel Customer Support Technician


View solution in original post

0 Kudos
10 Replies
Highlighted
Moderator
361 Views

Hello HernanBiasotti


Thank you for posting on the Intel® communities.


Regarding the behaviors you described and the settings you are changing, we would like to explain and recommend the following:


1- In the Intel® HD Graphics Control Panel the "Video" section only applies to Motion Video played on the system, not on the Windows® desktop and apps.


2- Please test the monitor and the computer with a straight-through connection HDMI-to-HDMI with a single cable since the Quantization range options only apply to native HDMI. Please let us know the outcome.

Please bear in mind that Intel® does not recommend the use of any kind of adapters. This is because we cannot test all of them, so we cannot guarantee that these are going to work. For more information please check the following links:




3- Finally and as the best approach, we recommend looking for the Monitor On-Screen Display (OSD) i.e. the menu, for an option to manually set the correct black levels. Not all monitors have it and if they do, they may call it differently so we kindly recommend you checking this further with your monitor manufacturer.


Best regards,


Andrew G.

Intel Customer Support Technician


0 Kudos
Highlighted
Beginner
358 Views

Hello @AndrewG_Intel , thanks for answering. 

I can't check the 630 through direct HDMI, because the HDMI port of the laptop is controlled exclusively by the discrete video card, an NVIDIA GTX 1060. That monitor shows the correct gamma level, since I can change it freely to "Full" in the Nvidia control panel.

I can't see how the quantization range only applies through direct HDMI, I was able to change it to Full before my factory reset and windows update. This is something new. I used to be able to set it, using the same adapter connected to the same monitor. So, what changed? The windows version and the drivers, probably. I believe it's a software issue. It has to be, since i WAS able to set the correct gamma before.

0 Kudos
Highlighted
Moderator
351 Views

Hello HernanBiasotti

 

Thank you for your response and the details provided.

 

Regarding your concerns, with the most recent drivers (xx.xx.100.xxxx and newer) Quantization Range Option will only be visible if the video output on your computer is native HDMI.

Using a DisplayPort (DP) video output or adapters such as DP-to-HDMI or USB Type-C to-HDMI will cause the option to disappear from the Intel® Graphics Control Panel > Display > General Settings location. This is not a software issue, it is expected behavior and it is publicly documented in the following link:

https://www.intel.com/content/www/us/en/support/articles/000029572/graphics.html

 

Nevertheless, could you please provide the following information to check this further:

 

1- Do you know what the graphics driver and operating system versions were before you performed the factory reset?

 

2- With all the displays/monitors connected to the computer, please provide a Report for Intel® Graphics Drivers following the steps on the below link:

https://www.intel.com/content/www/us/en/support/articles/000005848/graphics-drivers.html

 

3- DxDiag* report following these steps:

  • In the keyboard, press WinLogo key + R.
  • In the Run box please type dxdiag and hit Enter.
  • Click on Save All Information.
  • Open the report.
  • Use the option "save all information" to save the .TXT file.
  • Attach the report .TXT file to this thread. 

 

4- We understand that you are not able to test straight-through connection HDMI-to-HDMI and we noticed you mentioned the USB-C dock worked in the past. However, we are not able to guarantee proper functionality of adapters or dockings. Does your monitor has a DP port or do you have the option to test another display/monitor with DP to test direct connection DP-to-DP (or USB-C with DP mode) to rule out an issue with the adapter and to check the color quality behavior?

 

5- Please provide some screenshots from the Intel® HD Control Panel and/or the Intel® Graphics Command Center showing the Display color options you have available:

 

Note: To upload and attach a file, use the "Drag and drop here or browse files to attach" dialog below the edit box.

 

Best regards,

 

Andrew G.

Intel Customer Support Technician

 

0 Kudos
Highlighted
Beginner
318 Views

Hi @AndrewG_Intel . A workaround I was able to find was roll back to a pre-xx.xx.100.xxxx driver, change the video setting (which according to you only applies to video, but at least not in this case) gamma to Full, and then changing the refresh rate to something, anything, and then setting the original refresh rate. That sets the gamma correctly. This is a WORKAROUND, and clearly not the right way to do it. Can't I just set this in some way on newer drivers? I don't want to be stuck on an old and possibly dangerous driver.

0 Kudos
Highlighted
Moderator
309 Views

Hello HernanBiasotti

Thank you for your response.


Regarding your questions and to check further the behavior you described. Could you please provide screenshots of the settings you have changed and that you have available in the Intel® HD Control Panel (if possible screenshots when running the previous driver and the newer driver) and the reports requested in our previous post (DxDiag* and Report for Intel® Graphics Drivers)?


Also, could you please confirm the "pre-xx.xx.100.xxxx" driver version that you used to perform the rollback for this workaround?


Best regards,


Andrew G.

Intel Customer Support Technician


0 Kudos
Highlighted
Beginner
302 Views

Hello @AndrewG_Intel  , I'm attaching the reports and a few screenshots on my current driver. On the first one, I highlighted the only place where I can change gamma. If I apply it, nothing happens. In order for it to apply, I need to change the refresh rate highlighted on screenshot #2. Then it applies. I have no gamma options on the display section of the control panel. On the newer drivers and control panel, the options are exactly the same.
I do believe this is a driver issue, not sure if it's only the graphics driver or maybe a chipset driver? I'm saying this because I had even newer graphics drivers before factory resetting and it used to work.

0 Kudos
Highlighted
Moderator
268 Views

Hello HernanBiasotti

Thank you for your response.


We are glad to know the workaround worked for you, it is similar to the one described in the links previously shared.


The Quantization Range option was available in older drivers for non-HDMI outputs, however in actual code it wasn't applying any change because by design it has always only been enabled for native HDMI, hence our developer team "fixed" this so the option no longer appears on non-HDMI outputs.


We understand the situation and there is already internal work on getting the "Gamma" setting enabled in Intel Graphics Command Center; however, this is a work in progress and we cannot provide an ETA (Estimated Time of Arrival) for implementation.


Also, we wanted you to provide us with a Report for Intel® Graphics Drivers with all the displays/monitors connected to the computer in order to confirm the video output since non-HDMI® connections will cause the option to disappear from the Intel® Graphics Control Panel; however, the report only shows details about the built-in display, thus the report was run without the external display connected or the USB-C adapter is limiting the information retrieved from the display.


To sum up, this is not a driver issue, this behavior is expected by design and we are working to add this feature in the Intel® Graphics Command Center, but we do not have an ETA yet.

Thank you very much for your feedback.


Best regards,


Andrew G.

Intel Customer Support Technician


0 Kudos
Highlighted
Beginner
253 Views

Hi @AndrewG_Intel , I'm attaching the reports with every monitor plugged in.

So, in the future, I should be able to update drivers and keep the gamma working correctly? (no ETAs, I know)

0 Kudos
Highlighted
Moderator
235 Views

Hello HernanBiasotti

Thank you for your response and for attaching a new report.


After checking it, we could confirm that the Connector Type is being detected as "DisplayPort™, thus, it is explaining the behavior about the option disappearing from the Intel® HD Graphics Control Panel based upon the facts we previously explained.


Regarding your question, we hope to add the gamma option in the future; however, just to clarify, it is expected to be added in future releases of the Intel Graphics Command Center app (not necessarily tie to driver updates).


Should you have additional inquiries, please do not hesitate to contact us back.


Note:

For more information about the Intel® Graphics Command Center, please review the Frequently Asked Questions (FAQs):

https://www.intel.com/content/www/us/en/support/articles/000032768/graphics.html


Best regards,


Andrew G.

Intel Customer Support Technician


View solution in original post

0 Kudos
Highlighted
Moderator
201 Views

Hello HernanBiasotti


We are checking this thread and we noticed there are no new questions or comments, and since the thread has been marked as "Solved", we will proceed to close it now. We will continue working to add the gamma option in the future.


It has been a pleasure to assist you with this inquiry. If you need any additional information, please submit a new question as this thread will no longer being monitored.


Sincerely,


Andrew G.

Intel Customer Support Technician


0 Kudos