Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
55 Views

Hi ! I have an issue with my predator helios 300. The issue is with the intel drivers .

 I have updated them rolled them back, uninstalled, disabled, reinstalled them. The issue is the there is a lag in the normal usage like in the cursor movement, opening the browser. The scrolling is very laggy but the games work absolutely fine as thwy work on gtx 1060. So when i disable my intel drivers in the device manager the lag is gone everything is smooth but Everytime i turn them on lag persists. I have even reset to factory setting . Nothing is working

I have Intel uhd 630

I7-8750h

16 gb ram

Gtx 1060 6gb

Please help​

0 Kudos
3 Replies
Highlighted
Honored Contributor II
5 Views

Re: Hi ! I have an issue with my predator helios 300. The issue is with the intel drivers .

Go to https://downloadcenter.intel.com/product/98909/Intel-HD-Graphics-630

Hit "show more" button.

Then you can select from 20+ driver versions to try.

 

There seem to be a dozen different "Helios 300"

Download Intel® System Support Utility for Windows and upload a report to find out your particular model.

 

0 Kudos
Highlighted
Beginner
5 Views

Re: Hi ! I have an issue with my predator helios 300. The issue is with the intel drivers .

I have tried several mate! Could it be the bios issue ?​

0 Kudos
Highlighted
Honored Contributor II
5 Views

Re: Hi ! I have an issue with my predator helios 300. The issue is with the intel drivers .

Probably. That's why we need to know your exact SKU.

0 Kudos