Community
cancel
Showing results for 
Search instead for 
Did you mean: 
CWalk3
Beginner
2,604 Views

Intel Atom z2760 Lenovo Mixx - Windows 10 - Creators Update Graphics Update Driver -1177 Working with Tweaks

Hi All,

This post is in response to the following Posts that previously existed.

/message/320793 https://communities.intel.com/message/320793

 

/message/367972 https://communities.intel.com/message/367972

Many of you (once) were interested in getting this driver to work with Windows 10,

I finally got around to trying to install the Creators Edition, I Downloaded it onto my Lenovo Mixx (an old atom 2760)

 

Firstly, I downloaded the Creators update ISO and extracted this to my USB stick, (the Home/Pro edition)

 

Whenever the system began (after the copy of the WIM part) it would get to the "Getting Devices ready screen," , would take an age, (not hung) then eventually reboot seeming to be carrying on as you would expect.

 

Only to then arrive at a screen saying I would basically need to reinstall windows again!

 

I tried two different Downloads and came to the conclusion in my own mind this was something wrong with the way the latest sysprep had been done by Microsoft, (I also secretly blamed the store (app) and how this works with the whole sysprep process!)

 

Because of this I was sure previous versions of Enterprise edition handled store and edge differently,

 

(on some builds, I'm not even sure they existed as aps, I might be confusing with Server Editions though! anyway!!)

 

I decided to download enterprise edition, and install the same Creators edition verison of enterprise,

 

Interestingly the WIM file on the ISO is only a few kb difference.

This installed! and I was presented with a setup page! (which I probably wasn't expecting if I'm honest!)

 

Now we've all got to this point with different build of Windows 10 I'm sure, and the above is just my own experience,

 

The point is if you get this far, then try the below......

 

And this same solution might work for 14393 builds also…

 

Firstly, you would need to install your chipset Drivers the same as previous build, personally id remove the graphics driver from the package once download (edit the Config.xml file to remove this)

Basically, download from here,

 

https://download.lenovo.com/consumer/mobiles/pf132w8132.exe https://download.lenovo.com/consumer/mobiles/pf132w8132.exe

 

run as admin, then run the extraction to complete,

 

untick the install.

 

click finish

 

browse to the location, (default is here)

 

C:\Drivers\Platform Driver (Intel, Realtek, Bison, Chicony, Liteon)

right click the config.xml file and edit with notepad

 

at the bottom, is this

 

 

55702.inf

 

remove what I've shown above then close the file... (save it!)

 

Now execute the installer, this will install all but Graphics.

This Graphics driver doesn't seem to work on the RS2 Branch's any longer anyway, (1168 bundled), but there is a solution!

you'll also need to install your Wi-Fi, and you Bluetooth driver from Lenovo site also.

https://download.lenovo.com/consumer/mobiles/wlan132w8132.exe https://download.lenovo.com/consumer/mobiles/wlan132w8132.exe

 

https://download.lenovo.com/consumer/mobiles/bt132w8132.exe https://download.lenovo.com/consumer/mobiles/bt132w8132.exe

As this is Creators Edition of Windows 10 (a RS2 branch) from we can get the video driver from Microsoft, (still version 1177 with the same glitches as before)

 

Go to

 

http://www.catalog.update.microsoft.com/ http://www.catalog.update.microsoft.com,

 

(now normally I would never use Microsoft drivers as their horrible, but I'll make an exception in this case)

 

in the search field type (top right) enter

 

VEN_8086&DEV_08C7

 

This is the ID of the Graphics Card.

 

a list of drivers will appear,

 

under the products view it's important to find "Windows 10 RS2 and Later Servicing Drivers for testing" the version of 9.14.3.1177 - 11/15/2013

 

Download the file, it's about 12.5MB .CAB file,

 

once you have this also Download the following file version too.

 

9.14.3.1176 - 11/8/2013

extract the 1177 cab file and go to device manager, and point the video driver to this location, reboot!

 

You will now have video that is accelerated but suffers from the "Video TDR Failure" BSOD when you try to play any videos at all, (once you've added come codec's anyway. 😉 )

 

Try and play a video to see if I'm correct!! please I'd like to know....

now extract the 9.14.3.1176 - 11/8/2013 Cab file and place the following 3 files on your USB windows 10 bootable Media that you installed from, (in a folder you know)

 

igdperf32.sys - around 4kb

 

igdkmd32.sys - around 989kb

 

igddim32.sys - around 397kb

if you run properties on these 3 files 2 will have version stamps of 1176 (the other doesn't have one, the 4kb file )

now boot your device again from the setup media, answer the language page, and don't click install , press Shift and F10

 

this will open a CMD window...

 

find the drive letter of you Stick, (with the 3 files in,) go into this directory (using CD), and copy them to the following location..

 

c:\windows\system32\drivers

 

you command will likely look something like this.

copy igd*.sys c:\windows\system32\drivers

 

(this is only an example, you will need to find the stick files!)

 

you will be prompted to overwrite the files say yes, assuming this goes well, reboot your machine.

try playing the same video again, does it work now!? Hopefully YES, is the answer.

 

I couldn't spot any glitches in and apps any longer and the device is running the best it's ever ran (including 8.1) (I've also installed Window Media Centre, as I love it he he) and that plays brilliantly!! also, I've got office 2016 subscription working perfect too.

I personally see no difference in using this process on another z27XX machine,

 

for example, WIKI says these are based on the same

 

Asus VivoTab, Asus VivoTab Smart,HP Envy x2, HP ElitePad 900,, Latitude 10, Lenovo Thinkpad Tablet 2, Lenovo IdeaTab Lynx,

 

Samsung Series 5 Slate (Samsung ATIV Smart PC) Acer Iconia W510 ZTE V98, Acer Iconia W3, Samsung ATIV Tab 3

 

You will need the chipset drivers from the manufacturer though, as some are different for other device (like Camera)

 

as all the files are easily available im not going to provide them unless your really stuck!

Im sure their must be a glitch with 1176 .sys files otherwise why did th...

Tags (2)
2 Replies
idata
Community Manager
475 Views

Hello Walkerc79,

 

 

Thank you for contacting the Intel community.

 

 

We appreciate you have taking your valuable time to share this valuable information with the community and I hope this can help out others that are searching for similar information.

 

 

Best wishes,

 

 

 

Ivan U.

 

GAcco
Beginner
475 Views

What's the significance of doing the copying while booted from the installation media?

I tried this without booting from the installation media, and it just prevents the driver from loading due to something about the driver not being signed. (Incidentally, this does make videos work.)

Reply