Intel® graphics drivers and software, compatibility, troubleshooting, performance, and optimization
19846 Discussions

Intel Driver & Support Assisant failing to download updates


Experiencing an odd issue with the Assistant. Have a new Tuxedo InfinityBook Pro 14 gen 7 where I initally installed Windows 11 and Intela Driver Assistant which worked fine.

When installed Window 10, there installed few updates normally and few day later after when new graphics update was offered it was failing to download it. It fails in download process, seemingly after multiple attempts, it starts, reaches 20-30 %, than state changes back to "Starting..", downloads again to 10-20 %, and then again back to "Starting.." state. Cycles like this some 5 times and than changes back to state with "Download" button appearing as if nothing was done.

I ended up downloading graphics driver manually and installing. Now, as some time passed and another graphics driver ( was released I started getting this same issue also in Windows 11.

I have tried using Chrome and MS Edge with cleared cookies, cache, no extension and incognito mode, but the issue remains. I tried to look throught logs, but not spotting anything pointing to a problem there. I have attached archived Logs folder from both the Windows 10 and 11.

What could be a problem?

Labels (1)
0 Kudos
1 Reply

It appears this issue has been solved as of  IDSA version

0 Kudos