Showing results for 
Search instead for 
Did you mean: 

Intel Family Graphics Driver: does not meet minimum requirements

I discovered through the Intel Driver and Support assistant that I have a new graphics driver update for my laptop (my driver has never been updated on this PC, due to me having issues like this). When I press the download and install button at the top of Driver and Support it begins the install. Once it seemingly finishes extracting an error window pops up saying This computer does not meet the minimum requirements for installing the software, I tried both downloads for 64bit on the Intel Graphics Driver 4400 page and both of those gave me the same error.

Is there any way that I can update my Intel (r) HD Graphics 4400 card or does this error mean I am stuck with the graphics driver from 2014 until the rest of my days?

I'm running windows 8.1 64bit ASUSTeK COMPUTER INC. TP500LA. Intel i5-4210U CPU @ 1.70GHz Intel HD Graphics Family Driver version from 11/11/2014 8gb RAM

Tags (1)
0 Kudos
2 Replies
Honored Contributor II

Did it offer driver v4963?

Latest driver for your system is here: Download Intel® Graphics Driver for Windows 7*/8.1* [15.36]

You would have to upgrade to Windows 10 to get further driver updates.

OS support

4th Generation Intel® Core™ Processors and related Intel® Pentium® Processors/Intel® Celeron® Processors:

Windows® 10, 64-bit and 32-bit only

source: Download Intel® Graphics Driver for Windows* [15.40]

15.36 (HSW systems using Windows 7, 8.1)

This Branch has reached end of maintenance

HSW systems can upgrade to Windows 10 and use the 15.40 Code Branch.

source: INTEL-SA-00077


sounds like the issue i also have which is not out fault but im my case the fault of the given driver update not having an entry inside to match my HD4600, see my thread as well.

heres a pic of their driver updates .inf file showing entries for my HD4600 and my older currently installed intel update showing a totally different ID for the HD4600 which is why mine never updates, automatically or manually, im guessing you might be the same as its not just my thread and yours, ive seen others with the same "not compatible" issue.

My ID for the HD4600 = iHSWD_w81

ID's in their update package for the HD4600 = iHSWGT2D and iHSWGT2M

Im guessing this is why mine wont update as my ID doesnt match the ones in their update package, maybe you can check your own ID in device manager and compare to the entrys in their driver update .zip file you are given, chances are they are different when they shouldnt be, if this can be fixed with just editing in my ID into their .INF file then thats great but i dont want to do it without an ok incase i make matters worse.