Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Gavrilov__Kirill
Beginner
1,303 Views

Intel HD Graphics 630 reports OpenGL 4.5 but does not export necessary functions

Trying initializing OpenGL 4.5 on Intel HD Graphics 630 fails with the following message indicating that functions defined by OpenGL 4.5 Core Profile specs are missing:

OpenGL info:
  GLvendor: Intel
  GLdevice: Intel(R) HD Graphics 630
  GLversion: 4.5.0 - Build 23.20.16.4973
  GLSLversion: 4.50 - Build 23.20.16.4973

  Error! OpenGL context reports version 4.5 but does not export required functions (glGetnCompressedTexImage) for 4.5

 

0 Kudos
4 Replies
Roush__Elliot
Beginner
1,303 Views

I'm having the same issue using the latest drivers for my Intel HD 630 (version 26.20.100.7000).

Much of OpenGL 4.5 is supported, but I'm unable to load some functions from 4.5, such as glCreateTextures: https://www.khronos.org/registry/OpenGL-Refpages/gl4/html/glCreateTextures.xhtml

Can we get a response on OpenGL 4.5 support? The support page states this card should be supporting 4.5.

 

guillaumeqr
Beginner
1,303 Views

I have the same problem as Gavrilov. It's the very first time I encounter this kind of issue. I am working with PythonOCC, OpenCascade. Any help would be useful.

frank2288
Beginner
209 Views

Same problem here. Could not find a solution. Any help from Intel? 

 

I'm working with PythonOCC too, problems with Display functions. 

 

Same error 

Magres
Beginner
135 Views

I confirm this bug. Intel HD 620. Latest drivers from July 2021.

I always considered Intel as a reference implementation and it's starting to disappoint me.

Reply