Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
852 Views

Intel Iris Plus Graphics worse than Intel UHD graphics?

Jump to solution

Hello, I had the notebook HP Envy x360 15-dr1701ng which contains the Intel chip i5-10210U. This chip has Intel UHD graphics, but the notebook also had a NVIDIA graphics controller, which can be switched off.

Now i have a "better" notebook, the HP Envy 15-ed0779ng which contains the Intel chip i7-1065G7 with Intel Iris Plus graphics.

With both notebooks, I played the game Jurassic World Evolution. The old notebook showed a good picture quality, regardless of wether I switched the NVIDIA chip on or of. When it was switched off I had much lag and the game was lagging, but the picture quality was the same!

So now I play with the new notebook and I assumed, that the Intel Iris is better than the old Intel UHD graphics. Positive is, there is no lagging in the game, but the picture quality is very bad. Everything seems to be blurred and even worse than with the Intel UHD graphics, although I put up all graphic settings in the game.

I have the latest driver from July 8th, but this also doesn't help. Is there any setting, I have to do? What did I miss?

I'm sorry for my bad english, I'm from germany.

0 Kudos

Accepted Solutions
Highlighted
600 Views

Hello Ed_von_Schleck, 

 

Thank you very much for the update. 

 

It is good to hear that we at least found the cause of this behavior. As we had mentioned, it is recommended to use the settings available on gameplay.intel.com. Based on your Intel® processor and game; these settings advised using the Anti-Aliasing off. This is since Intel® tests the possible configurations and selects the ideal ones for gaming's best experience, so it is highly recommended to use gameplay.intel.com for gaming with Intel® graphics. 

 

Regards, 

 

Sebastian M.  

Intel Customer Support Technician.  


View solution in original post

0 Kudos
11 Replies
Highlighted
831 Views

Hello Ed_von_Schleck, 

 

Thank you for posting on the Intel® communities.   

 

In order to better assist you, please provide the following: 

 

1. Run the Intel® System Support Utility (Intel® SSU) and attach the report generated:  

  • Open the application, check the "Everything" box, and click on "Scan" to see the system and device information. By default, Intel® SSU will take you to the "Summary View".  
  • Click on the menu where it says "Summary" to change to "Detailed View".  
  • To save your scan, click on "Next", then "Save".  
  • Use the paperclip icon to attach the report to the thread. Please note that only one file can be attached at a time. 

 

2.  Get the DXDIAG  report and attach it in a .txt file: 

  • Go to Start > Run or Windows Key + R.   
  • On the Run prompt, type "dxdiag" then click OK.   
  • On the DirectX Diagnostic Tool window, click on Save All Information.   
  • Browse to a folder, type in a filename then click Save.   

 

3. Do you have a record (video, picture, etc) of the video quality of your previous PC? If yes, can you share it with us along with the video quality of the new PC? In case you do not have the previous PC's one, please share just the new one. 

 

Regards, 

 

Sebastian M.  

Intel Customer Support Technician.  


0 Kudos
Highlighted
Beginner
815 Views

Hi, I attached the 2 reports you wanted (SSU.txt and DxDiag.txt).

 

The attached pictures show the graphics with the old and the new notebook. In my opinion there is nearly no difference between NVIDIA and Intel UHD on the old notebook, but on the new one the details are worse.

I'm sorry I don't have a video, I made these screenshots on the weekend and yesterday my old notebook was picked up, so I can't use it anymore. I could do a video with the new notebook, but I don't know how I should do that.

0 Kudos
Highlighted
803 Views

Hello Ed_von_Schleck, 

 

Thank you for your reply, please provide the following details and check the information below: 

 

1. Please include a screenshot of all the settings that you are currently using to play this game.  

2. Bear in mind that as you mentioned, your previous PC used to have hybrid graphics, even though the discrete graphics card was disabled, it could remain enabled for different functions depending on the manufacturer's design, can you please explain how did you disable the dedicated graphics card? In addition to it; we would like to try replicating this behavior with the settings you are trying to use for the gameplay.  

 

Regards, 

 

Sebastian M.  

Intel Customer Support Technician.  


0 Kudos
Highlighted
764 Views

Hello Ed_von_Schleck,  

 

Were you able to check the previous post and get the information requested? Please let me know if you need more assistance.   

 

Regards,  

  

Sebastian M.   

Intel Customer Support Technician.   


0 Kudos
Highlighted
Beginner
748 Views

Hi, sorry I was very busy the last days.

 

As I wanted to get the information for you, I saw that I made a mistake with my graphics. So I caused the main part of the problem by myself.

I only have set the settings in the menu "Grafik" (english: "graphics") to high, but didn't notice until now, that there is also a menu "Anzeige" (english: "screen"). There I can set the resolution, so I have set it to FullHD (1920 x 1080) and the "problem" was solved.

I don't know why this setting was automatically set to FullHD after installation with the old notebook (because I never changed that before) and with the new one this was not the case, but ok...

I'm embarrassed about that now, normally I'm not as blind like that. 😉

 

So now the details are as they were with the old notebook, that's very good and the Intel Iris graphics does it very much smoother than the Intel UHD graphics.

The only thing I additionally remarked, is that the movement of the people (especially their legs) walking along the path is rather blurred. On the old notebook this also wasn't the case, but perhaps the Intel UHD was so slow, that I only couldn't see that there because of much jerking.

0 Kudos
Highlighted
692 Views

Hello Ed_von_Schleck, 

 

Thank you for the information, it is good to know that the resolution change fixed the previous problem, I would also like to perform more testing about that behavior you see on the leg movement, can you please provide the following? 

 

  • Can you provide a video of the behavior (you can also use YouTube or any cloud so you can provide a public link) and a screenshot of the game settings used when having this behavior?  
  • In case you feel it necessary, please provide a detailed step by step to replicate this behavior.  
  • Additionally, you can try the recommended settings for this game and your Intel® processor available on gameplay.intel.com. (See the attachments) 
  • Just in case, a new BETA driver has been released, you can try doing a clean installation of this driver and let us know about the outcome: 
  1. Download the latest DCH driver and save it on the computer. 
  2. Disconnect from the Internet so no new drivers are automatically installed by Windows Update. 
  3. Uninstall the driver and the Intel Graphics Control Panel from Control Panel > Programs and Features
  4. Restart the computer. 
  5. Confirm in Device Manager > Video Adapters the controller is listed as 'Microsoft Basic Display Adapter' > if not, repeat steps 2 through 4. 
  6. If the adapter continues to be listed as ‘Intel HD Graphics’ or similar, and no other Intel Graphics driver is listed under 'Programs and Features' for removal, then it means Windows has switched to a previously installed Legacy driver. At this point we can remove Legacy drivers from Device Manager
    1. Right-click on 'Intel HD Graphics' or similar, and select 'Uninstall Device
    2. In the pop-up window make sure 'Delete the driver software for this device' is checked. 
    3. Click on 'Uninstall'. 
    4. Restart. (Repeat steps 6.1.1 through 6.1.4 until the device gets listed as 'Microsoft Basic Display Adapter') 
  7. Install the DCH driver that was downloaded on step 1. 
  8. Restart the computer. 
  9. Reconnect to the Internet. 

 

Regards, 

 

Sebastian M.  

Intel Customer Support Technician.  

 

0 Kudos
Highlighted
670 Views

Hello Ed_von_Schleck,  

 

Could you check the previous post and follow our recommendations? Please let me know if you need more assistance.   

 

Regards,  

  

Sebastian M.   

Intel Customer Support Technician.   


0 Kudos
Highlighted
Beginner
649 Views

Ok I didn't assume, that the expected performance of the graphics of this core is that low for this game.

I have set it even higher (see attached video and settings), and the suggested resolution is too low in my opinion (I run with FullHD). So I think this is the reason why I see that blurred legs. I have high resolution and high graphics settings, because it looks even better than with your suggestion and the performance is ok. So I will turn them lower a little bit and see what will happen.

Thanks for your help so far!

0 Kudos
Highlighted
Beginner
647 Views

Well, finally I found out which setting is causing the blurred legs an arms: It's the Anti-Aliasing.

Independent from all other settings (I set them all to the highest possible value only for this test!) this is the only setting I changed in the attached 3 videos:

When Anti-Aliasing is switched off, there is nothing blurred

When it is set to TAA, it is a bit blurred.

When it is upscaled TAA, it is blurred very strong.

 

I don't know if this is an issue or only caused by a lack of performance of the core, but finally this is the cause of my problem, so I will switch that option off now and then find the best graphics settings for my system.

0 Kudos
Highlighted
601 Views

Hello Ed_von_Schleck, 

 

Thank you very much for the update. 

 

It is good to hear that we at least found the cause of this behavior. As we had mentioned, it is recommended to use the settings available on gameplay.intel.com. Based on your Intel® processor and game; these settings advised using the Anti-Aliasing off. This is since Intel® tests the possible configurations and selects the ideal ones for gaming's best experience, so it is highly recommended to use gameplay.intel.com for gaming with Intel® graphics. 

 

Regards, 

 

Sebastian M.  

Intel Customer Support Technician.  


View solution in original post

0 Kudos
Highlighted
535 Views

Hello Ed_von_Schleck, 

 

I hope the previous information was useful to you.


As we mentioned, it is highly recommended to use the settings available on gameplay.intel.com for the best experience at gaming.


I will proceed to close this inquiry, however; if you need further assistance, please submit a new question as this thread will no longer be monitored.

 

Regards, 

 

Sebastian M  

Intel Customer Support Technician  


0 Kudos