Graphics
Intel® graphics drivers and software, compatibility, troubleshooting, performance and optimization
Announcements
This community is designed for sharing of public information. Please do not share Intel or third-party confidential information here.
17540 Discussions

Intel Iris Xe - Unplayable performance on Halo CE MCC in classic graphics mode

GenericUsername1
2,172 Views

As the title says, the framerate in Classic graphics mode in Halo CE on the Master chief collection is unplayable (10-20 FPS).

 

It doesn't seem to matter what graphics preset or resolution you play on.

 

Remastered graphics seem to run a lot better, around 3-4x in the same scenario.

 

I'm using an i7 1185G7.

 

I've tried both the latest stable release driver (version 27.xxx) and the latest Beta driver (Version 30.0.100.9667) and both have the issue.w

12 Replies
lucdec
Beginner
2,128 Views

I have the same problem!  I tried the game on a 1135G7 and a 1165G7. The settings don't matter at all - I even set the resolution scale to 25% and turned everything down to low.  Still 5-20 FPS.

 

I was able to play this game last year on a Lenovo S940 with an i7 1065G7 and it reached 60 FPS effortlessly.

yoonmh4
Beginner
2,119 Views

I have the same problem here too...

Im using i7-1165g7 with 16gb lpddr4x ram.

No matter the settings or the resolution the game is unplayable in the classic graphics mode.

However, it runs better(but with frequent stuttering) in anniversary mode what the hell??

Plus, halo 3, odst, 4 runs very good in any settings but halo 2 annivarsary and reach should be running better than it is now.

I heard that its supposed to be on par with the Gt1030, but its NOT

Funny thing is that my i5-10400 desktop with uhd630 runs CE in classic mode like a champ with the same version of drivers(27.20.100.9466) 

Im pretty sure that this is a driver issue and i hope this gets fixed ASAP

yoonmh4
Beginner
744 Views

as of lastest patch, which is ver. 30.0.101.1191, the problem has been fixed!

 

almost half a year after posting the problem on the forum, and more than a year after the release of iris xe!

after over a year since product release, consumers finally get to have the performance they paid for......

 

companies these days think its OK to NOT provide the promised product/performance at launch because of whatever reasons
(prolly just being lazy as heck), out of the box, 
and just fix it sometime later via updates(which could take up to a year.. seriously??)

iris xe and the 11th gen was a perfect example. this kind of anti-consumer behavior makes me even regret about buying intel cpus for my other PCs, prolly shouldve gone for AMD's APUs huh, at least they have better performance

 

and RonaldM from intel, you said you will inform us when its fixed but you didnt! :'( did you guys even care at all??

the lastest driver released like more than a couple of weeks ago and im sure it has gone through beta testing and you guys had that much time but didnt bother,,, c'mon! almost 1.5k people searched up for this problem! 1.5k customers!

AndrewG_Intel
Moderator
2,094 Views

Hello @GenericUsername1 and all the community peers.

Thank you for posting on the Intel® communities.


We understand that some of you have tested the latest Intel® generic stable graphics driver (version 27.20.100.9466), and the latest BETA driver, version 30.0.100.9667. We are not sure if you tried a Clean Installation of Intel® Graphics Drivers in Windows® when testing those drivers, so we recommend trying that in case you haven't.

However, some of the processors mentioned here are for Mobile computers. The driver or software for your Intel® component might have been changed or replaced by the computer manufacturer (OEM). OEM drivers are handpicked and include customized features and solutions to platform-specific issues, so we recommend you work with your computer manufacturer before installing our generic driver and get the latest OEM drivers directly from them so you don’t lose features or customizations.


If the behavior persists, in order to check this further, please provide the following information?

1- Is the issue observed using the OEM customized driver? Please provide details and driver version as a reference.

2- Did the system work fine before or are you experiencing this issue since the first day that you have the computer?

3- If this worked fine before at any moment, were there any recent hardware or software changes that might relate to the point when the issue started? (For instance, Windows®, driver, or game updates?)

4- Please fill up the Template for submitting a Graphics bug available in the link.

5-Report for Intel® Graphics Drivers following the steps on the link. If you use external monitors to play the games, make sure the monitors in question are connected to the computer when generating the report.

6- Run the Intel® System Support Utility (Intel® SSU) to gather more details about the system.

  • Download the Intel® SSU and save the application on your computer
  • Open the application, check the "Everything" checkbox, and click "Scan" to see the system and device information. The Intel® SSU defaults to the "Summary View" on the output screen following the scan. Click the menu where it says "Summary" to change to "Detailed View".
  • To save your scan, click Next and click Save.
  • Once you have saved the file (.txt file), please attach it to your reply.
  • To upload and attach a file, use the "Drag and drop here or browse files to attach" option below the response textbox.


Best regards,

Andrew G.

Intel Customer Support Technician


GenericUsername1
2,073 Views

Hi Andrew,

 

I have tried a clean re-install of the intel Graphics Driver for Windows using the OEM Driver with still the same result being unplayable performance in classic graphics mode in Halo CE in the Master Chief Collection on Steam. See below responses to your requests:

 

1- Is the issue observed using the OEM customized driver? Please provide details and driver version as a reference.

A: I have completely removed the existing driver and re-installed with the latest Dell OEM driver which is using driver version: 27.20.100.9565 though sadly the issue persists.

 

2- Did the system work fine before or are you experiencing this issue since the first day that you have the computer?

A: I have had the issue since the first day of getting my computer.

 

3- If this worked fine before at any moment, were there any recent hardware or software changes that might relate to the point when the issue started? (For instance, Windows®, driver, or game updates?)

A: Sadly it has never worked at all since getting the laptop, no hardware changes have been made.

 

4- Please fill up the Template for submitting a Graphics bug available in the link.

A: I will do this now.

 

5-Report for Intel® Graphics Drivers following the steps on the link. If you use external monitors to play the games, make sure the monitors in question are connected to the computer when generating the report.

A: I will do this now.

 

6- Run the Intel® System Support Utility (Intel® SSU) to gather more details about the system.

  • Download the Intel® SSU and save the application on your computer
  • Open the application, check the "Everything" checkbox, and click "Scan" to see the system and device information. The Intel® SSU defaults to the "Summary View" on the output screen following the scan. Click the menu where it says "Summary" to change to "Detailed View".
  • To save your scan, click Next and click Save.
  • Once you have saved the file (.txt file), please attach it to your reply.
  • To upload and attach a file, use the "Drag and drop here or browse files to attach" option below the response textbox.

A: I will do this now.

 

Cheers

 

GenericUsername1
2,068 Views

Hi Andrew,

 

I have all of the info here ready, Is there a way I can send you all of my system information privately? I don't feel comfortable sharing this publically.

 

Cheers

AndrewG_Intel
Moderator
2,064 Views

Hello GenericUsername1

Thank you for your response and for all the details.


Sure, we will send you an email to the email address associated with your profile so you can reply back to us privately and provide us with the reports. (Just in case, make sure to also review your Spam folder).


Best regards,

Andrew G.

Intel Customer Support Technician


GenericUsername1
2,055 Views

Thanks Andrew!

 

I've just responded now with the requested files 🙂

 

Cheers

AndrewG_Intel
Moderator
2,036 Views

Hello GenericUsername1

Thank you for your response. We would like to confirm that we did receive your email with the reports and now we are going to review this further. We will be posting back in the thread as soon as more details are available or in case additional debugging information is required from your side.


Best regards,

Andrew G.

Intel Customer Support Technician


guntrixe
Novice
1,985 Views
I have the same bad performance on games with i511600k!
RonaldM_Intel
Moderator
1,923 Views

Hello everyone,

 

I would like to confirm Intel was able to reproduce this issue, and this performance bug has been assigned to the driver development queue under bug ID 14014641776.

As soon as there is an update we'll update this thread. Stay tuned for upcoming driver updates!

Thank you all for bringing this issue to our attention.

Best Regards,

Ronald M.

AkhilPl
Beginner
571 Views

This issue also happens to me, all the other games in the collection work fine, but halo ce functions poorly for some reason. I hope it gets fixed soon

 

Reply