Graphics
Intel® graphics drivers and software, compatibility, troubleshooting, performance and optimization
18286 Discussions

Intel UHd 730 graphics Screen Flickering after Installing the Drivers

Gamer5070
Beginner
760 Views

Hi Community 

Am Having a problem with my New System Whenever the Driver is Installed for Intel UHD 730 my screen Starts flickering blurred it's and kept doing it Even you can't see the screen as you can see in the attechments. untill you Disable the Intel UHd 730 graphics from task manager or uninstall the driver.  I TRIED  restarting and reinstalling the drivers various versions and reinstalling different Windows but no luck. 

I tried Using the external vga which works fine but on Motherboard hdmi port its not usable on intel graphics 

 

am Using i512400 on Aorus Elite DR4.

 

0 Kudos
6 Replies
Alberto_R_Intel
Moderator
708 Views

Gamer5070, Thank you for posting in the Intel® Communities Support.


In order for us to provide the most accurate assistance on this scenario, we just wanted to confirm a few details about your system:

Is this a new computer?

Did you build it?

Was this specific PC working fine before without the flickering/blurred screen?

What is the model of the monitor?

Are you using adapters or converters to connect the screen to the computer?

Did you make any recent hardware/software changes besides updating the graphics driver that might have caused this problem?

Which Windows* version are you using?

Does the problem happen at home or in the work environment?

Please attach the SSU report so we can verify further details about the components in your platform, check all the options in the report including the one that says "3rd party software logs":

https://downloadcenter.intel.com/download/25293/Intel-System-Support-Utility-for-Windows-?product=91...


Any questions, please let me know.


Regards,

Albert R.


Intel Customer Support Technician


Gamer5070
Beginner
690 Views
Thanks for your reply and here are the answers of you questions.
Yes It's A New PC and no I didn't Build it. Since it's a new PC so everything is Installed fresh here so no new Hardware or software changing are made . No Am not using any type of Adapter plus I have tried changing Cables and multiple displays screens to check if its a Display or resolution issue. The Problem happens whenever the Driver for UHD 730 installed. I tried all the ways I could think of installing various windows and installing drivers by various methods like Windows update by Motherboards website, intel support software any driver downloader but no luck with the flickering or Artifacts. It won't let you see the screen untill you Disable the uhd 730 or uninstall it's Graphics driver from device manager.
Gamer5070
Beginner
689 Views

And here are the fies you asked for 

Alberto_R_Intel
Moderator
670 Views

Gamer5070, You are very welcome, thank you very much for providing that information and the SSU report.


"It won't let you see the screen untill you Disable the uhd 730 or uninstall it's Graphics driver from device manager":

Yes, the reason for that is that the Intel® graphics driver is generic, which means it does not contain the customizations done by the manufacturer of the board, which can result in this type of problem.


For that same reason, we always recommend to install the graphics driver provided by the manufacturer of the computer/board, since that driver was customized by them to work with your specific platform.


According to the SSU report related to the Z690 AORUS ELITE DDR4 board, we can confirm that currently, the graphics driver version installed in your system is 30.0.101.1660.


Even though you mentioned that you already test different drivers, I looked on Gigabyte's website and the latest graphics driver version they have available in there is 30.0.101.1002, please try a clean installation of that driver following the instructions in the links below:

https://download.gigabyte.com/FileList/Driver/mb_driver_649_graphicdch_30.0.101.1002.zip?v=e1723a938...

https://www.intel.com/content/www/us/en/support/articles/000057389/graphics.html


It is important to mention that this could be a hardware-related problem, especially based on the fact that, as you mentioned, the problem is only showing while using the HDMI port, that you tested different HDMI cables, different monitors, and also that the Intel® processor failed the Intel® PDT test. 


So, the source of the problem could be the processor itself or the HDMI port on the board. If you have the option, in order to isolate the issue, you can either test your processor on a different board or test your board with a different processor, we understand that this option is not always available though.


Besides that, we recommend to get in contact directly with Gigabyte Support to confirm that the latest BIOS version is currently installed on your device or, if necessary, to gather the instructions on how to do that. Also, to check if they might have an HDMI firmware update for you to install on the board. 

https://www.gigabyte.com/Support


Once you get the chance, please let us know the results of the suggestions provided so, if needed, we can further assist you.


Regards,

Albert R.


Intel Customer Support Technician


Alberto_R_Intel
Moderator
619 Views

Hello Gamer5070, I just wanted to check if the information posted previously was useful for you and if you need further assistance on this matter?


Regards,

Albert R.


Intel Customer Support Technician


DeividA_Intel
Moderator
586 Views

Hello Gamer5070,  


  

We have not heard back from you, so we will close this inquiry. If you need further assistance or if you have additional questions, please create a new thread and we will gladly assist you.  


  

Regards,  

Deivid A.  

Intel Customer Support Technician  

 


Reply