Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Novice
859 Views

Intel Ultra High Definition graphics 620 resolution problems

Hi,

 

I have a problem with my Acer Swift SF314-52.

For some reason, no matter what I do, it will NOT go higher than 1920 x 1080 in resolution. Just bought a new Samsung monitor, which supports WQHD resolution (also called 2K). Regardless, I have just installed the newest Intel UHD Graphics 620 driver, and not even in the Intel Graphic command center am I able to select any resolution higher than 1920 x 1080. Now I have searched EVERYWHERE for anyone else having this problem, and nothing. I have tried forcing it by selecting the "User/custom" feature under resolution in the Intel Graphic command center, and writing in the resolution 2560 x 1440, but all it says is (remember I am translating here, so don't know if it's exactly the same in the english version of the program) " This setting is not supported" or it just ask me if I want to set the user defined settings, I press YES and then nothing happens.

So I really hope that somebody sees this, and wants to help out, because I am really about to go crazy. Even if I connect my laptop to my 4K LG tv will it go higher than 1920 x 1080...? The specs on Intel's own website says, that it supports up to a 4K resolution, so what am I doing wrong?

 

Hope someone can help me out here, thanks in advance and have a nice day

 

Regards

 

Mikkel from Denmark

 

 

 

0 Kudos
6 Replies
Highlighted
835 Views

MikeDK1990, Thank you for posting in the Intel® Communities Support.


In reference to your question, just to let you know, Intel® UHD Graphics 620 controller supports 4K resolution at 60Hz using the DisplayPort as long as the monitor supports that same resolution. It will also depend on the features the motherboard in the computer supports based on the customizations done by the manufacturer of it.


So, in order for us to be able to provide the most accurate assistance on this matter, please provide the following information:

-The SSU report:

https://downloadcenter.intel.com/download/25293/Intel-System-Support-Utility-for-Windows-?product=91...

-The Intel® Graphics report with the monitor that is not working attached to the computer:

https://www.intel.com/content/www/us/en/support/articles/000005848/graphics.html 


Which video port are you using?

Did you test the computer with a different known working 4K monitor/TV?

Did you test different high-quality cables?


Any questions, please let me know.


Regards,

Albert R.


Intel Customer Support Technician

A Contingent Worker at Intel


0 Kudos
Highlighted
Novice
827 Views

Hi there,

 

First of all, thank you @Alberto_R_Intel1 for the reply. Sorry I have not been so quick at replying back again.

Second of all, the number 2 link in you reply, just gets me to the Intel US Homepage. But I got it, and have attached it here to this message as well.

The port I am using is HDMI, since there is no Display port on my computer.

Yes I have tested it with numerous other screens, including my 2 4K TV's, and another 2K (WQHD) monitor, in a store that had a monitor, which worked with 3 other computers, all of the via HDMI.

I have tested the high quality, 4K capable cabel that came with screen, also the one that's in there right now. This cable is capable to support up to 4K at 144Hz, which I have already tested on my TV to my Xbox One, which works brilliantly. I also took this cable with me to the store, to guarantee that it was not the cable, and it worked fine on all 3 computers I tested it with.

 

So it's not the cable, nor is it the screen.

What you got for me Doc?

 

Thank you

 

0 Kudos
Highlighted
807 Views

MikeDK1990, You are very welcome, thank you very much for providing those files, let me apologize for any inconvenience.


After reviewing the reports, we can confirm that the Intel® UHD Graphics 620 controller detects and supports the 2560 x 1440 resolution. Based on the fact that you tested the monitor/TV with different computers and you were able to get that resolution too, that confirms also that the monitor and the cable support that resolution as well.

Just to confirm, if you test this laptop with those monitors are you able to get the resolution that you are looking for?


Keep in mind that the manufacturer of the computer has the option to do customizations on their device, as well as disable/enable features and functions, so this problem could be related to those customizations or could be related to a compatibility problem between the monitor and the laptop. 


Now, on the report also we can see that the Windows* version installed is 1903, please try to run the Windows* updates and update that version to 2004 which is the latest one.


Also, we can test the latest Intel® Graphics driver that is available in our web site which is version 27.20.100.8476, please try a clean installation of that driver and test the computer:

https://www.intel.com/content/www/us/en/support/articles/000005598/graphics.html

https://downloadcenter.intel.com/download/29784/Intel-Graphics-Windows-10-DCH-Drivers?product=126789


Additionally, I looked in Acer's web site and the latest Graphics driver version they have is 23.20.16.5038 which is the one that is currently installed:

https://www.acer.com/ac/en/US/content/support-product/7227?b=1&pn=N9.GQSWW.001

 

So, if the problem persists after trying the steps above then you can also get in contact directly with Acer for them to verify if there is another Graphics driver that they can recommend and that it is validated by them since driver version 23.20.16.5038 is not that new for the Intel® Graphics controller that the system works with:

https://www.acer.com/ac/en/US/content/service-contact

 

Regards,

Albert R.


Intel Customer Support Technician

A Contingent Worker at Intel


0 Kudos
Highlighted
Novice
774 Views

Hi again @Alberto_R_Intel1 

 

So now, a very interesting thing happened. I went to the Intel driver download page, wanting to install the newest driver. I had tried this before, didn't help, then I tried removing the entire driver for the graphic card, so it only says "Microsoft Basic graphic card" in Device manager. Then I tried reinstalling the older driver from Acer, that's where we left off last time you wrote me. Now I couldn't install the newest driver, it came up with the a message on the website, under the graphic card, where it said something about not me not having the newest driver, and it couldn't install it. Now I tried removing the driver for the graphic card entirely again, rebooted, and then...! Magic happened for a short period of time. The windows basic driver were, for a period of about 3 minutes, able to get the resolution up to 2560 x 1440. Then the screen blinked, now we are back, stuck at 1920 x 1080. Can't even change it down either. Now I tried downloading and installing the newest driver, and the following message appears " The driver being installed, is not validated for this computer. Get the relevant driver from the computer manufacturer. The installation program will close. Do you want more information? Click on Yes to be directed to Intels Supportwebsite"

 

Oh and by the way, I contacted Acer, and so far, no luck. It seems that there has not been a driver update since the one you are referring to, the one I recently removed.

 

So now we are again stuck, and I have no idea how to move on from here?

 

Thanks

0 Kudos
Highlighted
764 Views

Hi MikeDK1990, Thank you very much for sharing those updates.


What it seems to be happening, now that you mentioned that you were able to set the 2560 x 1440 resolution when the "Microsoft Basic Graphic Card" is installed, is that Windows* will run the updates and it will look for the driver provided by Acer to install it in your system, that is why it only worked for about 3 minutes and then the problem comes back again.


For this scenario what we recommend, even though you already mentioned you did that, will be to get in contact with Acer directly again to report this scenario for them to get in contact with Microsoft directly to provide a new customized driver for them and for you that contains the fixes for this problem with the resolution.


Regards,

Albert R.


Intel Customer Support Technician

A Contingent Worker at Intel


0 Kudos
Highlighted
Super User Retired Employee
760 Views

Let me state this slightly better. Your vendor (Acer, in this case) has a level of control over what drivers are installed to their machines by Windows Update. Sometimes (hell, all the time), the database gets screwed up and drivers that shouldn't be installed, are installed. When you see this happen, you need to discuss it with your vendor, so that they update the criteria in the Windows Update database so that the driver is not overwritten with one that is incorrect (older or not applicable).

Clear as mud?

...S

0 Kudos