Graphics
Intel® graphics drivers and software, compatibility, troubleshooting, performance and optimization
17468 Discussions

Intel core i5 4440: Audio bugged after updating drivers

EonOs
Beginner
747 Views

Hello. 

*This post is here because intel hd drivers are "linked" with audio drivers, and the problem apear after updating video drivers*
I update integrated graphics audio driver using intel driver update tool
After that, opening a fullscreen app, has a chance to crash sound 

Sometimes audio returns after closing the app, and sometimes no

It is very inconsistent, if you open the app twice, the first one may no crash sound and the second one may crash sound, it happens with ALL fullscreen apps

i tried to downgrade the drivers, uninstall, and reinstall, update to latest version and nothing helped

I reinstaled windows 10 5 times and check the problem on clean windows installs and still hapened

Windows doesnt throw error, just audio diseapears, if I open windows audio mixer, shows that windows and apps should play audio

 

This is thru a hdmi screen

 

*Update 1: Some apps didnt event try to give audio ex. Valorant

Some apps like Terraria, teams, zoom can crash sound, but if a diferent non-fullscreen app has sound playing the probability reduces by a lot (Terraria crashes sound 1/3, Teams 2/3, Zoom 1/6 aprox) 

*Update 2: These even happen with non full screen apps

Even non full screen apps can crash sound but with a little chance, also windows can start without sound, re-starting being the only solution

 

0 Kudos
9 Replies
AndrewG_Intel
Moderator
635 Views

Hello @EonOs

Thank you for posting on the Intel® communities.

In order to check this behavior further, could you please help us by providing the following details?

 

1- What is the driver version that you installed and triggered this behavior? (The one that you said "the problem apear after updating video drivers").

2- We understand that the issue started after upgrading the driver, but the issue persists even after trying to downgrade the drivers. Is this correct? Could you please list/mention the driver versions that you have tested and shows this behavior? Is the issue happening even with previous known-working drivers?

3- We noticed you tried reinstalling Windows. Just to make sure we understand correctly, after doing those Windows® clean installations, did you test them with previous known-working drivers or only with the latest driver version? Please provide details.

4- Have you tested different HDMI® cables or different HDMI® displays?

5- Are you using a straight-through connection (e.g. HDMI-to-HDMI) with a single cable? Or are you using any type of video adapters, converters, or dockings? Please provide details.

6- With the HDMI® display connected to the computer, please provide a Report for Intel® Graphics Drivers following the steps on the link.

7- Run the Intel® System Support Utility (Intel® SSU) to gather more details about the system.

  • Download the Intel® SSU and save the application on your computer
  • Open the application, check the "Everything" checkbox, and click "Scan" to see the system and device information. The Intel® SSU defaults to the "Summary View" on the output screen following the scan. Click the menu where it says "Summary" to change to "Detailed View".
  • To save your scan, click Next and click Save.

 

Best regards,

Andrew G.

Intel Customer Support Technician

 

EonOs
Beginner
579 Views

1.- The first time version was instaled by your driver update tool. Driver version on windows told to be "20.XX.XX.5171" then the problem started

2.- Yes, problem persist after downgrading drivers, and installing it on clean windows

For clear data I notice that driver version is diferent from what you install. Let me give an example

If I download driver 15.40.46.5144 and instal it, windows shows 20.19.15.5144, just the last 4 numbers match

The original driver that my pc had was 15.40.46.5144, installing  it on a clean install doesnt fix the problem

15.40.47.5166 instaling it on a clean install doest fix the problem

15.40.40.5171 instaling it on a clean install doest fix the problem

if I use last windows version 20H2 it will always try to install 15.40.40.5171 even in background with updates disabled, the only way to avoid it is disabling wifi conection

And yes. After downgrading to my old version (that was working fine) no longer works even in a clean windows install

3.- Yes, I reinstaled windows and only use the working, here are my steps

 -Full clear, clear disk, and resintaled windows 20h2 with driver 15.40.46.5144 --> No sound,still bug

-Full clear, clear disk, and resintaled windows 20h2 with driver 15.40.47.5166--> No sound,still bug

-Full clear, clear disk, and resintaled windows 20h2 with driver 15.40.40.5171--> No sound,still bug

-Full clear, clear disk, and resintaled windows 20h2 allow windows chose driver (windows instaled 15.40.40.5171 )--> No sound,still bug

-Full clear, clear disk, installed ubuntu  20.04.2.0 and let ubuntu install drivers. Install windows 20H2 as secondary--> Problem dissapear by two or three days. After that the problem returned

-Install windows as THIRD OS in a new partition (2) with driver 15.40.40.5171- > No problem everything works as usual, fixed? Maybe but my disk was a mess 

-Uninstall Windows in partition 1 and uninstall ubuntu -> Problem returned

-Instal windows in partition 1 and ubuntu -> No problem every thing works as usual, but Dualboot get bugged and shows 4 unexisting windows and doesnt allow me to boot ubuntu

-Uninstall windows on part 1 -> Problem returned

-Install driver 15.40.46.5144 ->No sound still bug, current state

4- Yes, test 3 diferent HDMI and tested with other pcs and screens (all hdmi and screens worked as expected, the problem was in my pc)

5- Yes straight-through with a single HDMI, no adapters, no docks.  HDMI PC-> HDMI cable-> Screen

6- Here you have

**********

Intel(R) HD Graphics 4600

 


Report Date: Friday, March 12, 2021
Report Time [hh:mm:ss]: 1:17:26 PM
Driver Version: 20.19.15.5144
Operating System: Windows* 10 Pro (10.0.19041)
Default Language: Spanish (Spain, International Sort)
Physical Memory: 8063 MB
Vendor ID: 8086
Device ID: 0412
Device Revision: 06
Video BIOS: 1030.0
Current Resolution: 1360 x 768

 


Processor: Intel(R) Core(TM) i5-4440 CPU @ 3.10GHz
Processor Speed: 3100 MHz
Processor Graphics in Use: Intel(R) HD Graphics 4600
Shader Version: 5.0
OpenGL* Version: 4.3
OpenCL* Version: 1.2


* Microsoft DirectX* *
Runtime Version: 12.0
Hardware-Supported Version: 11.1

 


* Devices connected to the Graphics Accelerator *


Active Displays: 1

 


* Digital Television *


Display Type: Digital
DDC2 Protocol: Supported
Gamma: 2.2
Connector Type: HDMI
Device Type: Digital Television


Maximum Image Size
Horizontal Size: 45.28 inches
Vertical Size: 25.59 inches


Supported Modes
640 x 480 (60p Hz)
720 x 400 (70p Hz)
720 x 480 (60p Hz)
800 x 600 (60p Hz)
1024 x 768 (60p Hz)
1280 x 720 (60p Hz)
1360 x 768 (60p Hz)
1920 x 1080 (60p Hz)
1920 x 1080 (30p Hz)
1920 x 1080 (24p Hz)
1920 x 1080 (60i Hz)

 

 

Raw EDID:
00 FF FF FF FF FF FF 00 1E 6D 01 00 01 01 01 01
01 13 01 03 80 73 41 78 0A CF 74 A3 57 4C B0 23
09 48 4C A1 08 00 81 C0 01 01 01 01 01 01 01 01
01 01 01 01 01 01 66 21 50 B0 51 00 1B 30 40 70
36 00 7E 8A 42 00 00 1E 01 1D 00 72 51 D0 1E 20
6E 28 55 00 7E 8A 42 00 00 1E 00 00 00 FD 00 39
3F 1F 3C 09 00 0A 20 20 20 20 20 20 00 00 00 FC
00 4C 47 20 54 56 0A 20 20 20 20 20 20 20 01 1D

02 03 18 F1 47 10 22 20 05 84 03 02 23 09 07 07
67 03 0C 00 20 00 B8 2D 02 3A 80 18 71 38 2D 40
58 2C 04 05 7E 8A 42 00 00 1E 01 1D 80 18 71 1C
16 20 58 2C 25 00 7E 8A 42 00 00 9E 01 1D 00 72
51 D0 1E 20 6E 28 55 00 7E 8A 42 00 00 1E 8C 0A
D0 8A 20 E0 2D 10 10 3E 96 00 7E 8A 42 00 00 18
26 36 80 A0 70 38 1F 40 30 20 25 00 7E 8A 42 00
00 1A 00 00 00 00 00 00 00 00 00 00 00 00 00 1C

 

* Other names and brands are the property of their respective owners.

********************************

7. the "info" file is the result of SSu

Beware that the problem doesnt get trigger by process indicated in 6 and 7 because thay arent a fullscreen app

AndrewG_Intel
Moderator
576 Views

Hello EonOs

Thank you for all the information provided and very detailed, we really appreciate it.


Based on the information you shared, we noticed that it seems only Intel® generic drivers have been tested (15.40.46.5144, 15.40.47.5166, 15.40.40.5171). Is this correct?

Linux* and Windows® use different drivers, and since the issue also happens on UBUNTU® and even this worked with Windows® driver 15.40.40.5171 on one of the tests, this does not seem to be a driver problem, but we would like to know if this behavior also happens with the customized drivers provided by the computer manufacturer (OEM).


Based on the motherboard model "B85M-G R2.0" (as per the Intel® SSU report), we are not able to found ASUS* driver for this specific model, the link shows no information. Is this also happening to you? >> ASUS* B85M-G R2.0 drivers.


We do get a link showing drivers available but only for ASUS* B85M-G (without the "R2.0") and we see different graphics driver versions available under the section "VGA Drivers"; however, since we don't handle the technical details of these third-party motherboards, we are not sure if they both apply for the same motherboard or if they are different and they have their own set of customized drivers.

Could you please verify this with ASUS* Support and if those drivers are valid for your system, could you please give it a try to see if the behavior is different?

You may use the Clean Installation of Intel® Graphics Drivers in Windows® 10 steps in case you are able to test any of those drivers, just instead of downloading and installing Intel® generic drivers from the Download Center, please use the recommended driver provided by ASUS*.

Please report back the outcome.


Also, please run the Intel® Processor Diagnostic Tool to verify that both the processor and the GPU (Graphics Processing Unite) are fine.

Make sure to download the proper version of the tool (32 or 64 bit) based on your operating system (OS):

To save the report, once the test is done, click on "File >> View Results File" and attach the .txt file to your reply.


Note:

The difference in driver versions and how they are displayed is expected behavior due to the naming schema used on Intel®'s Download Center and the operating system's own driver convention. Here, the key is comparing the Build number as the "Last four digits indicate the actual driver number". For more details, please review this link Understanding the Intel® Graphics Driver Version Number.


Best regards,

Andrew G.

Intel Customer Support Technician


EonOs
Beginner
564 Views

Maybe I miss spell or something. I´m sorry, I´m a spanish speaker

The sound does work in ubuntu, but graphics get glichy and crash on fullscreen

In windows graphics work, but sound doesnt

Yeah, I test all generic drivers, I was always using generic drivers and get no problem until last update

And yes, the page of asus shows no info

I already tested specific drivers of  ASUS* B85M-G since the only diference is a fan input extra on r2, but drivers still didnt work

I´m contacting Asus support so.. when i test it, i will answer that

I also attach the results of  Intel® Processor Diagnostic Tool but all seems correct

 

Thanks for all the help, 
I will still tring to fix this, and keep the result for anyone that need it

Right now the best solution for those that just need to work or study is ubuntu, since all works except for fullscreen apps

AndrewG_Intel
Moderator
546 Views

Hello EonOs

Thank you for your response and for all the details.

 

We understand that you have already tested with the OEM ASUS* drivers for ASUS* B85M-G and the issue persisted, but you are now contacting ASUS* support in order to check/test this further. Perfect, please feel free to post back any additional feedback.

In the meantime, we will also check this further from our side and we will be posting more details as soon as possible.

 

Best regards,

Andrew G.

Intel Customer Support Technician

 

AndrewG_Intel
Moderator
501 Views

Hello EonOs

Thank you for your patience in this matter.


After checking this further, the driver versions tested have been out there for many years and you have confirmed that rolling back to previous drivers also exhibit the issue, thus suggesting a possible hardware issue that should be troubleshoted with the computer manufacturer.

In this case, we recommend checking this further with ASUS* Support for further debugging.


Best regards,

Andrew G.

Intel Customer Support Technician


EonOs
Beginner
493 Views

I finally fix the problem!
And Im here to explain it to anyone else

 

After going all the process again with Asus they found the problem and also get very interested with it.

They were capable to replicate it in the same conditions. After that they told me that "Intel generic drivers must work better than Asus provided" thats why they no longer update specific board drivers

The problem was found in faulty Intel Drivers downloaded from you. In their words they found that "the driver was messing up with audio intensionally", they suposed that this was some kind of planned obsolence

That why downgrading doesnt work, the damage was made.

Also the drivers messed up with system recognition, that why ubuntu wasnt able to run the graphics

The way to "fix" it was simple, install lastest Intel HD drivers, and via a special function of the motherboard, disable audio part of the integrated GPU, and allow integrated audio card to do the job.

The bad thing is that there is no fix for ubuntu or other linux distros

 

After that, Im not sure if its worth to keep with intel. 
And thats it. Now you can close the treat
Thanks for all the help

AndrewG_Intel
Moderator
465 Views

Hello EonOs

Thank you for your response and for your feedback on how you fixed the problem. We are glad to know you were able to solve the problem by working with ASUS*.

For any other inquiries, please do not hesitate to contact us back.


Best regards,

Andrew G.

Intel Customer Support Technician


AndrewG_Intel
Moderator
449 Views

Hello EonOs

We have not heard back from you so we will proceed to close this thread now. If you need any additional information, please submit a new question as this thread will no longer be monitored.


Best regards,

Andrew G.

Intel Customer Support Technician


Reply