Intel® graphics drivers and software, compatibility, troubleshooting, performance, and optimization
20948 Discussions

Intel driver forces 4k signal on 1080p monitor


My LG monitor is 1080p.  Definitely.  Despite this, the Intel Graphics Command Center (on Windows 10) considers it 4k capable, and seems to have no way to countermand that, no way to limit the signal resolution to the actual resolution, and no way to disable specific video modes from its list.

The Intel driver will often send a 4k signal even for things using 1080p with no way for me to control that choice, and my system cannot handle 4k.  This happens for many games/engines when they use exclusive fullscreen.  Not only that, but because 4k would be limited to 30Hz over my HDMI cables, I sometimes have 1080p games think my refresh rate at 1080p is 30fps, even though it is 60Hz, so vsync either ruins the framerate or--and this is weird--the game runs at half speed to fit 60Hz into 30Hz.  Even with vsync disabled, some games randomly drop into 30fps half-speed mode (while the screen is still 60Hz) until I shake them out of it by switching in and out of exclusive fullscreen a few times.  I have checked the monitor OSD to verify the video modes and refresh rates.

I really need the Intel driver to stop feeding things this false 4k/30 signal mode, and to not force 4k signals even when games are trying to run at 1080p like they are supposed to.  

I really just need to be able to disable/hide these 4k video modes because I never want to use them on my 1080p monitor.

Monitor: LG 27GN600-B, HDMI

Integrated Graphics: Intel HD Graphics 530 (v, controlling the output/HDMI

Dedicated Graphics: Nvidia 960m (v, passes output through the Intel and does not control the output signal

System: Acer VN7-792G (laptop)

OS: Windows 10

0 Kudos
3 Replies

TyrianMollus, Thank you for posting in the Intel® Communities Support.


In reference to this scenario, it is important to mention that the Intel® HD Graphics 530 controller is under the status of End Of Interactive Support / Discontinued.

So, Intel® technical support will no longer be provided for this kind of product, but perhaps fellow community members have the knowledge to jump in and help. You may also find the Discontinued Products Website helpful to address your request:


Albert R.

Intel Customer Support Technician

0 Kudos

 it possible to complete switch off the NVidia graphics and reproduce the problem ? That would make analysis easier.

What does window offer you as resolutions for the display when you go to windows 10/11 advanced display settings/display adapter properties for the display ? Is there any resolution included that is not supported by your display ?

One common tool to troubleshoot possible EDID issues is an edid emulator/manager that you plug into the hdmi connection. Something like this for example: 

0 Kudos

I have the problem regardless of whether the game runs on the nvidia or on the intel.

Nvidia support has stated that the nvidia drivers take no part in the video mode/signal negotiation and cannot limit it, as the integrated graphics is in charge of that.

Windows will list unsupported resolutions if I check that box, but otherwise the supported resolutions match the monitor.  Again, the monitor "supports" 4k by downscaling to its native 1080p (and yes, it is native 1080p), so the 4k video modes rightly exist, I just don't want them to get used.  I would not want to use 4k if I had a 4k screen either.  I have no interest in 4k gaming.

The Intel Graphics Command Center no longer has resolution settings, and simply opens the windows display settings for setting resolution.  Yet, even with the windows display settings set to 1080p display and signal resolution, things are changing to the 4k video mode and not the screen's native/preferred resolution.

I need the Intel Graphics "Command" Center to remove/hide modes too high for my system to comfortably use, not to force me to use them even when I have the system settings set to 1080p.  Intel should not be ruining performance because my monitor has a feature.  If it were the nvidia driver in charge of things, I could easily set the maximum resolution to block this problem.

0 Kudos