Community
cancel
Showing results for 
Search instead for 
Did you mean: 
STown1
Beginner
2,891 Views

Issue installing Intel Graphics Driver 25.20.100.6326

As of yesterday (12th October) the "Intel High Definition Audio" device is no longer working.

The symptom is I have no audio device to pick from in Playback Devices (in Windows 10 Pro):

In Device Manager > Other Devices I can see Intel High Definition Audio and under properties it says:

"The drivers for this device are not installed. (Code 28)

There are no compatible drivers for this device.

To find a driver for this device, click Update Driver"

If I follow the advice to update the driver here it ends up with "Windows could not find drivers for your device".

I am trying to install the Intel driver directly (25.20.100.6326) to resolve the issue, as is advised on several forums online. I've download the driver for Intel HD Graphics 630 which is my device, and the .exe install runs as per normal - then it says I need to restart my computer. Upon re-starting, Windows starts the installation again from the start, and I end up in a loop of re-installing the driver and restarting Windows over and over again - and my audio is still not working and the driver is still not installed.

Basic details of my computer:

  • Windows 10 Pro 64-bit
  • HP OMEN 15-ce0xx (laptop)
  • NVIDIA GTX 1050

I have also tried installing the RealTek audio driver from the HP drivers section on their website, but the installation fails. I've also tried uninstalling all of the Windows Updates from the last two days - but the issue persists. Discussions online seem to hint that it's related to a Windows Update.

Also note: If I connect my Bluetooth headphones they work fine, presumably because they use a different driver.

Tags (1)
0 Kudos
4 Replies
AlHill
Super User
1,004 Views

What is your windows 10 version number and build number?

What is your processor model number?

 

Doc
STown1
Beginner
1,004 Views

  • Microsoft Windows 10 Pro 10.0.17134 Build 17134
  • Intel Core i7-7700HQ
STown1
Beginner
1,004 Views

OK: I have solved the issue for now.

I was able to install the driver from http://www.realtek.com.tw/downloads/downloadsCheck.aspx?Langid=1&PNid=24&PFid=24&Level=4&Conn=3&Down... Realtek directly. Even before restarting the volume icon in the system tray returned to normal, and after a restart I can hear audio through my headphones again.

NOTE: On the RealTek website when I hit "Next" it just kept refreshing the page. It worked after I clicked one of the icons to change the text size and THEN hit Next... in case anyone else runs into that issue too.

MTiss
Beginner
1,004 Views

Maaany thanks stownshend, you saved my life !

I was experiencing the exact same problem since 2018/10/12 on my Asus GL553VD (i7-7700HQ CPU @ 2.80GHz, 2808 MHz), and thanks to you it was solved today, same procedure.

After the installation of the realtek codec, the realtek audio manager refused to launch though, then I ran the Windows udpate check, which automatically installed the Microsoft HD audio codec update once again... and now everything works fine, including the realtek audio manager !

Reply