Graphics
Intel® graphics drivers and software, compatibility, troubleshooting, performance and optimization
17468 Discussions

Limited range over dvi-d, unable to change

megapro17
Beginner
895 Views
I connected my monitor to hd 530 (i5-6500) and it displays very bright colors, like when using limited range. In intel control center there is one option under color category, but it doesn't changing anything. I tried to update driver to latest version 27.20.100.9316 but it didn't helped. Also, tried to delete all intel drivers with DDU. When connected to other gpu monitor displays normally. How to set full range? Why it drops my colors even if I'm using dvi? It happens on nvidia only through hdmi, but can be easily changed. My os is windows 10 20h2.
0 Kudos
11 Replies
AndrewG_Intel
Moderator
843 Views

Hello @megapro17

Thank you for posting on the Intel® communities.

We would appreciate it if you could provide us with the following details in order to check this behavior further:

 

1- Did this configuration (system + video cables + display) work fine before? If yes, was there any recent hardware or software change (Windows/driver/apps updates) related to the point when this behavior started? Or is this a new computer?

2- Screenshots showing the options that you have available and are changing on Intel® Graphics Command Center (or Intel® Graphics Control Panel if still using it).

3- Is this happening only using DVI connections? Have you tested the behavior using other video ports/connections on this computer? For instance, HDMI* to HDMI*? Are you using a straight-through connection (e.g. DVI-to-DVI, HDMI® to HDMI, etc) with a single cable?

4- Display brand and model:

5- Please check these links:

There is information related to Limited Range and Full Range. Is this similar to the behavior that you are experiencing?

6- Please provide a Report for Intel® Graphics Drivers following the steps on the link.

7- Run the Intel® System Support Utility (Intel® SSU) to gather more details about the system.

  • Download the Intel® SSU and save the application on your computer
  • Open the application, check the "Everything" checkbox, and click "Scan" to see the system and device information. The Intel® SSU defaults to the "Summary View" on the output screen following the scan. Click the menu where it says "Summary" to change to "Detailed View".
  • To save your scan, click Next and click Save.

 

Best regards,

Andrew G.

Intel Customer Support Technician

megapro17
Beginner
810 Views

1. Long time ago it worked without any setup. I just connected my monitor to internal graphics and noticed blank colors

2. 

color full.PNG display.PNG

3. Over vga it's displays full range, there is no hdmi on mainboard. I'm using direct dvi-dvi cable.

4. LG E2260

5. It says about Non-CEA modes, but how to set it? I'm also unable to add any custom resolution, even 61 Hz says that it is not supported

6. 

AndrewG_Intel
Moderator
798 Views

Hello megapro17

Thank you for all the information provided. Please allow us to check this further and we will be posting back in the thread as soon as more details are available.

 

Note:

You may be unable to add Custom Resolutions or receive an error if the new resolution or mode exceeds the bandwidth limit supported on the particular chipset. There is also the possibility that the system manufacturer (OEM) has disabled support for Custom Resolution. 

For more details, please check:

How to Add/Delete Custom Resolutions and Modes in Intel® Graphics Command Center.

Intel® Graphics Control Panel Error “Custom Resolution Exceeds Maximum Bandwidth”.

 

Best regards,

Andrew G.

Intel Customer Support Technician

AndrewG_Intel
Moderator
781 Views

Hello megapro17

Thank you for your patience in this matter.


After checking this further, we would like to inform you that the Quantization range option is only available on native HDMI outputs connected to Intel® Graphics.

If the external display is connected via DVI output then you would need to use Windows* built-in color calibration options to set the right colors. For proper guidance on this, we recommend contacting Microsoft® Support*.


Best regards,

Andrew G.

Intel Customer Support Technician


megapro17
Beginner
773 Views

Windows doesn't have any settings that related to Quantization range. Built-in color calibration options cannot change this option.

> Quantization range option is only available on native HDMI outputs connected to Intel® Graphics.

This is clearly wrong behavior, because any other gpu let you control this option no matter of what output you're using. Even in older version intel driver it was possible.

AndrewG_Intel
Moderator
754 Views

Hello megapro17

Thank you for your response and for your feedback. We really appreciate it and we will share this with the proper team. In case we have more details about this, we will be posting them in the thread. For any other inquiries please don't hesitate to contact us back.


Best regards,

Andrew G.

Intel Customer Support Technician


AndrewG_Intel
Moderator
742 Views

Hello megapro17


We would like to inform you that we have routed your feedback to the proper team. Also, we want to confirm that Quantization range is only available on native HDMI connections as noted in this link: Quantization Range Option Is Not Visible in the Intel® Graphics Control Panel or Intel® Graphics Com....


If using Windows* built-in color calibration options is not helping to set the right colors, our recommendation is to check this further with the motherboard manufacturer or with the display manufacturer (perhaps color settings available on the on-screen display (OSD) menu) for the possibility of additional options/tools to achieve the desired colors.

For your convenience, please find here the links to MSI* Support and LG* Support.


Having said that, we will proceed to close this thread now. If you need any additional information, please submit a new question as this thread will no longer be monitored. Thank you for your understanding.


Best regards,

Andrew G.

Intel Customer Support Technician


megapro17
Beginner
730 Views

Why are you closing this report? What I need to do? My motherboard doesn't have HDMI, so? I could change Quantization range in the past! Why you have broke it? It is IMPOSSIBLE to get more colors when editing colors, it just make picture more bright or dark.

megapro17
Beginner
718 Views

After installing old drivers 15.45.34.5174 it's working perfectly out of box. Thanks intel for providing broken drivers

megapro17
Beginner
515 Views
https://www.avsforum.com/threads/theory-about-intels-hdmi-quantization-range-setting-full-0-255.1477...

Add DWORD "EnableRGBFullRange" = 1

to

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4d36e968-e325-11ce-bfc1-08002be10318}\0000
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4d36e968-e325-11ce-bfc1-08002be10318}\0001
bitdomo
Beginner
277 Views

I have exact same issue. I have an LG monitor and connect that through DVI to my PC. Colours look like I am using connecting through HDMI and the quantation of colours is set to Limited instead of Full range. There is no option for that to change in the intel control panel or whatever that program called since it is a DVI port and not a HDMI. I remember I did not have this issue back in the past maybe 3-4 years ago with exact same monitor and mother board etc everything. The colour are right in the bios or before windows load so I tried it what is with linux. In linux I experience the exact same issue. Using xrandr command shows that my screen is connected through a HDMI port and not DVI which is odd. But on linux I can change the colour quantation with a command easily and that fixes the issue.

On windows I was playing with some older drivers that fixed the issue and I got back my colours until I restart my pc and everything goes wrong again until I reinstall the old drivers. No idea why is that. Probably windows is reinstalling the newer drivers through windows update or something. Anyway finally found your thread and putting DWORD entry with EnableRGBFullRange = 1 to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4d36e968-e325-11ce-bfc1-08002be10318}\0001 fixed my issue on the latest intel drivers (as of now the installer exe is called igfx_win_101.1191.exe)

 

form me HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4d36e968-e325-11ce-bfc1-08002be10318}\0000 had entries about nvidia releated things. I have an nvidia gpu too but I dont use it for screen output so there is no screen attached to it. I just use it for deeplearning AI

Reply