Graphics
Intel® graphics drivers and software, compatibility, troubleshooting, performance, and optimization
20584 Discussions

Linux UHD Graphics 600 monitor turns off when using video acceleration

mm2021
Beginner
1,532 Views

Hello,

I have the following GPU running on Debian sid (I had similar issues on a laptop at work with Ubuntu and Windows 10).

 

00:02.0 VGA compatible controller [0300]: Intel Corporation GeminiLake [UHD Graphics 600] [8086:3185] (rev 06)
        DeviceName: Onboard - Video
        Subsystem: ASRock Incorporation GeminiLake [UHD Graphics 600] [1849:2212]
        Kernel driver in use: i915
        Kernel modules: i915
  *-core
       description: Motherboard
       product: J4125M
       vendor: ASRock
       physical id: 0
       serial: M80-F4007100194
     *-firmware
          description: BIOS
          vendor: American Megatrends Inc.
          physical id: 0
          version: P1.60
          date: 08/13/2021
          size: 64KiB
          capacity: 16MiB
          capabilities: pci upgrade shadowing cdboot bootselect socketedrom edd int13floppy1200 int13floppy720 int13floppy2880 int5printscreen in
t9keyboard int14serial int17printer acpi usb biosbootspecification uefi

 

If I use video acceleration (checked with  intel_gpu_top), the screens turn off for a second, then everything is normal egain. When the video stops playing, it turns off again.

After disabling hardware acceleration in the browser, this does not happen.

The monitors are fine. One is connected via VGA (eDP in xrandr) and the other via DVI-D (HDMI2)

 

m@ryz:~$ xrandr
Screen 0: minimum 320 x 200, current 2960 x 1050, maximum 16384 x 16384
eDP1 connected primary 1680x1050+1280+0 (normal left inverted right x axis y axis) 473mm x 296mm
   1680x1050     59.95*+  59.88  
   1400x1050     59.98  
   1600x900      59.95    59.82  
   1280x1024     60.02  
   1400x900      59.96    59.88  
   1280x960      60.00  
   1368x768      59.88    59.85  
   1280x800      59.81    59.91  
   1280x720      59.86    59.74  
   1024x768      60.00  
   1024x576      59.90    59.82  
   960x540       59.63    59.82  
   800x600       60.32    56.25  
   864x486       59.92    59.57  
   640x480       59.94  
   720x405       59.51    58.99  
   640x360       59.84    59.32  
HDMI1 disconnected (normal left inverted right x axis y axis)
HDMI2 connected 1280x1024+0+0 (normal left inverted right x axis y axis) 338mm x 271mm
   1280x1024     60.02*+
   1024x768      60.00  
   800x600       60.32  
   640x480       59.94  
   720x400       70.08  
m@ryz:~$ 

 

Resolution/refresh rate doesn't change.

 

What might be the problem here?

kind regards

Marco

Labels (1)
0 Kudos
7 Replies
mm2021
Beginner
1,508 Views

I now figured out that it only happens if a monitor is connected to HDMI or DVI. If only VGA is being used (detected as eDP1 in xrandr), the effect does not occur.

0 Kudos
Jean_Intel
Employee
1,500 Views

Hello mm2021,

 

Thank you for posting on the Intel️® communities. I am sorry to hear that you are experiencing issues with the display turning off.

 

In order to have a better understanding of your issue, please provide me with the following:

  • Are you using any type of adapter?
  • Have you tried using other cables or video outputs?
  • I understand that you mentioned that you have experienced this issue with a similar laptop with Windows 10. However, could you try installing Windows 10 on this specific system, to confirm if the issue is still present?
  • If you install Windows 10, please, create a report using the
  • Intel®️ System Support Utility (Intel®️ SSU) 
    • Download the Intel SSU
    • Open the application and click on "Scan" to see the system and device information. By default, Intel®️ SSU will take you to the "Summary View."
    • Click on the menu where it says: "Summary" to change it to "Detailed View."
    • To save your scan: click on "Next"; then "Save."

 

Best regards,

Jean O. 

Intel Customer Support Technician


0 Kudos
mm2021
Beginner
1,480 Views

I don't use any adapters or converters. I have tried other calbes, but my calbes are fine. It only occurs in the situations I described.

I also tested Lubuntu 22.10 live, the same happens, so it is not a fault of my installed Debian.

 

I will try out windows 10 on a second hard disk.

0 Kudos
mm2021
Beginner
1,477 Views

I have now found out that it is related to audio. If I have the internal Intel audio enabled in PulseAudio, the monitors turn off. If audio is disabled, it does not occur.

0 Kudos
mm2021
Beginner
1,437 Views

I solved it, see my post in this German Usenet newsgroup:

https://groups.google.com/g/de.comp.os.unix.linux.hardware/c/ap7jWboc3_k

 

Short:

I set the following boot option:

snd_hda_intel.power_save_controller=0

 

See that documentation for details what is does:

https://docs.kernel.org/sound/designs/powersave.html

 

Do you think that behaviour is a hardware issue or an issue in the Linux driver?

0 Kudos
Jean_Intel
Employee
1,456 Views

Hello mm2021,

 

Thanks for the information you provided.

 

We understand that the issue seems related to audio; however, as we mentioned, we may need you to test if the problem persists if you install a Windows Operating System. It is ideal to mention that our drivers are developed to work in a Windows environment. Also, if the issue persists, create an SSU report; this will gather information related to your system.

 

Best regards,

Jean O. 

Intel Customer Support Technician


0 Kudos
Jean_Intel
Employee
1,423 Views

Hello mm2021,


Thank you for your response.


As the issue is present in the Linux Operating System environment, we recommend contacting the Linux* Operating System Vendors for further recommendations.


Best regards,

Jean O. 

Intel Customer Support Technician


0 Kudos
Reply