Showing results for 
Search instead for 
Did you mean: 

Max resolution is 2560x1440 instead of 4k (UHD630)

Hi there,

I just bought a new PC (components are listed below) and connected it to my Samsung U28D590 (28" 3840x2160) using DP1.2 but the maximum resolution I can set is 2560x1440.

The latest drivers for all components are installed and I also tried different cables (all DP) but it won't let me change the resolution to the screen's native resolution.

Intel i5 8400

AsRock Z370M-ITX/ac

16 GB DDR4 @2666

Samsung SSD 960 EVO 250GB M.2

I'm looking forward to your replies.


Tags (2)
0 Kudos
2 Replies
Community Manager

Hello, raikur.



Thank you very much for contacting the Intel® Communities Team.



I understand you are having some problems with the resolution of your SAMSUNG* display which is not allowing you to go further than 2560x1440. Allow me to help you regarding this issue you are facing.



In order to help you better, I would like to gather more information about the configuration you have on the computer. Please attach to this thread the TXT file the Intel® System Support Utility will generate:



To attach a file, you must click the "Attach" option on the bottom right-hand corner of the response box.



Then, I would like to have an Intel® Graphics Report. In order to attach this report please follow the steps listed in this link:



Please make sure that when you run the report your computer is connected to your SAMSUNG* display.




Antony S.

Hey Antony,

thanks for your quick reply.

After testing some other displays I am sure that this Samsung display is broken somehow.

I tested with a few other Samsung displays of that model and all others are working fine.

This thread can be closed as my problem is solved now.

Thank you anyway for your help!