Graphics
Intel® graphics drivers and software, compatibility, troubleshooting, performance and optimization
17793 Discussions

Maximum resolution not being detected (Linux driver i915 and Intel Iris Plus Graphics G1)

mbn12
Beginner
2,472 Views


Hi all,

My Lenovo S145 with a Intel Iris Plus Graphics G1 GPU is not detecting the maximum resolution (2560x1080) of an LG Ultrawide monitor 29WK500/50S in a Gnome/Wayland session, but works in a X11 (I can manually add and set with xrandr).

Strangely, the same SO/Gnome/Wayland/Kernel Driver and Monitor fully works even in Gnome/Wayland, when only the GPU is changed (even same driver). Maybe a driver issue with a particular hardware?


- **I'd like to ask for help to correctly fix the resolution in a wayland session (only in X11 with xrandr)**
- **and to track down the issue (for learning purposes).**

 

I am posting here because the exact same software stack (SO/Gnome/Wayland/driver) and monitor works fine when the GPU is a Intel HD Graphics 520] [8086:1916]. It seems a particularity of this GPU hw.


How reproducible:
May be specific to my hardware (Lenovo Ideapad S145 / Intel Iris Plus Graphics G1).
Not related to monitor or HDMI cable (works fine in a gnome X11 session)

Steps to Reproduce:
1. Start gnome wayland session
2. Start control-center, display settings
3. Only presented resolution choice is maximum resolution of 1920x1080

Expected results:
Existing entry of 2560x1080@60 resolution and possibility to change.

Graphics adapter:
Intel Corporation Iris Plus Graphics G1 (Ice Lake) [8086:8a56] (rev 07)
Intel Core i5-1035G1
(desired resolution is supported by GPU / HDMI output - https://ark.intel.com/content/www/us/en/ark/products/196603/intel-core-i5-1035g1-processor-6m-cache-...)
```
00:02.0 VGA compatible controller [0300]: Intel Corporation Iris Plus Graphics G1 (Ice Lake) [8086:8a56] (rev 07)
Subsystem: Lenovo Device [17aa:3fdc]
Kernel driver in use: i915
Kernel modules: i915
```


OS:
Fedora 32 - 5.8.10-200.fc32.x86_64, up to date

Notebook:
Lenovo Ideapad S145


Monitor: LG Ultrawide 29WK500/50S (max res: 2560x1080)
Decoded edid reports the desired resolution:
```
DTD 4: 2560x1080 74.991 Hz 64:27 83.915 kHz 228.250 MHz (798 mm x 334 mm)
Hfront 48 Hsync 32 Hback 80 Hpol P
Vfront 3 Vsync 10 Vback 26 Vpol N
```

Full logs:
https://drive.google.com/drive/folders/1bGTums4cASLzIQNgc6xB9bLyi6hKksli?usp=sharing

 

Strangely, the same OS, monitor, cable, gnome/wayland and even kernel driver works fine. When connected to another noteboot the 2560x1080 resolution is detected just fine by gnome/wayland.
```
00:02.0 VGA compatible controller [0300]: Intel Corporation Skylake GT2 [HD Graphics 520] [8086:1916] (rev 07)
Subsystem: Acer Incorporated [ALI] Device [1025:100c]
Kernel driver in use: i915
Kernel modules: i915
```

- EDID reading was exact the same in both notebooks (one works just fine).


Solutions already tried:
Boot parameters in grub (individually):
```
video=XWAYLAND1:2560x1080@60
video=HDMI-1:2560x1080@60
i915.enable_guc=-1
nomodeset i915.modeset=0
```

Multiple xrandr solutions, adding modes, etc -- which are supposedly no to work anyway, since xrandr can't control wayland (?).
When logging in gnome using a X11 session I can manually add the mode and set it using xrandr (but the goal is to fix the wayland session).

- Issue also exist in newer Fedora 33 with gnome 3.38.

Possibly related issues:
https://ask.fedoraproject.org/t/fedora-31-workstation-gnome-wayland-low-display-resolution/5342
https://ask.fedoraproject.org/t/why-fedora-31-doesnt-support-higher-than-1024-768-resolution/4110
https://ask.fedoraproject.org/t/why-fedora-31-doesnt-support-higher-than-1024-768-resolution/4110/2
https://ask.fedoraproject.org/t/intel-advisory-drivers-above-version-5-0-should-be-installed/1378
https://ask.fedoraproject.org/t/custom-screen-resolution-problem/5113/2
https://ask.fedoraproject.org/t/wrong-monitor-resolution-detected/7656
https://bugs.launchpad.net/ubuntu/+source/mutter/+bug/1826316
https://gitlab.gnome.org/GNOME/mutter/-/issues/574
https://superuser.com/questions/1137574/manually-add-a-resolution-to-gnome-with-wayland
https://bugzilla.redhat.com/show_bug.cgi?id=1134885#c11
https://devopsx.com/change-resolution-from-command-line-in-ubuntu-18-04s-wayland/
https://unix.stackexchange.com/questions/275327/configure-gnome-wayland-display-configuration-from-c...


- Any other hardware than the GPU, HDMI cable or monitor could have any influence?
ie. some motherboard controller, BIOS/UEFI, etc... that could impact the correct detection?

Thank you in advance for any help,

Mario

 

0 Kudos
3 Replies
Sebastian_M_Intel
Moderator
2,424 Views

Hello mbn12, 

 

Thank you for posting on the Intel® communities.   

 

I would like to let you know that Intel® does not provide direct downloads and technical support for Linux drivers. The Intel Graphics Linux driver is primarily supported through the original equipment manufacturer (OEM), or the Linux* distribution vendor.  You might also want to visit the Intel Open Source Technology Center at https://01.org/linuxgraphics. Have you tried checking this website?  

 

You might also want to check with Lenovo* to see whether they have any information regarding Linux compatibility with this specific information.  

 

For more information, see the Drivers for Linux document for more details. 

 

Regards, 

 

Sebastian M  

Intel Customer Support Technician  


Sebastian_M_Intel
Moderator
2,407 Views

Hello mbn12, 

 

Were you able to check the previous post and follow our recommendations? Please let me know if you need more assistance.   


Additionally, I will highly recommend you to contact your OS Vendor for peer assistance on this: https://www.intel.com/content/www/us/en/support/topics/linux-osv.html


Regards, 

 

Sebastian M 

Intel Customer Support Technician  


Sebastian_M_Intel
Moderator
2,378 Views

Hello mbn12,  

  

We have not heard back from you, so we will close this inquiry. Please remember to check with your OEM, the Linux* distribution vendor, or visit the Intel Open Source Technology Center for further assistance. 


If you have additional questions, please create a new thread and we will gladly assist you.  

 

Regards,  

  

Sebastian M  

Intel Customer Support Technician  


Reply