Graphics
Intel® graphics drivers and software, compatibility, troubleshooting, performance, and optimization
20853 Discussions

Microsoft's Enhanced Video Renderer not working with Intel UHD Graphics 770

RamashankarAgrahari
12,564 Views

Hi,

I have a pc whose configurations are:

  • CPU: 12th Gen Intel® Core™ i5-12500T
  • Graphics: Intel® UHD Graphics 770 (driver 30.0.101.1371)
  • OS: Windows 10 Enterprise LTSC Version 1809 (Build 17763.4131)
  • SSU report is also attached for other details.

In this environment, when I use some of our product's applications, which uses Microsoft's EVR(Enhance Video Renderer) for video rendering, then they are not working properly. I have a doubt on intel graphics driver because if I rollback this driver and move to Microsoft basic display adapter then these apps starts working fine.

 

This issue can also be simulated by using Microsoft's GraphEdit or GraphStudio tool.

Steps: Insert a 'file source' filter and EVR filter. Render the file source. It does not get connected with EVR, even if I force to connect manually.

But If I rollback to Microsoft Basic Display Driver then EVR is able to connect and work properly  

I am suspecting that raw video format required for rendering is not supported by EVR due to intel graphics driver. I also upgraded the intel Graphics driver manually with latest version (gfx_win_101.4311) but issue still persist.

Note: I have another pc with same OS (Windows 10 Enterprise LTSC Version 1809 (Build 17763.4131)) and having CPU: Intel® Core™ i3-8100 CPU @ 3.60 GHz, Graphics: Intel® UHD Graphics 630 (driver 26.20.100.7158). EVR is working properly on that pc. So it also eliminates any doubt over windows LTSC OS version.

~ Thanks.

0 Kudos
23 Replies
Jocelyn_Intel
Employee
10,628 Views

Hello, @RamashankarAgrahari  

 

Thank you for posting on the Intel® communities.  

 

I am sorry to hear what is happening with your Intel® UHD Graphics 770, I will gladly assist you here. 

 

Please, answer these questions to have a better perspective of this issue and try the following steps: 

 

  1. How do the applications fail? Please describe in more detail how the apps are not working properly (crashes, freezes, artifacts, etc.). 
  2. What are the apps that you have issues with? 
  3. Update your graphics driver to the latest version (31.0.101.4369).  
  4. Update your BIOS to the latest version (2402)
  5. Make sure to have the latest version (21H2) and latest build (19044.2965) of Windows 10 Enterprise LTSC as per Microsoft's website. 

 

Best regards,  

Jocelyn M.   

Intel Customer Support Technician. 


0 Kudos
RamashankarAgrahari
10,585 Views

 Hi Jocelyn,

Please find response to your query as following:

1. One of app in our product use EVR as default renderer. So on this PC, when I initialize it using EVR it fails. So, to identify whether issue is in our app or in EVR, I checked with a simple File Source filter in GraphStudio & GraphEdit tool and play any media file using EVR. It failed there too. So I concluded that EVR is not working on this PC.

2. Any app which use EVR is not working.

3. I updated the graphics driver with 31.0.101.4369 version. Issue remains same.

4.  I updated to BIOS also to 2402, but issue still persist.

5. I cant update the OS to 21H2 right now due to the product requirement. But As I find my other PC with same LTSC 1809 version working fine, so I think OS is not the issue here.

Unfortunately the only case where it works is to remove intel driver and use Microsoft basic display adapter on this pc.

Thanks,

0 Kudos
Jocelyn_Intel
Employee
10,565 Views

Hello, @RamashankarAgrahari  

 

Thank you for the information provided, however, we need more details about the issue you are describing. 

 

Just to confirm, the apps you mentioned that also have issues with EVR are GraphStudio & GraphEdit? We need the name of the app or apps that you detected the issue in the first instance to investigate this issue properly. 

 

You mentioned that it fails, but how does it fail? Does it give you an error? What is the error

 

Could you please send us a video showing the issue you are describing to understand better? 

 

Also, please attach a new Intel® SSU report to investigate further. 

 

Best regards,  

Jocelyn M.   

Intel Customer Support Technician. 


0 Kudos
Jocelyn_Intel
Employee
10,528 Views

Hello, @RamashankarAgrahari  

 

We are checking this thread and we would like to know if you were able to review our previous post. If you need further assistance, please do not hesitate to contact us back. 

 

Best regards,  

Jocelyn M.   

Intel Customer Support Technician. 


0 Kudos
RamashankarAgrahari
10,510 Views

Hi @Jocelyn_Intel,

Sorry, I was out of office so could not reply you earlier.

 

I am facing issue in my product app which uses EVR. As I cant share that exact app so I used GraphStudio & GraphEdit tool to simulate that error.

In  GraphStudio/GraphEdit tool, I insert either a Video File Source filter or a Camera capture filter. Then add EVR filter. Then I try to connect them manually, it gives a connection error:

    HRESULT: 0x80040217 (2147746327)

    Name: VFW_E_CANNOT_CONNECT

    Description: No combination of intermediate filters could be found to make the connection.

    Severity code: Failed

    Facility Code: FACILITY_ITF (4)

    Error Code: 0x0217 (535)

And if I uninstall intel graphics driver from this pc then these two filter gets connected successfully.

I will share a video of this issue from that pc in next week, by Monday. 

Meanwhile you can check the attached image, just for filter connection reference, from another pc which works fine.

Thanks. 

0 Kudos
Jocelyn_Intel
Employee
10,474 Views

Hello, @RamashankarAgrahari  

 

Thank you for the information provided. 

 

Please attach the video, if possible, and a new Intel® SSU report to investigate further. 

 

Note: Make sure to mark the box that says "everything" before pressing the Scan button. After that, click on "Next>" and select "Save" and then, attach the .txt file. 

 

Best regards,  

Jocelyn M.   

Intel Customer Support Technician. 


0 Kudos
RamashankarAgrahari
10,449 Views

Hi @Jocelyn_Intel,

Please find attached the latest SSU report for this pc.

I am also attaching following two video files for the case when I try to use EVR filter in Graphedit tool to render a local media file.  

1. 1_Issue_With_Intel-Driver.mp4:

It is the case where latest intel driver is installed. First it doesn't choose EVR in automatic connection, second if I try to connect EVR manually it gives error. 

2. 2_Ok_Without_Intel-Driver.mp4: It is the case where intel driver is uninstalled and rollback to Microsoft basic display adapter. 

It automatically chooses EVR if already inserted in graph. Even if I connect it manually, it gets connected.

 

Let me know if any other details are required for this issue.

Thanks.

0 Kudos
Jocelyn_Intel
Employee
10,441 Views

Hello, @RamashankarAgrahari  

 

Thank you very much for the report and videos attached. 

 

Now that we have this important information, I will proceed to investigate this issue.  

 

As soon as I have updates or recommendations, I will post them here. 

 

Best regards,  

Jocelyn M.   

Intel Customer Support Technician. 


0 Kudos
RamashankarAgrahari
10,405 Views

Thanks @Jocelyn_Intel .

Will wait for your updates on this issue as it is becoming critical for our product. 

0 Kudos
Jocelyn_Intel
Employee
10,389 Views

Hello, @RamashankarAgrahari  

 

Thank you for your time, we will do the best we can to help you. 

 

We understand that you need to use an older version and build for Windows 10 Enterprise LTSC, however, as part of the troubleshooting and for us to replicate this issue, we will use the latest OS version build (19044.29.65) and version (21H2)

 

Can you try to test the latest OS build and version to see if the issue persists? 

 

Best regards,  

Jocelyn M.   

Intel Customer Support Technician. 


0 Kudos
RamashankarAgrahari
10,362 Views

Hi @Jocelyn_Intel ,

Though it is tough for us to check on Windows10 LTSC 21H2 OS, but still I will try to check it in next week.

 

Meanwhile, I observed one more thing on this pc which could be an important info.

While debugging EVR issue further, I came across a tool called DXVA Checker (https://bluesky-soft.com/en/DXVAChecker.html) which tells you about DXVA support.

This tool is showing NO SUPPORT for DXVA on this i5-12th Gen pc when intel driver is installed, and shows software version support when intel driver is uninstalled. Refer images: i5-12Gen_Intel_DXVA_Issue_1.png, i5-12Gen_Intel_DXVA_Issue_2.png, i5-12Gen_Microsoft_DXVA_OK_1.png, i5-12Gen_Microsoft_DXVA_OK_2.png

 

Then, I used this tool on my other pc also which works fine for EVR scenarios. This pc has same Windows10 LTSC 2019 OS version installed, but CPU is Intel® Core™ i3-8100 CPU  and GPU is UHD Graphics 630 GPU.  Here this tool is showing full support of DXVA with intel driver too. Refer images: i3-8Gen_DXVA_OK_1.png, i3-8Gen_DXVA_OK_2.png.

 

With this observation, I believe this DXVA support has something to do with EVR issue.

As I am not aware of whose responsibility is to support DXVA on pc, whether it is OS or intel GPU hardware or intel graphics driver, so can you clarify this? Since same OS is working fine with other intel CPU/GPU hardware so I don't have doubt on OS.  

Do I need to install any thing more (any OS component/modules or intel software/driver) on this pc to fix this issue?
Thanks.

0 Kudos
Jocelyn_Intel
Employee
10,288 Views

Hello, @RamashankarAgrahari  

 

Thank you for the information provided, but we still need to try the latest OS version and build as part of the normal troubleshooting (updating everything to the latest version), DXVA is actually a Microsoft API. 

 

Please let us know the results and if the issue persists, please provide us with a new Intel® SSU report to investigate further. 

 

Best regards,  

Jocelyn M.   

Intel Customer Support Technician. 


0 Kudos
RamashankarAgrahari
10,185 Views

Hi @Jocelyn_Intel ,

 

I did check the case today with latest OS (Windows 10 LTSC 21H2). Issue behavior seems improved, but not fixed fully.

It started working fine for one case (playing any local media file using EVR, refer image 1), but still not working for another case (playing local camera stream using EVR, refer image 2). It works with Video Renderer only (refer image 3).

I am attaching latest SSU report, along with DXVA checker report too. DXVA tool says that it started supporting DXVA for some media types but still unsupported for many others. Refer the image 4, 5.

Please check.

 

Further, I am still worried for its proper support on Windows 10 LTSC 2019 itself as that is the required OS for our product and we cannot upgrade that so easily or in near future. 

So we are more concerned on why Windows 10 2019 LTSC works fine with  Intel® Core™ i3-8100 (UHD Graphics 630), but not with Intel® Core™ i5-12500T (UHD Graphics 770).

 

Thanks.

0 Kudos
Jocelyn_Intel
Employee
10,125 Views

Hello, @RamashankarAgrahari  

 

Thank you for the information provided and for testing it out. 

 

We will proceed to investigate more about this, I appreciate your diagnostics about this too. 

 

As soon as I get any recommendations or updates, I will post them here. 

 

Best regards,  

Jocelyn M.   

Intel Customer Support Technician. 


0 Kudos
Jocelyn_Intel
Employee
9,536 Views

Hello, @RamashankarAgrahari  

 

Thank you for your time. 

 

Can you tell us what codecs (standalone) or codecs pack are installed on your PC? 

Is there anything specific configured or are there any special requirements? 

 

We have done some tests with and without klite-codec pack and we have some problems reproducing this issue. Can you please provide us with the information above?

 

Best regards,  

Jocelyn M.   

Intel Customer Support Technician. 


0 Kudos
Jocelyn_Intel
Employee
9,444 Views

Hello, @RamashankarAgrahari  

 

We hope you are great.


We are checking this thread and we would like to know if you were able to review our previous post. If you need further assistance, please do not hesitate to contact us back. 

 

Best regards,  

Jocelyn M.   

Intel Customer Support Technician. 


0 Kudos
RamashankarAgrahari
9,340 Views

Hi @Jocelyn_Intel ,

Yes, I could check your post but could not reply earlier.

 

>> Can you tell us what codecs (standalone) or codecs pack are installed on your PC? 

I installed a third party Multimedia codec pack (specific to our products requirement).

It is the same codec pack and version which works well on another PC ( Windows 10 2019 LTSC having Intel® Core™ i3-8100 (UHD Graphics 630)).

 

 

>> We have done some tests with and without klite-codec pack and we have some problems reproducing this issue

So is it working fine with klite-codec pack?

What OS version you are using?

 

Thanks.

0 Kudos
Jocelyn_Intel
Employee
9,311 Views

Hello, @RamashankarAgrahari  

 

Thank you for your reply. 

 

In that case, please specify the third party Multimedia codec pack so our team can reproduce your issue properly, since we had problems trying to see your issue with and without klite-codec pack. 

 

Best regards,  

Jocelyn M.   

Intel Customer Support Technician. 


0 Kudos
RamashankarAgrahari
9,232 Views

Hi @Jocelyn_Intel 

 

As this third party multimedia codec pack is a propriety, I had asked our approving authority if I can share that with you or not. Waiting for their approval.

 

Meanwhile, as you mentioned your team is unable to reproduce this issue, so may I know the following:
1. On which OS version you are trying it?

2. What processor and Graphics card and driver you are using?

 

I will also try out at my end by using klite-codec pack.

 

Thanks.

0 Kudos
Jocelyn_Intel
Employee
9,169 Views

Hello, @RamashankarAgrahari  

 

Thank you for your reply. 

 

I understand that you want to know this information, however, we need to know and inform our team since they require the codec pack to try to reproduce this issue properly, so they can give us all the details after all the information is gathered to them. 

 

We really appreciate your help in getting the codec pack, if it is too private information, we can send an email linked to the e-mail address associated with your community profile or you can send it to me via DM in the Community Messages so you can more comfortable. 

 

Best regards,  

Jocelyn M.   

Intel Customer Support Technician. 


0 Kudos
Reply