Graphics
Intel® graphics drivers and software, compatibility, troubleshooting, performance and optimization
17454 Discussions

OpenGL not working on installing latest DCH drivers in Intel HD Graphics 620.

rahulv4667
Beginner
548 Views

Hi, I have recently started trying my hand at GPU related computing with OpenGL and SYCL. For SYCL, I tried to install OneAPI base toolkit. It prompted me to update the graphics drivers(I dont remember the exact reason). I did update them using DCH drivers since there were no updates from laptop manufacturer(Dell). But, after updating, my OpenGL programs(running OpenGL 3.3) stopped working. GLFW couldn't create OpenGL context error was being thrown. On graphics command center, no information related to OpenGL was specified although Vulkan and Direct info was there. When I checked OpenGL version using GLextensions viewer, it showed OpenGL 1.1, which according to my is the most basic version shipped which interoperates with Direct3d. I thought there was some problem with installation and redid the installation. The problem persisted. I even rest my PC. But still it persists. Also, the screen is getting stuck for 2-5 seconds when there is a huge render task(eg: Facebook Web). This issue wasn't there when I had my old manufaturer drivers. But I am not sure if this has anything to do with no OpenGL problem.

 

Now, I tried to look in to the Graphics folder of driver zip file and found that there are no dlls related to OpenGL while there are dlls for Vulkan and OpenCL. So, I needed to know how to get latest OpenGL(or whatever my HD Graphics 620 graphics card ideally supports) running on my system while also being able to use OneAPI toolkit without having to downgrade to manufacturers driver(which shows last update in Dec 2017).  I am using Windows 10 by the way.

 

I will be happy to provide more information if required.

0 Kudos
2 Replies
Stefan3D
Honored Contributor II
523 Views

"When I checked OpenGL version using GLextensions viewer, it showed OpenGL 1.1"

 

Usually that means, the Microsoft Basic display driver is active.

Check device manager for the notorious code 43

 

The runtimes are named

ig9icd32.dll
ig9icd64.dll
ig11icd32.dll
ig11icd64.dll

 

rahulv4667
Beginner
510 Views

Ok. So, interesting things happened.

 

The device manager doesn't show any error in device status. It is displaying the usual 'This device is working properly'. But when I went through the events list, I found that there is an event 'device not started(igfx)' after installing the new drivers. I am pasting the full event information below:

 

 

Device PCI\VEN_8086&DEV_5916&SUBSYS_078B1028&REV_02\3&11583659&0&10 had a problem starting.

Driver Name: oem61.inf
Class Guid: {4d36e968-e325-11ce-bfc1-08002be10318}
Service: igfx
Lower Filters:
Upper Filters:
Problem: 0x15
Problem Status: 0x0

 

But this was resolved when tried to uninstall and reinstall as shown in the code 43 link. Yet, the OpenGL problem isn't resolved. Rolling back works. But again the initial problem of oneapi needing updated drivers would have persisted.

 

What I did as an experiment was to uninstall the device(as given in link) but along with deleting the device drivers. When I looked for hardware changes(as said in the link), the system didn't find the device back(don't know if it should have). So, when I restarted the system, initially the integrated card was displayed as  'video controller(vga compatible)'. I decided to install the old manufacturer's driver but just before I could start installing, the drivers got updated and 27.20.100.8854 drivers were installed. I am not sure how those version of drivers were available because the newer DCH versions that I downloaded were 27.20.100.9313 and 27.20.100.9466 and the old version was 22 something. My internet connection was on. So, I am suspecting that. Anyway, the good news is the problem is resolved. This set of drivers seems to run both my OpenGL code and install OneAPI toolkit just fine. 

 

The changes I found in the latest install event log was that after 'device service added(igfx)', there were three more services added(cphs, cplspcon, igfxCUIService2.0.0.0). There was no mention of starting problem.

 

Regarding the runtimes, I had ig9icd32.dll and ig9icd64.dll on all the drivers. I didn't find any change in this. 

 

I am unable to see the 'close thread' button anywhere. Please let me know if I have to do something to close this discussion.

Reply